WordPress.org

Ready to get started?Download WordPress

Forums

WP-o-Matic - Please switch to Firefox / Safari (8 posts)

  1. mattw21
    Member
    Posted 4 years ago #

    I set up a new blog (http://ezpromo.ezgo-now.com) and installed the plug-in WP-o-Matic. After I activated it and tried to set it up I get a new window that states, (Please switch to Firefox / Safari) After some re-installs & trouble shooting I installed the (SimplePie Core) plug-in. Well I get the exact same results with that.(Please switch to Firefox / Safari) I am sure I'm over looking the obvious but need help just the same. Both of my WP 2.61 blogs are installed on sub-directories of (ezgo-now.com)which is where the WP data base is. This has never caused any problems for in the past.

    My site is http://ezpromo.ezgo-now.com/
    & I am using:
    Windows XP
    Internet explorer 7
    WP 2.6.1
    Panorama 1.9 Theme

    I also tried this at my other WP blog (http://ezmoney.ezgo-now.com/)with the Amazing Grace theme & got the same results.

    Thanking you in advance,
    Matt
    mattw21@verizon.net

  2. Not sure what the problem you are having exactly is but a couple of things:

    1. Don't use WordPress 2.6.3. Seriously don't. You have an empty blog so you don't have any reason not to. Unless you want to hand over your blog to "bad people" stick with the current version 2.8.4.

    2. This is a support forum so you are probably in the right place. But unless you are soliciting for paid help, putting an e-mail address is a DIAW thing to do.

    So what are you trying to do? If it's popup a window or warning saying "Internet Explorer is EVIL" just edit your theme index.php to add right below get_header() a conditional in the HTML like so:

    <?php get_header(); ?>
    <!--[if IE]>
    <h3>OI! Internet Explorer BAD!</h3>
    <![endif]-->

    Replace the <h3>OI! Internet Explorer BAD!</h3> with whatever.

  3. selmicro
    Member
    Posted 4 years ago #

    Not much help, if that was your intent. Sounds more like you are telling him how to screw with users instead of honestly addressing the issue...

    I too have just tried to install WP-o-matic and when I run the setup all I get is the same message "use firefox or safari" making the plugin totally useless since I cannot get by it even if I do start firefox up...

    So at this point my only recourse is to write up a very negative review of WP-O-Matic itself as well as a very negative review of the WP-O-Matic support forums. I can't image that anyone is will to accept but a single smart ass comment in 4 days when they are seriously trying to solve a problem.

    Sorry, but poor help is worse than no help if for no other reason than it causes good people to waste even more time on an apparetly poor and unsupported product.

  4. Not much help, if that was your intent. Sounds more like you are telling him how to screw with users instead of honestly addressing the issue...

    I was actually trying to find out what he was talking about as I don't use that plugin. Tonight I'll download that plugin if only to satisfy my curiosity.

    Now do you actually have something to contribute or do you just like to complain about other people's effort?

    Sorry, but poor help is worse than no help if for no other reason than it causes good people to waste even more time on an apparetly poor and unsupported product.

    So true. You should seek a refund; this is no way to treat a customer.

  5. Well that was a short trip and I know what mattw21 is talking about.

    1. Download http://downloads.wordpress.org/plugin/wp-o-matic.1.0RC4.zip from the http://wordpress.org/extend/plugins/wp-o-matic/ page.

    2. Using your favorite text editor edit the file

    wp-o-matic/wpomatic.php

    Go to line 1079 and comment out the two lines from this

    if (isset($_SERVER['HTTP_USER_AGENT']) && (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== false))
          die('Please switch to Firefox / Safari');

    to this

    // if (isset($_SERVER['HTTP_USER_AGENT']) && (strpos($_SERVER['HTTP_USER_AGENT'], 'MSIE') !== false))
        //  die('Please switch to Firefox / Safari');

    That will take out the Firefox / Safari test. I tried it in Internet Explorer 8 and AFAIK it works fine.

    I won't hold my breath, but you're welcome.

  6. mattw21
    Member
    Posted 4 years ago #

    Thanks very much. I kinda got off onto another project & forgot about this one. I'll follow the advice & try the suggestions since it still needs done. It's kinda funny but the driving force behind starting this 2nd blog was to get a clean, safe install for WP 2.8. However when I tried to open & install it I would come to a dead end because I already had 2.6 installed. By the time I finally discovered just what needed done (I felt like an idiot it was such a quick & simple fix) I had already gone back to 2.6. I will for sure move to 2.8 now that I know how.

  7. jvazjr
    Member
    Posted 4 years ago #

    @mattw21

    i am having the same problem

    can you help?

  8. jvazjr
    Member
    Posted 4 years ago #

    nevermind

    i figured it out

Topic Closed

This topic has been closed to new replies.

About this Topic