WordPress.org

Ready to get started?Download WordPress

Forums

WP-o-Matic
wp-o-matic not auto fetching (13 posts)

  1. lvalesko
    Member
    Posted 3 years ago #

    Does a manual fetch just fine, but won't auto fetch every day as I have it set to!

  2. Mr E
    Member
    Posted 3 years ago #

    Did you properly set the cron on your web hosting?

    Also, Some hosts may wish to ignore the first segment of the cron command provided.

    If you did set a cron, I suggest you check with your hosting provider, inform them you have a cron job which needs confirmation and then give them the reference to the cron entry you made. They should be able to check the records and confirm the settings on the hosting side are correct.

  3. lvalesko
    Member
    Posted 3 years ago #

    I didn't know I had to set up anything else outside of installing the plug in and configuring it within WP.

    Can you point my in the direction of finding out how to do a Cron job?

    I am not a programmer type but do have half a brain so with some direction I feel confident I can do whatever needs to be done... as long as you don't have to be a programmer geek to do it!

    Thanks :-)

  4. Mr E
    Member
    Posted 3 years ago #

    Sorry for the late reply, I'd be happy to .. provided I know ;)

    Who is your hosting provider?

  5. Mr E
    Member
    Posted 3 years ago #

    Also, a semi-short over-view of the Cron & wp-o-matic is that the Cron is an 'activate' command the web hosting server sends to the script to tell the script "do your tasks". This is necessary on things that require annual actions (every 15 minutes, once a day, ect), the Cron setup on your hosting normally lets you set these times.

    As wp-o-matic is a fetching system (fetches posts from rss feeds) its life is to the tune of:
    'activate'
    fetch
    fetch
    fetch
    stop

    The Cron command supplements you sitting there hitting the 'activate' button all day long as it automates this very process for wp-o-matic to run autonomously.

    Please note: Cron Job's take away from server performance to some degree and this can impact your website performance. Do not take these words as saying its a serious problem, but its worth keeping in mind that making a dozen wp-o-matic tasks, then setting the Cron to run each minute, will probably impact your website load time / performance as it will stress the server your site is hosted on. Again, its not a critical type of note, but certainly worth keeping in mind.

  6. saltmanz
    Member
    Posted 3 years ago #

    I can't get the autofetch to work either. I had my hosting admin set up the cron job, which seemed to work: I can get WP-O-Matic to log "Running cron job" every hour. But no posts.

  7. Mr E
    Member
    Posted 3 years ago #

    @ saltmanz

    This may not at all be the problem, but its worth looking at...

    Different hosting providers sometimes snip the first segment(s) of the cron. I know with Godaddy a cron of

    */20 * * * * /usr/bin/curl http://example.com/wp-content/plugins/WP-o-Matic/cron.php?code=df12345

    will not work, however if its

    /usr/bin/curl http://example.com/wp-content/plugins/WP-o-Matic/cron.php?code=df12345

    it does work. You can sometimes get this answer from the hosting provider but you will probably have to wait out a call to tier two. Often google'n the hell out of this finds the answer.

  8. saltmanz
    Member
    Posted 3 years ago #

    I'm on Dreamhost, and according to the emails I get from the cron job, the cron is set up like this:

    /usr/local/bin/setlock -n /tmp/cronlock.935310.99590 sh -c $'/usr/bin/curl http72//www.saltmanz.com/blog/wp-content/plugins/wp-o-matic/cron.php77code750398ae23'‏

  9. saltmanz
    Member
    Posted 3 years ago #

    I eventually got it to work by going into the code and commenting out the part that checks for the last update; now it updates everytime the cron runs.

    Edit - What I did was replace this

    $campaigns = $this->getCampaigns('unparsed=1');

    with this

    $campaigns = $this->getCampaigns();

    I also made it so it always uses the dates from the feed, by commenting out a couple of lines here:

    // Item date
    //    if($campaign->feeddate && ($item->get_date('U') > (current_time('timestamp', 1) - $campaign->frequency) && $item->get_date('U') < current_time('timestamp', 1)))
          $date = $item->get_date('U');
    //    else
    //      $date = null;
  10. missp
    Member
    Posted 3 years ago #

    I am also having an issue with fetching. I have 16 campaigns (around 20 feeds) and every one fetches great except for 3 of them. I've double checked the feeds in a reader and they are being updated regularly. It seems WP-o-Matic is choking on these 3 feeds for some reason (although the log does show the fed/campaign was processed).

    I tried the hack above with no success. I also tried to delete the troublesome campaigns and start over from scratch with no success. Manual fetching does nothing.

    One problematic feed is: http://news.google.com/news?ned=us&topic=h&output=rss.

  11. Mr E
    Member
    Posted 3 years ago #

    missip,

    I've not run into this particular problem but it may be too many fetch actions being dispatched.

    Try removing a few of them and see if the problem persists. Also note, I am unsure if wp o matic needs specific RSS formats. To be honest I'm not well versed in that but I understand there are a few feed types, may give some direction...

  12. steve.mcnally
    Member
    Posted 2 years ago #

    I'm getting 500 errors in my access logs when the cron job goes:

    192.168.16.91 - - [17/Oct/2011:16:00:01 -0400] "GET /wp-content/plugins/wp-o-matic/cron.php?code=XXAAXXX HTTP/1.1" 500 - 1133

    The cron itself is firing, but the job's not working.

    Manual Fetch from the Campaigns panel works fine from a browser.
    But, using curl to fetch the same URL from the shell on the same machine throws an Apache 500.

    E.g.

    http://mydomain.com/mysite/options-general.php?page=wpomatic.php&s=forcefetch&id=1&_wpnonce=XAXXXXAA

    This is on a self-hosted machine. It's a multi-site install. Cron itself works.

  13. steve.mcnally
    Member
    Posted 2 years ago #

    using wget vs curl for the manual get from shell,
    I see I'm getting redirected through wp-login, and then getting permission denied.

    e.g.

    wp-login.php?redirect_to=http:%2F%2Fmydomain%2Fmysite%2Fwp-admin%2Foptions-general.php?page=wpomatic.php&reauth=1: Permission denied

    Is the cron job supposed to have to authenticate first?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags