WordPress.org

Ready to get started?Download WordPress

Forums

WP needs db repairing when creating network (30 posts)

  1. massayoshi
    Member
    Posted 4 years ago #

    Using 3.0 beta
    I followed this guide: http://codex.wordpress.org/User:Andrea/Create_A_Network

    And at the end it says "...refresh your dashboard. You will now see a new menu section called Super Admin.". But when I refreshed I got this error "One or more database tables are unavailable. The database may need to be repaired." and then I found out that if I comment the line "define('VHOST', 'yes');" it goes back to normal. Without the Network.

    My config.php

    /** MULTI USER! */
    define('WP_ALLOW_MULTISITE', true);
    define('VHOST', 'yes');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'my.domain.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    define('WP_ALLOW_REPAIR', true);
  2. massayoshi
    Member
    Posted 4 years ago #

    Just one small correction, VHOST was set to NO. I changed to see if it would work. It didn't.

  3. The VHOST setting is used to determine if you picked a subfolder (no) or a subdomain (yes) url structure for new sites.

    VHOST = virtual subdomains.

    you will probably need to check some settings and run the network install again. And please go to wherever you manage your database and see if it actually added any new tables.

    things to look for that WPMU was picky about that may have changed:
    - does the db user have ALL permissions on the db?
    - is the db user's password 6 characters or more (I know...)

  4. massayoshi
    Member
    Posted 4 years ago #

    Yeah I know about the vhost. I just pointed it out because this was causing the WP to "crash".

    The db user's pass has more than 6 chars and 2 tables were created I believe. wp_blogs and wp_blog_versions. Should've been more? And from what I know the db user can't use drop.

    Thanks

  5. massayoshi
    Member
    Posted 4 years ago #

    I'm an idiot. I forgot to add the first line on the config.php
    define( 'MULTISITE', true );

    When I read it I thought it was the same as "define('WP_ALLOW_MULTISITE', true);" so I skipped.

    I'm on Super Admin!

    Thanks for your help!

  6. massayoshi
    Member
    Posted 4 years ago #

    One last question, is it possible to allow a user to post just under one category?

  7. pswheeler
    Member
    Posted 4 years ago #

    I tried to set up multi. And i have had no luck. Went to the same place as you but i guess it is missing infor for me.. Is there a way I could see a full copy of your config file with dp and pas info removed.

  8. pswheeler
    Member
    Posted 4 years ago #

    I keep getting data base errors. I used what you have posted. not sure what i am doing wrong yet..

  9. pswheeler - put define( 'MULTISITE', true ); in your config file FIRST.

    Then go visit the Network menu.

    "is it possible to allow a user to post just under one category? "

    Same as it would be for if it were just a single WP blog.

  10. pswheeler
    Member
    Posted 4 years ago #

    this is what i got in the config file.

    define( 'MULTISITE', true );
    define('WP_ALLOW_MULTISITE', true);
    define('VHOST', 'no');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'gottabmine.com');
    define('PATH_CURRENT_SITE', '/');
    define('SITE_ID_CURRENT_SITE', 1);
    define('BLOG_ID_CURRENT_SITE', 1);
    define('WP_ALLOW_REPAIR', true);

    i did a fresh install and i get this error now.

    Parse error: syntax error, unexpected T_STRING in /home/wheeler3/public_html/blog/wp-config.php on line 4

    These are the first lines in the config file right after @package wordpress.

  11. take them out.

    do not put them in when you are installing.

    Get WP installed & running first.

    then edit your config file again and place this one line in there:

    define( 'MULTISITE', true );

    Then go visit the Network menu item under Tools. Follow those directions.

    Can you confirm you did that?

  12. pswheeler
    Member
    Posted 4 years ago #

    i was running. now i get can not concet to db.

  13. pswheeler
    Member
    Posted 4 years ago #

    ok wordpress is up and running at http://www.gottabmine.com . the config file works. now i am ready to try for a 4th time lol.

  14. pswheeler
    Member
    Posted 4 years ago #

    ok i have it added just like this.

    * @package WordPress
    */
    define( 'MULTISITE', true );

    but i get a error. i will leave the error up on the site for people to see.

  15. massayoshi
    Member
    Posted 4 years ago #

    @pswheeler did you have any luck?

  16. pswheeler
    Member
    Posted 4 years ago #

    no.. not yet. hope to get it up soon. but break time. kids need to be taken to school.

  17. massayoshi
    Member
    Posted 4 years ago #

    Before install your config.php you should add just one line to it:

    define('WP_ALLOW_MULTISITE', true);

    Then you go to admin, Tools > Network, choose if you want the subblog as subdomains or subfolders, add the other lines to yout config.php and edit the .htaccess file.

    I chose to use subfolders and my config.php looks like this:

    /* WP MULTI USER */
    define('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'VHOST', 'no' );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'my.domain.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );
  18. It means you have a typo on line 2. :) Probably the single quotes are barfing if you just copied & pasted it off the screen here.

    (I gotta break for lunch. :) )

  19. pswheeler
    Member
    Posted 4 years ago #

    ok so i should i just type it in and not do a copy paste?

    as for the .htaccess file what should i edit in there?

    and now it crashed again time for reset again lol.

    and yes i do keep a config fiel from the install.. but for some reson after i change a copy it crashes.

  20. pswheeler
    Member
    Posted 4 years ago #

    ok if i have it this way

    /* WP MULTI USER */
    define('WP_ALLOW_MULTISITE', true);

    no errors but no super admin. but if i have it this way

    /* WP MULTI USER */
    define('WP_ALLOW_MULTISITE', true);
    define('MULTISITE', true );

    I get error.. Error is left up for people to see.

    Sorry for being a pain. I normally do not have any problems setting up and editing my wp sites.

  21. ok if i have it this way

    /* WP MULTI USER */
    define('WP_ALLOW_MULTISITE', true);

    no errors but no super admin.

    That line alone does not set up the Super Admin stuff. Please, just put in that line. Now go log in to your wordpress site. Visit the Tools menu item. See the thing called "Network"?

    Click it. Follow those steps. Do not edit the config file again ULESS it tells you.

    (it will, but you absolutely have to run the stuff under the Network area first.)

  22. pswheeler
    Member
    Posted 4 years ago #

    now i feel dumb.. I keeped loking for network in the wrong spot. That is why i could not get it to work. Hang me up to dry. Running network now. and got it running. going to hind my head in the sand now.

  23. massayoshi
    Member
    Posted 4 years ago #

    @pswheeler follow the instructions of my previous post. it's exactly what I did.

  24. pswheeler
    Member
    Posted 4 years ago #

    Just one mroe thing, Under general Settings you could set up the page look from http://gottabmine.com/blog to http://gottabmine.com But once network is install i can not seem to find it. Where did it move too?

  25. massayoshi
    Member
    Posted 4 years ago #

    You have to Edit your main website and change the "Permalink Structure".

  26. pswheeler
    Member
    Posted 4 years ago #

    i know that.. I just can not get to the Main websites Permalink area. Not sure why and it is strange. For some reson this seems harder then setting up wpmu.

  27. pswheeler
    Member
    Posted 4 years ago #

    I cheated.. I turned off Multi fixed it then turned it back on. It works like i want it to now.

  28. massayoshi
    Member
    Posted 4 years ago #

    From now on you should only edit your permalink when Editing your website. I think.

  29. brijith
    Member
    Posted 3 years ago #

    Hi,
    there is one query for me..Actually in config file I have placed the necessary code for MU..but in the url I get '/blog' which I dont want..for example http://www.abc.com/blog/category/postname and I don't want /blog in the url..want it to be http://www.abc.com/category/postname..I tried editing it in the custom structure of the permalink but there /blog is not editable..why it is so? what am I suppose to do change '/blog'

  30. You should really be posting this in the multisite forum, as this forum is for people TESTING the alpha and beta releases of WordPress.

    Here are directions on how to change that, and why you may NOT want to: http://code.ipstenu.org/switching-to-wordpress-multisite-breaks-links/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags