WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Multisite- Domain mapped pretty permalinks not working (5 posts)

  1. ntoqiakt
    Member
    Posted 2 years ago #

    Hi guys,

    I know that questions like this have been asked umpteen times, but I've been searching for a couple of days and haven't yet found where the problem is.

    I have a fresh WP Multisite install with subdomains. The only activated plugin is WP MU Domain Mapping (0.5.4.2).

    Home site and new sites on subdomains work as expected, ie, pretty permalinks working fine, images working, etc.

    However, on domain mapped sites, pretty permalinks don't work - only default permalinks - and images are broken even in the back end.

    I would appreciate your help.

    Regards,

    Theo

  2. Double check your .htaccess

    Make sure it's the subdomain one.

  3. ntoqiakt
    Member
    Posted 2 years ago #

    Hey Mikka,

    Thanks for your reply.

    My .htaccess (in the root of my home site) is the one that WP tells me I should have in the Settings/Network Setup, ie:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
  4. ntoqiakt
    Member
    Posted 2 years ago #

    Ok... after some more tinkering (read: stabbing in the dark!) I've cracked it!

    Just FYI, the whole set up is on a VPS running Debian 6.0.4 with Webmin/Virtualmin

    To set up the WP Multisite subdomains, I set the default site to the WP installation and to fix the problem with the pretty permalinks and images I had to comment out the AllowOverride None in the / and public_html directories.

    (actually, something similar was suggested among other things in a another thread)

    So, basically, I edited the /etc/apache2/sites-available/default to make the above changes and now it's working just fine!

    Perhaps I missed something in the instructions... but anyway, hopefully this might help someone else too!

  5. Heh. We actually tell you to set AllowOverride to All, but yes, messing with that will getcha. Most hosts have it set up 'right' to start with.

Topic Closed

This topic has been closed to new replies.

About this Topic