WordPress.org

Ready to get started?Download WordPress

Forums

WP-Members: Itunes responds with login error to every user (33 posts)

  1. mattperry1976
    Member
    Posted 2 years ago #

    Tim,

    I upgraded to the new beta 16 version and logged in with my testuser, logged back out, then tried to load premium feed and continue to get repeated login requests as in the original issue.

    As a side note, changing the log flag to TRUE in the /wp-content/plugins/podpress_options/pordpress_config.php had no effect in switching on the logging function, however I was able to temporarily change the flag to TRUE in the /wp-content/plugins/podpress/podpress.php to get the logging to work

    thanks again for all your help and hard work on this issue

    matt

  2. ntm
    Member
    Posted 2 years ago #

    @all: I have received the log file from Matt and we continued the communication via email. That is why I would like to give short summary.

    The log file showed that the variable $_SERVER['PHP_AUTH_DIGEST'] and $_SERVER['Authorization'] were not defined during the communication between the server and the browser.
    Further searching reviled that the server of Matts Blog is an Apache Server which did not run with modules modules mod_auth_basic and mod_auth_digest which are required for both encryption methods of the Premium Feature of podPress.

    (It is possible to control whether those two modules are active e.g. with the WP Plugin http://wordpress.org/extend/plugins/php-server-info/. The row "Loaded Modules" should include the names of both modules.)

    If the modules are not active podPress will show the login dialogue again and again (regardless of the username and password).

    I will add a control to the next version of podPress which will test whether these modules are available or not and will show a regarding message if one or both modules are not available.

    Tim

  3. ntm
    Member
    Posted 2 years ago #

    As indicated above the server on which Matts podcast is situated runs is an Apache server in the CGI Mode. If the server is running in this mode e.g. the variable $_SERVER['Authorization'] does not get transmitted.

    But today I learned (in the examples of this site) that there is a fix for this problem. Put the following line into the .htaccess file:

    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    This file gets generated by WordPress if activate a non-default Permalink scheme. If you have done this place this line between the other lines (below )

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    ...
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    </IfModule>
    # END WordPress

    Important is that file contains in a line above this new line the command:

    RewriteEngine On

    You can find the .htaccess file in the root folder of your WP blog. It is possible that this file is a hidden file. Some (FTP) programs don't show these file by default. But usually there is option which makes them visible.

    You may also try the Digest method. If the server offers it should work with all current web browsers.

Topic Closed

This topic has been closed to new replies.

About this Topic