WordPress.org

Ready to get started?Download WordPress

Forums

WP-Members - Activation resetting password, even with password field (4 posts)

  1. lechatlisse
    Member
    Posted 1 year ago #

    Hi there,

    Title says it all. I have approval system set up, I have created a password field with the following settings:
    Name Password
    Options password
    Both "Display" and "Required" checked.

    As a test I put the [password] field in both emails. The first email gets sent with the password the user entered. When I activate the user, the new email gets sent out with a random password, so it has been reset.

    This is proven by trying to log in: only the random generated password works...

    Chad, if you could help me out here, that would be amazing! Thanks.

  2. Chad Butler
    Member
    Posted 1 year ago #

    Take a look at the password field you created in the fields tab. Is the option name "password"?

  3. lechatlisse
    Member
    Posted 1 year ago #

    Indeed, as per original post, my option field value is "password"

    Thanks for your help.

  4. lechatlisse
    Member
    Posted 1 year ago #

    I uninstalled the plugin and started from scratch and the plugin exhibited exactly the same behavior. I'd be tempted to think this is a bug. Could you investigate?

    As I previously mentioned, I followed the Password field instructions to the tee.

    At present I have disabled the option to initially set a custom password as it does not seem to be functioning with the approval process. This is such a shame as it's pretty basic functionality.

    Could you let me know how you go Chad?

    Thanks in advance.

Topic Closed

This topic has been closed to new replies.

About this Topic