WordPress.org

Ready to get started?Download WordPress

Forums

WP-Member plugin error "Are you sure you want to do this?" (6 posts)

  1. Adwiz
    Member
    Posted 1 year ago #

    I've installed WP-Member and it was working fine earlier in the day. Now, whenever we try to register a user we see a blank screen with just one error message:

    Error: Are you sure you want to do this?
    Try again.

    I disabled all plugins except WP-Member and it still had the error. I deactivated and reactivated WP-Member. Still happens. We are running WP 3.5. I'm now completely stumped and would appreciate any help.

  2. Amadain
    Member
    Posted 1 year ago #

    Hi Adwiz, I notice you also posted this very same question on the Rocketgeek.com blog (who made the plugin)and after much toing and froing the matter was resolved.

    How it was resolved is not stated, which is frustrating.

    I would love to ask the question on Rocketgeek, but I have to pay $47 to do so.

    I have no objection to paying for plugins but to pay that amount to ask one question which may not be answered is not a sensible course of action.

  3. Adwiz
    Member
    Posted 1 year ago #

    It appeared to be a problem with the update itself. We updated the plugin from within WordPress, and it left some files unchanged. Chad Butler was able to identify the issue because he's familiar with the files and immediately noticed something wasn't right. He-installing the plugin from scratch which fixed the problem.

  4. Amadain
    Member
    Posted 1 year ago #

    Thanks Adwin

    I deleted and re-installed latest version, sadly has had no effect.

    I can only hope someone else out there has an answer.

  5. Adwiz
    Member
    Posted 1 year ago #

    Amadain, Chad is releasing a new version of wp-members next week which appears to have some significant changes. It might solve the problem. But in the meantime, here's a fix he asked me to try that you might be able to try. I couldn't do it because one of my files hadn't updated, which made part of the change impossible to attend to:

    In wp-members-register.php, line 48 currently is:

    check_admin_referer( 'wpmem-register' );

    Replace it with this:

    if( empty( $_POST ) || !wp_verify_nonce( $_POST['wpmem-form-submit'], 'wpmem-validate-submit' ) ) {
    $wpmem_themsg = __( 'There was an error validating the form.', 'wp-members' );
    return;
    }

    In wp-members-dialogs.php, line 333 is:

    wp_nonce_field( 'wpmem-register' ) . '

    Replace it with this:

    wp_nonce_field( 'wpmem-validate-submit', 'wpmem-form-submit' ) . '

  6. Jessica Estefane Karam
    Member
    Posted 1 year ago #

    What I did was to upload to my directory the 2.8.2 Version which is still beta from:
    <a href="http://wordpress.org/extend/plugins/wp-members/developers/
    ">
    the problem was fixed as this new version seems to have taken care of the glitch.

Topic Closed

This topic has been closed to new replies.

About this Topic