WordPress.org

Ready to get started?Download WordPress

Forums

wp-mail.php can't find my emails (3 posts)

  1. wormholer693
    Member
    Posted 6 years ago #

    Have been using WordPress for a couple of weeks now and already a regular blogger.

    I have set up a secret email address and have added the settings on the Options, Write page of wp-admin. However, whenever I check wp-mail.php, I recieve the following message:
    "There doesn’t seem to be any new mail."
    I have signed into my pop3 mail box and sure enough, there is an email waiting.
    I've double and triple checked the settings on the options, write page and they are correct. I've even gone as far as setting up my mail client to download the emails using the same settings and this confirms that they work.

    Is there something I'm missing?

    blog.andybarratt.co.uk

  2. wormholer693
    Member
    Posted 6 years ago #

    Hasn't anybody had this problem before?

  3. comprido
    Member
    Posted 6 years ago #

    Well, I´m working now with the wp-mail.php at http://www.rodavirtual.com .

    During the last 5 days I´ve been testing how it works.

    1) Since I work with Hostgator, my mail settings to set up the accounts on Outlook Express (...) have to be like webmaster+rodavirtual.com and not the usual webmaster@rodavirtual.com .

    But, in this way, after lot of tests I note that wp-mail require the "@" form to log in.

    2) You may to refresh your blog until the mail sended stay on your server. I mean... a common error is that we are sending continously messages, refreshing the brownser, and always opening our email client to ensure that the email was sended correctly.

    Usually the email client download your mail from the server and it can affect the wp-mail hack.
    So do not try to access your mail account (through your email client) until the messages are posted on your blog!

    3) A very important item. If you read the configuration manual here at http://codex.wordpress.org/Blog_by_Email do not pass the "Automated Browser Activation" ALERT:

    <iframe src="http://yourblogdomain/wordpressinstalldir/wp-mail.php" name="mailiframe" width="0" height="0" frameborder="0" scrolling="no" title=""></iframe>

    Edit the above line of code so that it refers to the location of your wp-mail.php file. Add this line of code to the footer.php file in the directory for whatever theme you are using (don't include it within an HTML paragraph).

    You may have to refresh your blog to see the new post. New users may find this method the most helpful.

    I´ll expect that this info may help you.

    Now my problem is that the emails I want to post have a "MIME" codification and them are posted without any format at my blog...

Topic Closed

This topic has been closed to new replies.

About this Topic