WordPress.org

Ready to get started?Download WordPress

Forums

WP Mail SMTP
wp-mail-smtp php mailer and smtp returning errors (17 posts)

  1. pinkteeshirt
    Member
    Posted 2 years ago #

    I have just found that any email or contact form function on any website that I have with my 123-reg hosting, does not work.

    If I use SMTP function I get the following error

    SMTP -> FROM SERVER:550-ATLAS [Home directory didnt exist: 622801,
    550 /websites/123reg/LinuxPackage26/ab/so/lu/absolutespirit.co.uk/public_html]

    If I use PHP Mail function I get

    Could not instantiate mail function

    123 support tell me the following:-

    It appears that the folder path specified in your mail form has some flaws. Could you please point to the exact script that you are using, along with its full path, so we can further investigate this for you?

    I am a PHP novice and I don't know where to look.

    The directory structure of my sites on 123 has a root directory with all my web sites as directories off it. WP then map domains to these subdirectories according to my instructions. Public_html does not appear as a directory anywhere.

    I guess I need to know what scripts handle the incorrect directory path that 123-reg say that I have.

    What I can't understand is why PHP Mailer does not work either.

    I have to say that this is obviously not a wp-mail-smtp problem as no contact form plugin works. Wp-mail just gives me sensible clues.

    http://wordpress.org/extend/plugins/wp-mail-smtp/

  2. pinkteeshirt
    Member
    Posted 2 years ago #

    Correction to the post above.

    I meant that 123-reg map the domain to the directory.

  3. pinkteeshirt
    Member
    Posted 2 years ago #

    I have just had another reply from 123 support as follows.

    The underlying issue is that the path given on these scripts is wrong. Your WP installment is not located in the root of your public_html folder, but in a sub-folder - absolute. So the given path should be /public_html/absolute/. However, if we can't locate these files, we can't make the amendments for you.

    Does this make any sort of sense to anyone?
    Can anyone tell me how I can change the "given path". Is this in a setup script somewhere?
    Or....which files would they be able to amend for me if i knew what they were?

  4. frenchgeordie
    Member
    Posted 2 years ago #

    Hi Callum, Pinkteeshirt,

    I am having similar problems, I could not use the PHP mail() function so am trying to use wp mail smtp.
    I can run a test to an email using the domain of the website, for example name@mydomain.com
    if i try to run a test to another domain example
    name@somonelesesdomain.com it fails
    so when a new user registers no email is sent, i have tried this using test email accounts.
    I think that my path to the the mail function may be wrong as you describe in this thread. not sure???
    the path looks like this
    /root/mydomain.com/wordpress files and folders

    output from running a test, i have changed the domain names and user names as well as the password
    Test Message Sent

    The result was:

    bool(true)
    The full debugging output is shown below:

    [Code moderated as per the Forum Rules. Please use the pastebin]

    What do you think??????

  5. Callum Macdonald
    Member
    Plugin Author

    Posted 2 years ago #

    The path of the PHP file is not relevant here, that's a nonsense on behalf of 123-reg. The issue probably relates to PHP security settings. My suggestion is to ask 123-reg a simpler question:

    How do I send email from WordPress on my 123-reg hosting?

    Hopefully that will generate a more intelligent reply than the nonsense you've had so far.

    @frenchgeordie, your problem sounds different. I'd guess that you're not using SMTP authentication and so you can send email to your own domain, but no others because your server won't relay. The debugging output you posted has been removed, you could pastebin it if you like.

  6. frenchgeordie
    Member
    Posted 2 years ago #

    Hi

    thanks for your advice Callum.
    After checking out my server hosting provider, i find that i need to use a different port as the default port 25 is blocked for SMTP.
    I will try this today.

    cheers

  7. pinkteeshirt
    Member
    Posted 2 years ago #

    Thank you for your comment Callum.

    This is the latest reply from 123-reg. I have not asked them your question yet as they will maintain they have answered it here.

    Our engineers have advised that using a third party smtp server will not work. It's not possible to access an external SMTP server from linux shared hosting. All mail traffic is directed through the local server.

    The easiest way would be to use the built in php mail functions and use 'localhost' as the mail server.

    I know this isn't necessarilly a wp-mail-smtp issue but I feel 123 are running rings round me. 4 support engineers all saying different things now. Surely if none of the contact forms I use- being wp-mail-smtp (as phpmailer or smtp), contact form 7, cforms II all dont work then there is a fault at 123-reg.

    Is there any other way that I can prove them wrong? I just don't know where to go now.

    Alan Ellicott

  8. Callum Macdonald
    Member
    Plugin Author

    Posted 2 years ago #

    @frenchgeordie: If your host blocks port 25, they probably provide a relay server through which you can send email. Have you tried localhost port 25?

    @pinkteeshirt: If you try using PHP's mail() function (which is not the same as PHPMailer, they are two different things) and the test message is unsuccessful, then the mail() function is not working properly. Alternatively, have you tried choosing SMTP with localhost as the host, port 25, and no authentication?

  9. pinkteeshirt
    Member
    Posted 2 years ago #

    Callum,
    Excuse the novice understanding of PHP's mail() and PHPMailer.
    However I have tried the SMTP, localhost, Port 25,with no auth and exactly the same arror message comes up regarding the path being incorrect.

    I have to say that moving the site and database temporarily to my own ubuntu server with local host configured for pretend domain has proved that all settings are correct for your plugin. Messages have been sent with no problem.

    123-reg are still looking into it. I use WordPress because everything normally works without me knowing more than I need to (although I can hack around at PHP to move and dissappear things) Even though I pay for admitedly slow shared hosting, I should expect email/contact forms to work properly.
    Even the in-built comment notification or new user notifications do not work on any sites I have with 123-reg. I believe there is simply something wrong with their handling of just my hosting otherwise there would be lots of complaints out there.
    Many thanks
    Alan

  10. Callum Macdonald
    Member
    Plugin Author

    Posted 2 years ago #

    @pinkteeshirt, Do you have a gmail account? Have you tried using that? You might find it "just works" as it'll bypass 123reg for the sending of email.

  11. pinkteeshirt
    Member
    Posted 2 years ago #

    Callum,
    I am really embarrassed at wasting your time with this one.
    123-reg have now come back with what they think is a solution after I pointed out to them that everything started to go wrong after my hosting package was upgraded.

    I have checked and after the upgrade the patch directory has changed to /websites/123reg/LinuxPackage26/ab/so/lu/absolutespirit.co.uk/public_html.

    I have made the modification in the database and also sent a test email using the form on your website. Can you please confirm if it has arrived?

    It hasn't made the slightest difference as you predicted earlier! and any test on any contact form fails SMTP or PHPMail.

    Yes I do have a gmail account but I don't understand how you might wish me to use it !!

    Thanks again

  12. pinkteeshirt
    Member
    Posted 2 years ago #

    Callum: re previous message, the bit in italics is their response.

  13. Callum Macdonald
    Member
    Plugin Author

    Posted 2 years ago #

    You can use a gmail account as your outgoing mail server if your server has the appropriate SSL options enabled in PHP. You'll find the smtp settings somewhere, I think they're smtp.gmail.com on port 465 with SSL and using your gmail / google apps username / password.

  14. pinkteeshirt
    Member
    Posted 2 years ago #

    After something like 19 days 123-reg have discovered that the permissions on my root directory were wrong and that this prevented Exim operation working which will have affected SMTP. I have no control of the permmissions on this directory - only the site directories.
    This was very frustrating indeeed and resulted in me taking out a subscription to another hosting company as a precaution.
    123-reg have offered me 3 months extra hosting in compensation.

    Thanks for everyone's contribution.

    Alan

  15. milantyagi
    Member
    Posted 2 years ago #

    Please help me any one on below issue i'm using wp-mail-smtp plugin
    =====================

    Test Message Sent

    The result was:

    boolean true

    The full debugging output is shown below:

    [Debug moderated as per the Forum Rules. Please use the pastebin]

  16. Paulo Melo
    Member
    Posted 2 years ago #

    Hello
    My English is bad - google translation ...
    Sending several emails to different recipients and all back to my inbox - to the address of the sender.
    How to avoid this error?
    Here my code in PHP
    Thanks - Paul[ Signature moderated. ]

  17. Paulo Melo
    Member
    Posted 2 years ago #

    [Code moderated as per the Forum Rules. The maximum number of lines of code that you can post in these forums is ten lines. Please use the pastebin]

    Grato - Paulo

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic