WordPress.org

Ready to get started?Download WordPress

Forums

WP-Mail-SMTP 0.8.6, Sending emails does not work (4 posts)

  1. Alyen
    Member
    Posted 3 years ago #

    Since I did the upgrade to version 3.0.1 wordpress plugin wp-email-smtp send email stopped and when I try to send a test email I get the error message of Next Step:

    Desde que hice la actualización del wordpress a la versión 3.0.1 el plugin wp-mail-smtp dejo de enviar email y cuando intento enviar un email de prueba me sale el seguiente mensage de error:

    Depois de da atulizaçao do wordpress para a versao 3.0.1 o plugin wp-mail-smtp nao enviar mais email, mesmo eu tentando enviar un email de test nao enviar e sai esse msg:

    Test Message Sent
    
    The result was:
    
    bool(false)
    
    The full debugging output is shown below:
    
    object(PHPMailer)#4093 (45) {
      ["Priority"]=>
      int(3)
      ["CharSet"]=>
      string(5) "UTF-8"
      ["ContentType"]=>
      string(10) "text/plain"
      ["Encoding"]=>
      string(4) "8bit"
      ["ErrorInfo"]=>
      string(43) "SMTP Error: Could not connect to SMTP host."
      ["From"]=>
      string(21) "aaa@bbb.com"
      ["FromName"]=>
      string(22) "Contato"
      ["Sender"]=>
      string(0) ""
      ["Subject"]=>
      string(58) "WP Mail SMTP: Test mail to aaa@aaa.com"
      ["Body"]=>
      string(68) "This is a test email generated by the WP Mail SMTP WordPress plugin."
      ["AltBody"]=>
      string(0) ""
      ["WordWrap"]=>
      int(0)
      ["Mailer"]=>
      string(4) "smtp"
      ["Sendmail"]=>
      string(18) "/usr/sbin/sendmail"
      ["PluginDir"]=>
      string(0) ""
      ["Version"]=>
      string(5) "2.0.4"
      ["ConfirmReadingTo"]=>
      string(0) ""
      ["Hostname"]=>
      string(0) ""
      ["MessageID"]=>
      string(0) ""
      ["Host"]=>
      string(14) "smtp.gmail.com"
      ["Port"]=>
      string(3) "465"
      ["Helo"]=>
      string(0) ""
      ["SMTPSecure"]=>
      string(3) "ssl"
      ["SMTPAuth"]=>
      bool(true)
      ["Username"]=>
      string(23) "aaa@bbb.com"
      ["Password"]=>
      string(8) "*******"
      ["Timeout"]=>
      int(10)
      ["SMTPDebug"]=>
      int(2)
      ["SMTPKeepAlive"]=>
      bool(false)
      ["SingleTo"]=>
      bool(false)
      ["smtp"]=>
      object(SMTP)#4094 (7) {
        ["SMTP_PORT"]=>
        int(25)
        ["CRLF"]=>
        string(2) "
    "
        ["do_debug"]=>
        int(2)
        ["do_verp"]=>
        bool(false)
        ["smtp_conn"]=>
        bool(false)
        ["error"]=>
        array(3) {
          ["error"]=>
          string(27) "Failed to connect to server"
          ["errno"]=>
          int(110)
          ["errstr"]=>
          string(20) "Connection timed out"
        }
        ["helo_rply"]=>
        NULL
      }
      ["to"]=>
      array(1) {
        [0]=>
        array(2) {
          [0]=>
          string(31) "aaa@aaa.com"
          [1]=>
          string(0) ""
        }
      }
      ["cc"]=>
      array(0) {
      }
      ["bcc"]=>
      array(0) {
      }
      ["ReplyTo"]=>
      array(0) {
      }
      ["attachment"]=>
      array(0) {
      }
      ["CustomHeader"]=>
      array(0) {
      }
      ["message_type"]=>
      string(5) "plain"
      ["boundary"]=>
      array(2) {
        [1]=>
        string(35) "b1_baec03357435dd94d569be6c239b8cfb"
        [2]=>
        string(35) "b2_baec03357435dd94d569be6c239b8cfb"
      }
      ["language"]=>
      array(13) {
        ["mailer_not_supported"]=>
        string(25) " mailer is not supported."
        ["provide_address"]=>
        string(55) "You must provide at least one  mailer is not supported."
        ["execute"]=>
        string(19) "Could not execute: "
        ["instantiate"]=>
        string(36) "Could not instantiate mail function."
        ["authenticate"]=>
        string(35) "SMTP Error: Could not authenticate."
        ["from_failed"]=>
        string(35) "The following From address failed: "
        ["data_not_accepted"]=>
        string(30) "SMTP Error: Data not accepted."
        ["recipients_failed"]=>
        string(56) "SMTP Error: The following SMTP Error: Data not accepted."
        ["connect_host"]=>
        string(43) "SMTP Error: Could not connect to SMTP host."
        ["file_access"]=>
        string(23) "Could not access file: "
        ["file_open"]=>
        string(33) "File Error: Could not open file: "
        ["encoding"]=>
        string(18) "Unknown encoding: "
        ["signing"]=>
        string(15) "Signing Error: "
      }
      ["error_count"]=>
      int(1)
      ["LE"]=>
      string(1) "
    "
      ["sign_cert_file"]=>
      string(0) ""
      ["sign_key_file"]=>
      string(0) ""
      ["sign_key_pass"]=>
      string(0) ""
    }
    
    The SMTP debugging output is shown below:
    
    SMTP -> ERROR: Failed to connect to server: Connection timed out (110)
  2. Callum Macdonald
    Member
    Posted 3 years ago #

  3. FutureX5
    Member
    Posted 3 years ago #

    Exact same problem "Mailer is not supported" I tried with 2 different hosts: Gmail and 1and1 both rejected the connection. Tried ports 25, 265, 587. same thing

    Using WordPress 3.0.5
    WP-Mail-SMTP 0.8.6

    What's the solution?

  4. Callum Macdonald
    Member
    Posted 3 years ago #

    @FutureX5: Mailer not supported is the first error message in the "language" part of the output, is that actually the error you got? Please copy / paste the "SMTP debugging output". If the error there is "Cannot connect to host", this is the most common problem and it relates to your PHP settings / permissions. Please contact your host.

Topic Closed

This topic has been closed to new replies.

About this Topic