WordPress.org

Ready to get started?Download WordPress

Forums

wp-mail - encoding problem (3 posts)

  1. yaakov
    Member
    Posted 5 years ago #

    I am trying to post by email as indicated at
    http://codex.wordpress.org/Blog_by_Email

    but I get aweful results when I post in non latin character
    I trying with russian and with hebrew, from a gmail account
    it post without doint the decoding at all :
    with subject topic :
    =?UTF-8?B?16PXkteT15zXmtej?=

    and content :
    5PXktec15rXoyDXktec15PXmtej15Ig15zXktea15PXoyDXkteT15zXmteS16PXkwrXktec15PX
    mtej15zXkiDXkyDXktec15PXmtejINeS15PXnCDXktea16PXkyDXnNea15LXo9eTINea16PXktec
    15MK15LXnNeT15rXo9eSINeT15rXo9ecINeS15zXmteT16Mg15LXnNeS15rXk9ejINec15LXk9ea
    16PXkteT15zXmtej15LXnNeS15PXmgo

    I tried to fix by making some change in wp-mail.php but it doesnt seem to work.

    any idea how to fix it ?

    thanks

  2. Daniel Heffernan
    Member
    Posted 5 years ago #

    I'm having the same trouble with it. The body of mine is also base-64 encoded UTF-8. I'm going to poke around wp-mail.php and see if I can find a header telling me whether or not I should run base64_decode() on the body.

  3. Daniel Heffernan
    Member
    Posted 5 years ago #

    After some investigation, this does not seem to be an issue when the subject/body begins with a latin character. When beginning with a "special" (Russian, Japanese, Greek, etc) character, it seems to fail.

Topic Closed

This topic has been closed to new replies.

About this Topic