WordPress.org

Ready to get started?Download WordPress

Forums

WP-Mail and Blackberry (6 posts)

  1. Courtman
    Member
    Posted 6 years ago #

    I've set up my blog so it reads emails from an account on my server. When I send small posts (2 or 3 paragraphs) from my Blackberry in plain text it posts just fine. However, yesterday I sent my first "full post" and when I rain wp-mail.php it went to the mailbox, got the message but the message showed up as random characters.

    Here is the original message which I've sent from my Blackberry and is sitting in the webmail of my server:

    -----------------------------------------------------------
    Content-Transfer-Encoding: base64
    Content-Type: text/plain
    Date: Sat, 29 Dec 2007 09:32:19 +0000 [09:32:19 AM GMT]
    Delivered-To: 616-xxx@xxx.net
    From: Adrian Court <xxx@xxx.net>
    Importance: Normal
    MIME-Version: 1.0
    Message-ID: <764751803-1198920745-cardhu_decombobulator_blackberry.rim.net-599439937-@bxe042.bisx.produk.on.blackberry>
    Received: (qmail 19000 invoked from network); 29 Dec 2007 09:32:42 +0000
    from smtp02.bis.eu.blackberry.com (216.9.253.49) by wrenntestsite.co.uk with SMTP; 29 Dec 2007 09:32:42 +0000
    from bda013.bis.eu.blackberry.com (bda013.bisx.produk.on.blackberry [172.24.224.73]) by srs.bis.eu.blackberry.com (8.13.7 TEAMON/8.13.7) with ESMTP id lBT9WVQm016197 for <xxx@xxx.net>; Sat, 29 Dec 2007 09:32:31 GMT
    from bda013-cell00.bisx.produk.on.blackberry (localhost.localdomain [127.0.0.1]) by bda013.bis.eu.blackberry.com (8.13.4 TEAMON/8.13.4) with ESMTP id lBT9WR3X025485 for <xxx@xxx.net>; Sat, 29 Dec 2007 09:32:27 GMT

    Received-SPF: pass (wrenntestsite.co.uk: SPF record at srs.bis.eu.blackberry.com designates 216.9.253.49 as permitted sender)
    Reply-To: xxx@xxx.net
    Return-Path: <SRS0=MDtWsY=RU=xxx.net=xxx@srs.bis.eu.blackberry.com>
    Sensitivity: Normal
    Subject: Bah Hondabug test
    To: Blog Entry <xxx@xxx.net>
    X-Priority: Normal
    X-rim-org-msg-ref-id: 764751803

    I've been the proud owner of my first brand new car - a Honda Civic - since June 2007. Overall I've been very pleased with it. Space-age looks inside and out, nice to drive, spacious, and economical.

    Economical until the end of September that is, when the economy started to drop from 38mpg/tank down towards the 32mpg mark. This was noticed in tandem with a stutter at certain rev ranges. Much investigation ensued from the garage until they found that the stutter was an "engine characteristic" of the VTEC cutting in and out.

    Not happy with this answer I test-drove a similar Civic and sure enough it had the characteristic, but not like my car. More checks showed the valve clearances to be too big and a cracked spark plug. But still the stutter remains. Now Honda are promising a software update in January to "fix" the problem. We shall see.

    To compound my misery I got rear-ended and needed a new bumper. Because of the newness of the car I thought Honda would do the work best. Wrong. The new bumper, sprayed with the same batch of paint by Honda in Swindon looks nothing like the rest of my car.

    And to cap it all yesterday the car started making a rubbery squeak from the front-right area. I found a trapped and detached door seal, but that didn't cure it and a further test-drive reveals a suspension problem!!!

    So in January my car is going into the garage to have the VTEC looked at again, the bumper redone, the suspension fixed plus a couple of other small snags. There is also a recall out on a dodgy handbrake. And they say Honda is the height of reliability?

    So, by the end of January I will have a reliable car I can be happy with again. Failing that they can have the keys back. I'm beginning to realise how Jenson Button felt last season...

    Oh, and Happy New Year to you all!
    -----------------------------------------------------------

    When I run wp-mail.php I get the following page:

    -----------------------------------------------------------
    Author = xxx@xxx.net
    Author = xxx@xxx.net

    Content-type: text/plain, Content-Transfer-Encoding: base64, boundary:

    Raw content:

    DQotLS0tLU9yaWdpbmFsIE1lc3NhZ2UtLS0tLQ0KRnJvbTogIkFkcmlhbiBDb3VydCIgPGFkcmlh
    bkBwZWFudXR3b29kLm5ldD4NCg0KRGF0ZTogRnJpLCAyOCBEZWMgMjAwNyAxNjo0OTozMyANClRv
    OiJCbG9nIEVudHJ5IiA8dzNiMTBnQHBlYW51dHdvb2QubmV0Pg0KU3ViamVjdDogQmFoIEhvbmRh
    YnVncw0KDQoNCkkndmUgYmVlbiB0aGUgcHJvdWQgb3duZXIgb2YgbXkgZmlyc3QgYnJhbmQgbmV3
    IGNhciAtIGEgSG9uZGEgQ2l2aWMgLSBzaW5jZSBKdW5lIDIwMDcuIE92ZXJhbGwgSSd2ZSBiZWVu
    IHZlcnkgcGxlYXNlZCB3aXRoIGl0LiBTcGFjZS1hZ2UgbG9va3MgaW5zaWRlIGFuZCBvdXQsIG5p
    Y2UgdG8gZHJpdmUsIHNwYWNpb3VzLCBhbmQgZWNvbm9taWNhbC4NCg0KRWNvbm9taWNhbCB1bnRp
    bCB0aGUgZW5kIG9mIFNlcHRlbWJlciB0aGF0IGlzLCB3aGVuIHRoZSBlY29ub215IHN0YXJ0ZWQg
    dG8gZHJvcCBmcm9tIDM4bXBnL3RhbmsgZG93biB0b3dhcmRzIHRoZSAzMm1wZyBtYXJrLiBUaGlz
    IHdhcyBub3RpY2VkIGluIHRhbmRlbSB3aXRoIGEgc3R1dHRlciBhdCBjZXJ0YWluIHJldiByYW5n
    ZXMuIE11Y2ggaW52ZXN0aWdhdGlvbiBlbnN1ZWQgZnJvbSB0aGUgZ2FyYWdlIHVudGlsIHRoZXkg
    Zm91bmQgdGhhdCB0aGUgc3R1dHRlciB3YXMgYW4gImVuZ2luZSBjaGFyYWN0ZXJpc3RpYyIgb2Yg
    dGhlIFZURUMgY3V0dGluZyBpbiBhbmQgb3V0Lg0KDQpOb3QgaGFwcHkgd2l0aCB0aGlzIGFuc3dl
    ciBJIHRlc3QtZHJvdmUgYSBzaW1pbGFyIENpdmljIGFuZCBzdXJlIGVub3VnaCBpdCBoYWQgdGhl
    IGNoYXJhY3RlcmlzdGljLCBidXQgbm90IGxpa2UgbXkgY2FyLiBNb3JlIGNoZWNrcyBzaG93ZWQg
    dGhlIHZhbHZlIGNsZWFyYW5jZXMgdG8gYmUgdG9vIGJpZyBhbmQgYSBjcmFja2VkIHNwYXJrIHBs
    dWcuIEJ1dCBzdGlsbCB0aGUgc3R1dHRlciByZW1haW5zLiBOb3cgSG9uZGEgYXJlIHByb21pc2lu
    ZyBhIHNvZnR3YXJlIHVwZGF0ZSBpbiBKYW51YXJ5IHRvICJmaXgiIHRoZSBwcm9ibGVtLiBXZSBz
    aGFsbCBzZWUuDQoNClRvIGNvbXBvdW5kIG15IG1pc2VyeSBJIGdvdCByZWFyLWVuZGVkIGFuZCBu
    ZWVkZWQgYSBuZXcgYnVtcGVyLiBCZWNhdXNlIG9mIHRoZSBuZXduZXNzIG9mIHRoZSBjYXIgSSB0
    aG91Z2h0IEhvbmRhIHdvdWxkIGRvIHRoZSB3b3JrIGJlc3QuIFdyb25nLiBUaGUgbmV3IGJ1bXBl
    ciwgc3ByYXllZCB3aXRoIHRoZSBzYW1lIGJhdGNoIG9mIHBhaW50IGJ5IEhvbmRhIGluIFN3aW5k
    b24gbG9va3Mgbm90aGluZyBsaWtlIHRoZSByZXN0IG9mIG15IGNhci4NCg0KQW5kIHRvIGNhcCBp
    dCBhbGwgeWVzdGVyZGF5IHRoZSBjYXIgc3RhcnRlZCBtYWtpbmcgYSBydWJiZXJ5IHNxdWVhayBm
    cm9tIHRoZSBmcm9udC1yaWdodCBhcmVhLiBJIGZvdW5kIGEgdHJhcHBlZCBhbmQgZGV0YWNoZWQg
    ZG9vciBzZWFsLCBidXQgdGhhdCBkaWRuJ3QgY3VyZSBpdCBhbmQgYSBmdXJ0aGVyIHRlc3QtZHJp
    dmUgcmV2ZWFscyBhIHN1c3BlbnNpb24gcHJvYmxlbSEhIQ0KDQpTbyBpbiBKYW51YXJ5IG15IGNh
    ciBpcyBnb2luZyBpbnRvIHRoZSBnYXJhZ2UgdG8gaGF2ZSB0aGUgVlRFQyBsb29rZWQgYXQgYWdh
    aW4sIHRoZSBidW1wZXIgcmVkb25lLCB0aGUgc3VzcGVuc2lvbiBmaXhlZCBwbHVzIGEgY291cGxl
    IG9mIG90aGVyIHNtYWxsIHNuYWdzLiBUaGVyZSBpcyBhbHNvIGEgcmVjYWxsIG91dCBvbiBhIGRv
    ZGd5IGhhbmRicmFrZS4gQW5kIHRoZXkgc2F5IEhvbmRhIGlzIHRoZSBoZWlnaHQgb2YgcmVsaWFi
    aWxpdHk/DQoNClNvLCBieSB0aGUgZW5kIG9mIEphbnVhcnkgSSB3aWxsIGhhdmUgYSByZWxpYWJs
    ZSBjYXIgSSBjYW4gYmUgaGFwcHkgd2l0aCBhZ2Fpbi4gRmFpbGluZyB0aGF0IHRoZXkgY2FuIGhh
    dmUgdGhlIGtleXMgYmFjay4gSSdtIGJlZ2lubmluZyB0byByZWFsaXNlIGhvdyBKZW5zb24gQnV0
    dG9uIGZlbHQgbGFzdCBzZWFzb24uLi4NCg0KT2gsIGFuZCBIYXBweSBOZXcgWWVhciB0byB5b3Ug
    YWxsIQ==

    Author: 1
    -----------------------------------------------------------

    And thats what goes on the blog. Interestingly, using Horde to view the mail when I view the message source I get the same gibberish.

    Can anyone help or advise what may be causing this? I want to be able to use my Blackberry to blog while away from home, this looks like it may be difficult!

  2. straitline
    Member
    Posted 6 years ago #

    Did you have any luck solving this problem? I am having the same issues with a blackberry posting to wordpress.

  3. ma3stro
    Member
    Posted 6 years ago #

    I am having similar issues. I can get text-only posts to work from my BlackBerry but if I try to add an image only the Subject comes through (no body and no image). What gives??

  4. domino138
    Member
    Posted 6 years ago #

    Postmaster 1.0.4

    Brett adjusted his plugin to work with BlackBerry attachments.

  5. masaka
    Member
    Posted 6 years ago #

    i have the same problem too.

    short answer: WordPress is encoding it in base64 for some reason. Using a base64 decoder (http://www.opinionatedgeek.com/dotnet/tools/Base64Decode/Default.aspx) with your pasted text gave me your post back in plain text.

    i do not know how to fix this.

  6. masaka
    Member
    Posted 6 years ago #

    okay, i take it back.

    WordPress is not encoding it in base64, it's simply leaving it in base64, because the blackberry sends e-mails in base64.

    either way, here's what i did to fix it:
    in wp-mail.php, under the lines:

    if (stripos($content_transfer_encoding, "quoted-printable") !== false) {
    		$content = quoted_printable_decode($content);
    	}

    i put:

    if (strcmp($content_transfer_encoding, 'base64')==0){
    		$content = base64_decode($content);
    	}

    i'm not a php wizard, but basically what it says, if the encoding is base64, decode the content.

Topic Closed

This topic has been closed to new replies.

About this Topic