WordPress.org

Ready to get started?Download WordPress

Forums

/wp-login.php?redirect_to=http problem (31 posts)

  1. aubervilliers
    Member
    Posted 3 years ago #

    Hello,

    i have a problem connecting with my blogs. When i try mydomain.com/wp-login.php it does not work.

    It gives me http://mydomain.com/wp-login.php?redirect_to=http://mydomain.com/wp-admin/&reauth=1

    It works only with my principal blog. I can't go to the dashboard of the other blogs.

    Need some help.

    Thank you

  2. site4
    Member
    Posted 3 years ago #

    same thing got these every time I try to move up from reg WP to Multi Site it locks me out here are the codes it is spitting at me any way

    http://2chirp.me/wp-login.php?redirect_to=http%3A%2F%2F2mydomain.tld%2Fwp-admin%2Fwidgets.php%3Fs%3D%26show%3D%26sidebar%3Dsecond-section&reauth=1
    
    login.php?redirect_to=http%3A%2F%2F2mydomain.tld%2Fwp-admin%2Fwidgets.php%3Fs%3D%26show%3D%26sidebar%3Dsecond-section&reauth=1
    
    ?redirect_to=http%3A%2F%2F2mydomain.tld%2Fwp-admin%2Fpost.php%3Fpost%3D1%26action%3Dedit&reauth=1
    
    wp-login.php?redirect_to=http%3A%2F%2F2mydomain.tld%2Fwp-admin%2F&reauth=1

    Notice they are different ???

    hope this gets fixed asap :)

  3. disable your plugins first. all of 'em.

  4. aubervilliers
    Member
    Posted 3 years ago #

    I did it but nothing happens.

    I can connect the whole blogs if i set up wp-config.php like this : define('DOMAIN_CURRENT_SITE', 'mydomain.com' );
    But i can't go to the super admin profile.

    But if i sept up wp-config.php like that : define('DOMAIN_CURRENT_SITE', 'subdomain.mydomain.com' );
    i can only connect the admin panel with my principal site but i can go to the super admin profile.

    Stranger : one or the other !

  5. site4 - Make a NEW topic. Don't steal someone else's, it's rude.

    What code did you put in your wp-config.php?

    define('WP_ALLOW_MULTISITE', true); right?

  6. aubervilliers
    Member
    Posted 3 years ago #

    this is my wp-config.php :

    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'robespierre-cochennec-peri.aubervilliers.fr' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', '1');
    define('BLOGID_CURRENT_SITE', '1' );
    
    /* Uncomment to allow blog admins to edit their users. See http://trac.mu.wordpress.org/ticket/1169 */
    //define( "EDIT_ANY_USER", true );
    /* Uncomment to enable post by email options. See http://trac.mu.wordpress.org/ticket/1084 */
    //define( "POST_BY_EMAIL", true );
    
    /**#@+
     * Authentication Unique Keys.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link http://api.wordpress.org/secret-key/1.1/wpmu/salt WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    [REMOVED]
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', 'fr_FR');
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    // uncomment this to enable WP_CONTENT_DIR/sunrise.php support
    //define( 'SUNRISE', 'on' );
    
    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    // define( "UPLOADBLOGSDIR", "fileserver" );
    
    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to http://examples.com/ for the following: define( 'NOBLOGREDIRECT', 'http://example.com/' );
    // Set this value to %siteurl% to redirect to the root of the site
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you must use the theme 404 handler.
    
    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );
    
    define( "WP_USE_MULTIPLE_DB", false );
    define (‘WP_ALLOW_MULTISITE’, true);
    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, true );

    Like i said before, if i set up wp-config.php like this : define('DOMAIN_CURRENT_SITE', 'mydomain.com' );
    But i can't go to the super admin profile.

    But if i sept up wp-config.php like that : define('DOMAIN_CURRENT_SITE', 'subdomain.mydomain.com' );
    i can only connect the admin panel with my principal site but i can go to the super admin profile.

    Do you have a solution ?

  7. *AUGH* Please don't EVER post your auth keys and salts every again. You can use those to hack.

    And yes. I have a possible solution.

    See this part?

    define( "WP_USE_MULTIPLE_DB", false );
    define (‘WP_ALLOW_MULTISITE’, true);
    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, true );

    The STYLE of quotes are different. Change it to this:

    define( "WP_USE_MULTIPLE_DB", false );
    define ('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );

    Also put that ABOVE the // double check $base part... Make the WHOLE thing look like this:

    $table_prefix  = 'wp_';
    define ('WPLANG', 'fr_FR');
    
    /* Authentication Unique Keys. */
    [Removed]
    
    /* MultiSite */
    define( "WP_USE_MULTIPLE_DB", false );
    define ('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'aubervilliers.fr' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', '1');
    define('BLOGID_CURRENT_SITE', '1' );
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    define( "WP_USE_MULTIPLE_DB", false );
    
    /* That's all, stop editing! Happy blogging. */

    Just replace [Removed] with NEW keys from http://api.wordpress.org/secret-key/1.1/wpmu/salt PLEASE

    I also pulled out a LOT of cruft that you don't need right now. Or ... anymore. It's all commented out so lets clean that out for now.

  8. Yeah, he's got the old mu config file.

  9. aubervilliers
    Member
    Posted 3 years ago #

    It does not work. Other problems come. ;(

  10. WHAT other problems?

    I'm not psychic, you know :)

  11. aubervilliers
    Member
    Posted 3 years ago #

    WordPress notifies me database error with the configuration you gave me.

    My configuration : wordpress 3.1 subdomain

    If you have another idea. Thank you.

  12. aubervilliers
    Member
    Posted 3 years ago #

    Ipstenu,

    i tried to put the quotes like you told me and the configuration you gave me. But I have a database error for my principal bog (on chrome : "Error establishing a database connection").

    I can reach the other blogs and their admin panel. I can't go to the super admin profile and my principal blog dashboard.

    Do you have an idea to fix for my problem.

    Thank you

  13. i tried to put the quotes like you told me and the configuration you gave me. But I have a database error for my principal bog (on chrome : "Error establishing a database connection").

    Okay, let's try this...

    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'robespierre-cochennec-peri.aubervilliers.fr' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', '1');
    define('BLOGID_CURRENT_SITE', '1' );
    
    /* Uncomment to allow blog admins to edit their users. See http://trac.mu.wordpress.org/ticket/1169 */
    //define( "EDIT_ANY_USER", true );
    /* Uncomment to enable post by email options. See http://trac.mu.wordpress.org/ticket/1084 */
    //define( "POST_BY_EMAIL", true );
    
    /**#@+
     * Authentication Unique Keys.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link http://api.wordpress.org/secret-key/1.1/wpmu/salt WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    [REMOVED]
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', 'fr_FR');
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    // uncomment this to enable WP_CONTENT_DIR/sunrise.php support
    //define( 'SUNRISE', 'on' );
    
    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    // define( "UPLOADBLOGSDIR", "fileserver" );
    
    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to http://examples.com/ for the following: define( 'NOBLOGREDIRECT', 'http://example.com/' );
    // Set this value to %siteurl% to redirect to the root of the site
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you must use the theme 404 handler.
    
    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );
    
    define( "WP_USE_MULTIPLE_DB", false );
    define ('WP_ALLOW_MULTISITE', true);
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', true );
  14. aubervilliers
    Member
    Posted 3 years ago #

    Hello Ipstenu,

    i tried your last solution but does not work. The same errors appear.

    With my initial config with the wrong quotes, i am almost ready to succeed just the link inside the admin panel to go to the super admin profile does not work.

    But if i put the principal blog url with /wp-admin/network on the url bar, i can reach the super admin profile but cannot configure a blog when i choose modify.

    What it's strange is when i am connected in my principal blog i can go to any other blogs panel admin and switch between the admin and the blog public.

    Another idea ? ;(

  15. aubervilliers
    Member
    Posted 3 years ago #

    I can modify the config of the blogs with this url :
    http://robespierre-cochennec-peri.aubervilliers.fr/wp-admin/network/site-info.php?id=1

    and change the number for each blog config.

    Why it's not automatic and have to do this manuelly playing with urls ?

    :(((((((((

  16. Try this for the end bit. BUT.

    define( "WP_USE_MULTIPLE_DB", false );
    define ( "WP_ALLOW_MULTISITE", true);
    define( "MULTISITE", true );
    define( "SUBDOMAIN_INSTALL", true );

    I wanna point out that ALL I changed was the TYPE of quotes

    ‘ THAT quote will NEVER work on your server. You need to use NON formatted quotes. So ' or " will be fine. Make sure you're not using Word or any RTF text editor here. Use NOTEPAD.

  17. aubervilliers
    Member
    Posted 3 years ago #

    It doesn't work ;). I use dreamweaver for editing my wp-config.php

    My wp-config.php :

    <?php
    /**
     * The base configurations of the WordPress.
     *
     **************************************************************************
     * Do not try to create this file manually. Read the README.txt and run the
     * web installer.
     **************************************************************************
     *
     * This file has the following configurations: MySQL settings, Table Prefix,
     * Secret Keys, WordPress Language, and ABSPATH. You can find more information by
     * visiting {@link http://codex.wordpress.org/Editing_wp-config.php Editing
     * wp-config.php} Codex page. You can get the MySQL settings from your web host.
     *
     * This file is used by the wp-config.php creation script during the
     * installation.
     *
     * @package WordPress
     */
    
    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'remove to communicate with you');
    
    /** MySQL database username */
    define('DB_USER', 'remove to communicate with you');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'remove to communicate with you');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
    define('VHOST', 'yes');
    $base = '/';
    define('DOMAIN_CURRENT_SITE', 'robespierre-cochennec-peri.aubervilliers.fr' );
    define('PATH_CURRENT_SITE', '/' );
    define('SITE_ID_CURRENT_SITE', '1');
    define('BLOGID_CURRENT_SITE', '1' );
    
    /* Uncomment to allow blog admins to edit their users. See http://trac.mu.wordpress.org/ticket/1169 */
    //define( "EDIT_ANY_USER", true );
    /* Uncomment to enable post by email options. See http://trac.mu.wordpress.org/ticket/1084 */
    //define( "POST_BY_EMAIL", true );
    
    /**#@+
     * Authentication Unique Keys.
     *
     * Change these to different unique phrases!
     * You can generate these using the {@link http://api.wordpress.org/secret-key/1.1/wpmu/salt WordPress.org secret-key service}
     * You can change these at any point in time to invalidate all existing cookies. This will force all users to have to log in again.
     *
     * @since 2.6.0
     */
    remove to communicate with you
    /**#@-*/
    
    /**
     * WordPress Database Table prefix.
     *
     * You can have multiple installations in one database if you give each a unique
     * prefix. Only numbers, letters, and underscores please!
     */
    $table_prefix  = 'wp_';
    
    /**
     * WordPress Localized Language, defaults to English.
     *
     * Change this to localize WordPress.  A corresponding MO file for the chosen
     * language must be installed to wp-content/languages. For example, install
     * de.mo to wp-content/languages and set WPLANG to 'de' to enable German
     * language support.
     */
    define ('WPLANG', 'fr_FR');
    
    // double check $base
    if( $base == 'BASE' )
    	die( 'Problem in wp-config.php - $base is set to BASE when it should be the path like "/" or "/blogs/"! Please fix it!' );
    
    // uncomment this to enable WP_CONTENT_DIR/sunrise.php support
    //define( 'SUNRISE', 'on' );
    
    // uncomment to move wp-content/blogs.dir to another relative path
    // remember to change WP_CONTENT too.
    // define( "UPLOADBLOGSDIR", "fileserver" );
    
    // If VHOST is 'yes' uncomment and set this to a URL to redirect if a blog does not exist or is a 404 on the main blog. (Useful if signup is disabled)
    // For example, the browser will redirect to http://examples.com/ for the following: define( 'NOBLOGREDIRECT', 'http://example.com/' );
    // Set this value to %siteurl% to redirect to the root of the site
    // define( 'NOBLOGREDIRECT', '' );
    // On a directory based install you must use the theme 404 handler.
    
    // Location of mu-plugins
    // define( 'WPMU_PLUGIN_DIR', '' );
    // define( 'WPMU_PLUGIN_URL', '' );
    // define( 'MUPLUGINDIR', 'wp-content/mu-plugins' );
    
    define( "WP_USE_MULTIPLE_DB", false );
    define ("WP_ALLOW_MULTISITE", true);
    define( "MULTISITE", true );
    define( "SUBDOMAIN_INSTALL", true );
    
    /* That's all, stop editing! Happy blogging. */
    
    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    	define('ABSPATH', dirname(__FILE__) . '/');
    
    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    my .htaccess :

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    #uploaded files
    #RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*
    RewriteRule ^(.*/)?files/(.*) wp-includes//ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    #RewriteCond %{REQUEST_URI} ^.*/wp-admin$
    #RewriteRule ^(.+)$ $1/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule  ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    I don't understand the problem.

  18. Let's fix htaccess:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule . index.php [L]
    # END WordPress
    
    <IfModule mod_security.c>
    <Files async-upload.php>
    SecFilterEngine Off
    SecFilterScanPOST Off
    </Files>
    </IfModule>

    I really DOUBT that's it, but it can't hurt.

    Also, please STOP using dreamweaver to edit your files. Just use a plain text editor. It really can matter. I have no idea how dreamweaver saves things, but it's POSSIBLE the formatting is borking things.

  19. aubervilliers
    Member
    Posted 3 years ago #

    Good evening, it doesn't work too with the new .htaccess.

    I don't know what to do :(

    If you have another suggestion i will test it. Thank you.

  20. Open wp-config.php in NOTEPAD (or any PLANI text editor - TextPad, NotePad++, just NOT Dreamweaver or Word or anything fancy).

    Check to see if there are funky characters.

    SAVE the .htaccess via Notepad as plain text. No changes. Just save it.

  21. aubervilliers
    Member
    Posted 3 years ago #

    I opened wp-config.php with notepad. I see no funky characters.

    I saved .htaccess with notepad too. Still the same. It does not work.

    If you want i can send you by mail the two files ?

  22. Go to your network admin. Can you do that? Look under the Setup menu. Snag the htaccess rules from there. paste those in.

  23. aubervilliers
    Member
    Posted 3 years ago #

    Hi Andrea, the links in the dashboard "network admin" and "updates" doesn't work.

    I can only access my network admin manually with my principal site url adding /wp-admin/network/ at my principal site.

    I don't see set up menu to edit .htaccess. Why ?

  24. I can only access my network admin manually with my principal site url adding /wp-admin/network/ at my principal site.

    Well, that;s exactly where network admin IS.

    can you get to /wp-admin/network/setup.php ?

  25. aubervilliers
    Member
    Posted 3 years ago #

    No it gives me :

    The panel creation network is not designed for networking, WordPress MU.

    But i can go to /wp-admin/network.

  26. Aha, so you upgraded from wordpressmu then. Yes?

    Cuz that network setup menu is where the htaccess is stored. the right one.

  27. aubervilliers
    Member
    Posted 3 years ago #

    Ok but what do i have to now to fix the problem ? Thank you to help me.

  28. Stop bumping your posts (I've been deleting them today).

    Andrea (and I) have day jobs and people pay us to work. When we have time (and ideas/solutions) we will post. Until then, be patient. Bumping is both in violation of forum policy and annoying.

  29. @aubervilliers your issues sound complicated enough that you really should look at hiring someone to fix it

    jobs.wordpress.net

  30. aubervilliers
    Member
    Posted 3 years ago #

    What do you think about installing a new wordpress clean 3.1 and import all my blogs (files and databases) ?

    Is that solution will fix my problem ?

    Thank you both for all the time you took for my problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.