WordPress.org

Ready to get started?Download WordPress

Forums

wp-login.php - takes me to the index (15 posts)

  1. barrygb
    Member
    Posted 10 years ago #

    When I navigate to my "index.php" and click on login or go directly to "wp-login.php", I arrive at the "index of /wp-admin" page rather than to the expected login screen. Any ideas?
    Barry

  2. TechGnome
    Moderator
    Posted 10 years ago #

    If you have previously loggedin, w/o hitting the "Logout" link, it will automatically log you back in.
    TG

  3. harpshot
    Member
    Posted 10 years ago #

    Barry - The file wp-login.php is in the "wordpress" directory (or whatever your main blog install directory is called), not in the wp-admin subdirectory. Your browser seems to be looking for login.php in the wrong directory (wp-admin) and, not finding it, is displaying a unix style view of the wp-admin directory, if I'm understanding you correctly. I can think of some possibilities, but they depend on your OS and server setup. Maybe if you provide more details about your installation somebody can help. I'm not presently near the computer with my WP install. All I can suggest from where I'm at is that maybe your directory structure or contents got messed up somehow. Or your "main" index.php ended up in /wp-admin subdirectory replacing the small index.php that's normally there and just does a little re-directing.

  4. barrygb
    Member
    Posted 10 years ago #

    I've installed in my apache htdocs folder (Win 2k), unzipped from original zip file. Followed install.php, and all appears to be fine. When I place http://localhost/wp-login.php into my browser, as expected, I come to the login page. However, once I fill out username and password to login, I am taken to the Index of /wp-admin page with a listing of the .php files contained within. Not quite the behavior I was expecting. Happens this way whether or not I am currently logged in. If I hit the link for "back to blog", it takes me to my default index.htm webpage.
    Thanks,
    Barry

  5. jerryhung
    Member
    Posted 10 years ago #

    To barrygb
    I think you need to modify Apache's configuration file to tell it look for index.php as index. Search for index.htm, then add index.php (if it's not there)
    I forgot if Apache 2.0 does that, because my Apache 1.3.9.4 defaults to look for index.php
    Same thing applies on IIS (as it doesn't look for any *.php by default). So a safe way could be to do a redirect index.htm (with meta-data redirect)

  6. barrygb
    Member
    Posted 10 years ago #

    Perhaps I'm missing something, after you login is it supposed to take you to the index page with the listing of all the .php files?
    Barry

  7. harpshot
    Member
    Posted 10 years ago #

    No. You you should see a nice administrator's page, probably ready to
    write an article, but where you'll select tabs to do things like post,
    edit, set options, etc. You'll know it when you see it.
    Now that I'm home on the PC w/ my WP installation, I can duplicate your experience by deleting the index.php file from the /wp-admin folder. Your main, or default, index file should be index.php (probably not index.htm as you mentioned earlier) in your root (/htdocs) folder. But you should also have another index.php file in the /wp-admin folder. It's a small file, about 300 bytes. If you don't see it there, extract it from your wp zip file.
    If that's not it, then Jerry's suggestion about your httpd.conf file may be where to turn next. However, TG who posted above was betting that the necessary /wp-admin/index.php file is missing, and so am I.

  8. barrygb
    Member
    Posted 10 years ago #

    index.php exists in both my htdocs folder and the wp-admin folder..... the one in the wp-admin folder is merely a redirect with only a couple of lines in it.
    index.php in my browser brings me to a nice "my weblog" page, login brings me to the unexpected /wp-admin page with a listing of the .php files
    Same if I try to login from http://localhost/wp-login.php
    best illustrated by http://www.barrygb.com/weblog.jpg
    and http://www.barrygb.com/weblog1.jpg
    Barry

  9. barrygb
    Member
    Posted 10 years ago #

    Oddly enough, works perfectly on my linux box....................
    Barry

  10. Anonymous
    Unregistered
    Posted 10 years ago #

    To Barry,
    Having just installed WordPress 1.0.2 and experienced but overcame the "issue with install.php" as described under another post with this name; I was then faced with the problem you have described in your post. Except with this difference that I would receive a message saying 'Directory Listing Denied' given the fact of course that my hosted server does not allow directory contents to be listed.
    It was Jerry's post that pointed me in the right direction! I indeed needed to tell the webserver to look for index.php as the default document. Thus I added index.php to the range of already defined default documents such as default.htm default.asp, index.htm, index.html, index.asp, index.php and it worked! Thanks Jerry!
    The reason why you get to see your blog as illustrated on http://www.barrygb.com/weblog.jpg is because the full filename: index.php had been included in the URI at the addressbar of your browser.
    However in case of what is illustrated on http://www.barrygb.com/weblog1.jpg the URI is merely a path not including a filename. The behaviour of most webservers is that it will try to display any of the default documents as defined; alternatively if it cannot find such a (index) file it will list the contents of the directory itself. As shown in your case.
    Revisited Jerry's comment again and take it from there! Hope this was helpful.
    FD

  11. harpshot
    Member
    Posted 10 years ago #

    An excellent explanation, FD, in conjunction with Jerry's. If you're on a hosted server and don't have access to httpd.conf, would that go in a .htacess file (if you couldn't get the admin to modify httpd.conf)? Fortunately, I haven't run into the problem you guys had, but this seems like good stuff to learn about.

  12. Anonymous
    Unregistered
    Posted 10 years ago #

    I did experience the same problem and modifying the httpd.conf solved it.
    Thanks AHB

  13. Anonymous
    Unregistered
    Posted 10 years ago #

    Hi,

  14. Anonymous
    Unregistered
    Posted 10 years ago #

    Hi,
    I have the same problem now, and it's a hosted server. (sorry about previous post, kept hitting Enter by accident)
    Would editing .htaccess fix the redirect problem, and how would I go about doing that?

  15. Anonymous
    Unregistered
    Posted 9 years ago #

    I had the same problem as Barry a short while ago however editing the httpd.conf file resolved it.
    I am running W2K with Apache 2.0.52 and WordPress 1.3-alpha-4.
    Below is the line in httpd.conf that you need to edit. The line below reflects my settings. The point is to have index.php included somewhere in the line. I hope this helps anyone having the same issue.
    DirectoryIndex index.php index.html index.html.var default.htm default.html index.htm

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.