WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp-login.php not redirecting to wp-admin.php (6 posts)

  1. sefa
    Member
    Posted 7 years ago #

    Hi,

    Apparently, I had a link to bypass this problem in a text file on my other computer. When I log in at wp-login.php it redirects to wp-admin not wp-admin.php. My server doesn't allow directory listings, so all I'm getting is a Directory Listing Denied error. I'm hoping someone else had this problem and knows what that link is since I don't have access to my other computer for the next fortnight.

    Thanks,
    Sefa

  2. moshu
    Member
    Posted 7 years ago #

    I don't think there is a wp-admin.php file. At least I didn't see it.
    WP does the right thing: it redirects you to the wp-admin folder and in this case it should display/show the index file of that directory.

    Your problem is that index.php is not a valid index file. Talk to your host and tell them to make index.php a valid index file. That's all.

  3. sefa
    Member
    Posted 7 years ago #

    Are you sure this is the only possible cause? Because it was working.

  4. moshu
    Member
    Posted 7 years ago #

    The "Directory Listing Denied error" clearly points toward this: it is a problem with your server settings!

  5. sefa
    Member
    Posted 7 years ago #

    Sorry, I've been AFK for a few days. I've allowed directory listing because my server is taking too long to respond to me asking them to make index.php valid. I can just select index.php manually now. Thanks for your help.

  6. jimjangles
    Member
    Posted 6 years ago #

    I had a similar INSTALL problem, whereby after typing in "admin" and then my password it would bring me to folder wp-admin and browser would display http error. Well, I finally figured out that I did not have index.php as an allowed Directory Index with my hosting company. You see I thought as others that it was my Windows Server problem ,as some said WordPress prefers Apache. The only directory index I had was index.asp and index.htm so by a adding index.php..,Voila I have WordPress Dashboard in view and now I am ready to create a great blog.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags