WordPress.org

Ready to get started?Download WordPress

Forums

WP Login Issue (20 posts)

  1. mtl
    Member
    Posted 9 years ago #

    Am having difficulties with the login for WP -- after the initial login that comes as part of setting up the database, trying to login again with the correct password won't get me past the login screen at all. [I've reset the database several times... keeps happening each time.]
    It doesn't seem to be a browser issue, as I've tried both Mozilla & IE... I did play with 'wp-layout.css' and 'index.php' -- not sure if those affect anything regarding the login.
    Any suggestions, ideas, or help would be most appreciated. Thanks!

  2. mtl
    Member
    Posted 9 years ago #

    I just did -- but the changes aren't taking in the SQL database, even though it tells me it has. Is there something that's been set read-only that I need to fix?

  3. PLN
    Member
    Posted 9 years ago #

    I just ran into the same problem. I was using ssl (https) to access the site. Switching to non-ssl (http) seems to have fixed it.
    (But now, obviously, I have lost secure access, so I'm going to go after it a bit more...)

  4. mtl
    Member
    Posted 9 years ago #

    I'm on a regular http:// server, so I don't think that's the issue, unfortunately. (If only it were that simple a fix!)

  5. Mark (podz)
    Support Maven
    Posted 9 years ago #

    When it comes back to the login, what happens if you manually alter the url to http://www.example.com/wp-admin/post.php ?

  6. mtl
    Member
    Posted 9 years ago #

    It redirects me to the login screen, but the address in the navigation bar changes to this: http://(mywebsite.com)/wordpress/wp-login.php?redirect_to=%2Fwordpress%2Fwp-admin%2F Both the UserID and Password information fields are blank, and there is no error message.
    Also, I should note I haven't completely reinstalled the database each time -- I've only wiped the tables and then reinstalled WP. Each time after a new install, however, I can get into the Option menus and such as 'admin,' but I can't logout. (And if I wipe the cookies, then I'm locked out because of the above issue.)

  7. mtl
    Member
    Posted 9 years ago #

    Think I found the source of the problem, though I'm not sure of what the proper fix would be. I set up a test site and a test database to do some troubleshooting, and found that when the Options are set to display the blog in a different directory from where all the php files are, that's when the login issues go awry. Changing the Options to have the blog in the standard "wordpress" directory seems to allow the login process work fine again.
    So I suppose the easy fix is to just keep everything in one directory for now... anyone aware of a more "proper" solution?

  8. I'd keep it all in the same directory. That's how the installation recommends it. If you want your index.php file to be in a different directory, you could always create an index.php file which redirects to your wordpress index.php .

  9. Ruby Sinreich
    Member
    Posted 9 years ago #

    I have it all in one directory and am having this problem too (not on my blog but one I set up for a friend). I've been through all of the steps at http://faq.wordpress.net/view.php?p=68

    What else can I do?

  10. sidvorak
    Member
    Posted 9 years ago #

    I am having this same issue. After logging in, there is no error and I am redirected back to the login page. The admin section is not accessible if I manually type in the address either (it redirects me back to the login page).

    I have reset my password withing the database with no success. Seems like it might be a cookie issue although I have reset my cookies and computer cache.

  11. Read "Site URL Resetting or Redirecting under WP v1.5b" at: http://codex.wordpress.org/Login_Trouble

  12. sidvorak
    Member
    Posted 9 years ago #

    "Site URL Resetting or Redirecting under WP v1.5b" does not provide a solution.

    My 'siteurl' is listed correctly in the database as is my 'home' url. In my case, I am nearly certain it is a problem with the cookie not being set. I tried setting Firefox to ask for permission to set cookies so that I could see notification if wp-login.php tries to set a cookie. However, it never does.

    This was an upgrade btw from 1.3.

  13. Alvin
    Member
    Posted 9 years ago #

    I'm also having this problem, a fresh install of WP

    And I tried everything http://codex.wordpress.org/Login_Trouble says. This problem has been in the beta forever. If anyone wanna get my server login details and stuff I'm more than willingly to let you have it to test out.

  14. sidvorak
    Member
    Posted 9 years ago #

    This really shouldn't be an issue. 1.3 was working fine for me. What changed?

  15. sidvorak
    Member
    Posted 9 years ago #

    Is there anyway to download 1.3? I'd like to be able to login to my site again. Since, this issue doesn't seem to have an immediate solution maybe the older version will work.

    Does anyone know if the method for setting cookies was changed between 1.3 and 1.5?

  16. Ryan Boren
    WordPress Dev
    Posted 9 years ago #

    Look at this bug and add your comments.

  17. sidvorak
    Member
    Posted 9 years ago #

    Ok, it seems that there is a bug with IIS. Setting a cookie and following it with a header(location:) wipes out the cookie header info. I posted some changes that use a META refresh instead of the header() redirect here: http://mosquito.wordpress.org/view.php?id=592

    They work for me as well as others. If you are having the login problem give it a look.

  18. TobySimmons
    Member
    Posted 9 years ago #

    I've listed all (I think!) the changes that need to be made when running WP 1.5 on a Windows (IIS 5) server here. Please let me know if you think I've missed something.

  19. Ruby Sinreich
    Member
    Posted 9 years ago #

    By the way, I suggested that my friend having this problem try using a different browser and it worked fine! So it was clearly a cookie problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.