WordPress.org

Ready to get started?Download WordPress

Forums

wp-login does not work with Safari (8 posts)

  1. bronski
    Member
    Posted 10 years ago #

    OS X 10.3.3 and Safari 1.2.1 here, too - and no problem.
    Have you updated your mod_rewrite-rules?

  2. soulcore
    Member
    Posted 10 years ago #

    it's the same in my opera version (7.50 beta 1)
    with 1.20 beta i'm kicked out of the wp-admin stuff every time i refresh the page.
    firefox makes no problem, i don't want to change my fav. browser.
    trying to get an older version running :x

  3. nsxpower
    Member
    Posted 10 years ago #

    Safari 1.2 works as advertized with WP 1.02 and generated (w/ minor addition) mod_rewrite code.

  4. Anonymous
    Unregistered
    Posted 10 years ago #

    I see this problem too. WP on Linux, client is Safari 1.2 on OS X 10.3.3. I get a redirect loop between /wp-login.php?redirect_to=%2Fwp-admin%2F and /wp-admin/.
    Interestingly this didn't happen the first time I tried to log in.
    (Looking at the code has me confused. It looks like the password cookie is set to the md5 of the md5 of the password!? Is there some logic to this?)

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    Hmmm...OK, after clearing out the cookies for the site from Safari, everything seems to work. Dumping some info out of the code, it looks like it still had an old cookie that had the md5 of the password in it, rather than the md5 of the md5 of the password as WordPress now seems to expect.

  6. bronski
    Member
    Posted 10 years ago #

    tcloer: 1.02 had only 3 mod_rewrite rules, and 1.2 almost a dozen. But anyway... as several people complain about this there really seems to be an issue.

  7. tcloer
    Member
    Posted 10 years ago #

    Thanks Pete - the cookie was obviously the issue. I removed all the cookies for my site and now everything works fine. Thanks for the tip!

  8. frankj
    Blocked
    Posted 8 years ago #

    Hi

    I have found what the issue is with this:

    1) You may have added this site to the "blocked cookie list" - delete it from there
    IE: tools > internet options > privacy > sites > look under managed sites
    If your site is there, delete it

    2) Make sure your browser is accepting cookies for this site
    Between the login and the re-direct to the correct admin page it seems like WP reads
    the cookie, if it ain't there, it will just redirect to the wp-admin page again
    IE: tools > internet options > privacy > sites > in address of website type your
    url with http:// in front and click "allow"

    3) Test by setting your security level to low.
    IE: tools > internet options > privacy > drag lever down to "accept all cookies"

    You may need to apply just 1 or all of them for it to work.

    Hope you get it working & God Bless

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.