WordPress.org

Ready to get started?Download WordPress

Forums

wp-login Blank Page!! (27 posts)

  1. runtimeerror
    Member
    Posted 5 years ago #

    Hi!
    I have recently installed WordPress on my hosting. The installation went well, I got my admin pass, but the problem appears when I try to login to the control panel of my blog. When I load wp-login.php and I insert admin and the password, the only thing I get is a Blank Page. No error messages, only a Blank Page. It happens with Explorer, Firefox, etc.
    Can you help me?
    Thank you!
    The demonstration that it's installed correctly: http://www.runtimecomics.com

  2. Samuel B
    moderator
    Posted 5 years ago #

    blank pages are usually php errors - look in your error logs to see why it's crashing at that point

  3. runtimeerror
    Member
    Posted 5 years ago #

    Where can I see my error logs?

  4. runtimeerror
    Member
    Posted 5 years ago #

    If it helps, I have installed WordPress 2.7 for the first time (not an upgrade), so I think widgets are not related to this problem.
    Any suggestions...?

  5. AdamQuadmon
    Member
    Posted 5 years ago #

    I'm interested in this topic, I've the same problems

  6. Samuel B
    moderator
    Posted 5 years ago #

    blank pages are usually php errors - look in your error logs to see why it's crashing at that point

    you can access your error logs via ftp or at your host control center

    you need to look at the logs to see why php is crashing

  7. andrei_r
    Member
    Posted 5 years ago #

    Rename your plugins folder, and it will work. I didn't know exactly what plugin messed up my login, but I guess there are quite a lot that make this "crush".

  8. k.v.ahuja
    Member
    Posted 5 years ago #

    I have a similar problem.

    1. The installation was a success
    2. I am able to login
    3. I am able to do all administratiin tasks like creating posts etc

    Problem: When I try to view the web-site, I get a listing page of all php files. I checked the log files and do not see any error.

  9. whooami
    Member
    Posted 5 years ago #

    Problem: When I try to view the web-site, I get a listing page of all php files. I checked the log files and do not see any error.

    I have a similar problem.

    not similar.

    Add this to the top of your .htaccess file:
    DirectoryIndex index.php

  10. k.v.ahuja
    Member
    Posted 5 years ago #

    This post helped : http://wordpress.org/support/topic/230970?replies=3

    My issue is resolved. I am all set.

  11. annicole72
    Member
    Posted 5 years ago #

    My wp-admin goes to a redirect. should i just delete the index.php file inside the wp-admin folder?

  12. TheImpalaKid
    Member
    Posted 5 years ago #

    I am also having this problem. The login screen comes up fine, but when it tries to go to http://motorsportsnews.net/wordpress/wp-admin/, all I get is a blank screen.

  13. Bmz
    Member
    Posted 5 years ago #

    I have same problem. First it came out with Mozilla, been six months now. Then it worked with IE and now, with no browsers at all!!!!!!

    WHY? No access inside, no access to do nothing :(

  14. churchillmortgage
    Member
    Posted 5 years ago #

    apparently it has to do with the way Apache looks at the index.php file. The following is from the post by k.v.ahuja.

    Solution 1
    If allowed by your host, putting this in an .htaccess file will solve the problem:
    DirectoryIndex index.html index.htm index.php

    Solution 2
    Some hosts allow you to make a change, via their hosting control panel, to the DirectoryIndex. It's typically described as Indexes or Index documents, but may also require you to type something like
    DirectoryIndex index.html index.htm index.php
    or specify index.php as an index type file.

    Solution 3
    Instruct Apache to treat index.php as an index file. If you own the server, or have access to the http.conf file, simply modify the DirectoryIndex line in httpd.conf to:
    DirectoryIndex index.html index.htm index.php

    This search of the forum found the solutions described above:
    http://wordpress.org/search/displays+directory?forums=1

  15. DrBallard
    Member
    Posted 5 years ago #

    I tried this solution, but the problem remains. Still blank login page!!

  16. DrBallard
    Member
    Posted 5 years ago #

    Solution found!!!!!!!

    All right, delete the .htaccess file, then delete the wp-config file, then drop your database and create a brand new one.
    Next step: upload a fresh copy of wp-config-sample.php to your directory and go to your main page.
    You will have a message saying "wp-config can't be found, would you like to create one". Create it, entering the infos of your brand new DB.

    Tadam, it worked, well, for me!

  17. willisjw
    Member
    Posted 5 years ago #

    Ok, there seem to be a mix of problems reported here, but let me chime in. I had a working 2.7 installation until this morning. All of a sudden when I click on login I get a blank page -- no request for passwords -- nothing. http://www.macgardens.org goes to http://wp.macfusion.org/wp-login.php and it's completely blank. Some of the solutions discussed here sound like they would wipe out my whole website. I've emptied the cache, deleted the wp cookies, looked at the error log, and renamed the plugins folder. Nothing changes. Drop your database? What does that mean and imply?

  18. willisjw
    Member
    Posted 5 years ago #

    Well, my problem is now resolved. I replaced the wp-login.php file with one from a new install package and everything now works as it should.

  19. Boldrix
    Member
    Posted 5 years ago #

    I had the same problem, but none of the solutions worked for me (i didn't try to drop the DB of course).
    I had changed encoding to utf-8 (bad habit) in wp-includes\wpmu-funcions.php file, so when i changed that back - no blank page appeared.

  20. rale
    Member
    Posted 5 years ago #

    I was having a similar problem with my site. I searched high and low and followed all the recommendations (disabled plugins, checked wp-config.php, checked for trailing blank line in wp-login/wp-admin php files, etc). It wasn't until I went into my DB and reverted to the default theme that I started taking a hard look at the theme I was running (boldlines). I noticed there was a blank line at the end of the theme's functions.php. I removed the blank line and everything started to work just fine. Perhaps this will help someone else.

    Cheers,
    Al

  21. jojohippo
    Member
    Posted 5 years ago #

    Thanks rale, the blank line at the end of functions.php seemed to be my problem as well.

  22. lola rennt
    Member
    Posted 4 years ago #

    Deleting the blank lines at the end of the fucntion.php solved my recursive problem too!
    Thanks!

  23. ShawnM
    Member
    Posted 4 years ago #

    As like 20 people have said you need to delete the blank lines at the end of the fucntion.php. Check out http://www.homebuilderwholesale.com

  24. twilightgrejer
    Member
    Posted 4 years ago #

    Thank you, thank you, thank you so much!
    I had the same problem, and did what many of you did, i.e. delete the blank lines at the end of the functions.php file.

    I had added a function to the file, and then decided to delete that function, and I think it was then that the blank lines got in the document, but I would have never been able to guess that was the problem by myself!

  25. Jonathan Lundström
    Member
    Posted 4 years ago #

    I had the same problem but also found that having multiple php lines like this

    <?php
    
    ?>

    will also make the wp-admin crash. Easy fix but would not have discovered it without Rale :-)

  26. emilioincerto
    Member
    Posted 4 years ago #

    This post helped a lot!! Thanks my blank page issues is solved

    - This post helped : http://wordpress.org/support/topic/230970?replies=3

  27. mibaster
    Member
    Posted 4 years ago #

    Renaming plugins folder resolve my problem. Thanks.

Topic Closed

This topic has been closed to new replies.

About this Topic