WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP issue, or server issue? (3 posts)

  1. elfin
    Moderator
    Posted 5 years ago #

    I'm currently unable to test my own plugin (eshop) on my test site: http://eshop.quirm.net/. Here is the snipper of code I've narrowed the problem down to:

    if(get_option('eshop_checkout')!=''){
     if( $wp_rewrite->using_permalinks()){
      //$p->autoredirect=get_permalink(get_option('eshop_checkout')).'?action=redirect';
      $p->autoredirect=$this_script.'/index.php?page_id='.get_option('eshop_checkout').'&action=redirect';
     }else{
      //$p->autoredirect=get_permalink(get_option('eshop_checkout')).'&action=redirect';
      $p->autoredirect=$this_script.'/index.php?page_id='.get_option('eshop_checkout').'&action=redirect';
     }
    }

    The $p->autorediect is then added to the action part of a form. eg.
    <form method="post" action="http://eshop.quirm.net/index.php?page_id=4&amp;action=redirect">
    Until today the plugin has been working fine with the 2 commented out lines, but it appears something has changed somewhere, and I have tried many variations before coming up with the change above. But surely there must be something else wrong.

    recently my web hosting went over to php 5 - could this be why the original code no longer works? Or could it be an apache setup difference?

    I really am at a loss as to why my original code is no longer working. Especially as it works locally!

  2. elfin
    Moderator
    Posted 5 years ago #

    **UPDATE**

    also happening on a live site, and that was working until a few days ago so I'm now fairly certain this is a server issue.

  3. elfin
    Moderator
    Posted 5 years ago #

    Well its fixed, but not sure how or why.

    Updated affected site to wordpress 2.6.1 via fantastico.

    Debugged the plugin, though that is difficult with all the wordpress errors that come up...

    Changes were mainly undeclared variables, but it wasn't affecting other sites with the same setup - which was why I was stumped.

Topic Closed

This topic has been closed to new replies.

About this Topic