WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Installed in local host cannot access WP Server (25 posts)

  1. jucebone
    Member
    Posted 2 years ago #

    I cannot access WP Server via Localhost

  2. s_ha_dum
    Member
    Posted 2 years ago #

    You are going to have to provide a better description of the problem than that.

  3. jucebone
    Member
    Posted 2 years ago #

    I get the following error messages, viz.
    If I try to access eg Themes then=.

    An unexpected error occurred. Something may be wrong with WordPress.org or this server’s configuration. If you continue to have problems, please try the support forums.

    Try again
    or
    RSS Error: WP HTTP Error: Could not open handle for fopen() to http://blogsearch.google.com/blogsearch_feeds?scoring=d&ie=utf-8&num=10&output=rss&partner=wordpress&q=link:http://localhost/Wordpress_1/wordpress/

    And access to widgets etc gives error messages

  4. s_ha_dum
    Member
    Posted 2 years ago #

    I would check with your host to see if fopen() is enabled on the server. It is a PHP function but is sometimes disabled by server admins.

  5. jucebone
    Member
    Posted 2 years ago #

    Thankyou for your reply
    My host is LocalHost, so how do I check?

  6. s_ha_dum
    Member
    Posted 2 years ago #

  7. jucebone
    Member
    Posted 2 years ago #

    url-fopen-open in Php.ini

  8. jucebone
    Member
    Posted 2 years ago #

    repeat.
    the instruction in php.ini
    url-fopen-open was "open"

    Status still the same

  9. s_ha_dum
    Member
    Posted 2 years ago #

    It didn't occur to me until you said it was localhost but one problem you are going to have is that localhost means 'this computer' You are passing http://blogsearch.google.com a GET value that means "look at yourself to find jucebone's WordPress installation" That isn't going to work. You are telling blogsearch to look on http://blogsearch.google.com to find your WordPress. Just ignore it. You can't fix it.

  10. jucebone
    Member
    Posted 2 years ago #

    gee thanks fro staying with me.
    Ok
    So how do I progress the growth of a Localhost WP website, when I can't access WP.org from localhost?

  11. s_ha_dum
    Member
    Posted 2 years ago #

    What do you mean by "the growth"? What growth? If you are running on 'localhost' nobody can get to the site who isn't sitting at that machine. If you expect this to be publicly accessible you need to put it on a publicly accessible server.

  12. jucebone
    Member
    Posted 2 years ago #

    Hi,
    let's replace the word "growth" with "develop"

    IE,
    How do I develop the site in Localhost with the aim of eventually uplifting it to a WebHost?

  13. s_ha_dum
    Member
    Posted 2 years ago #

    You really shouldn't have much trouble. I do it all the time. Its my job.

    The particular error you posted isn't a problem. Just ignore it. If that fopen() shows up elsewhere then something about your server/PHP installation is broken.

    It occurs to me that 'open' isn't a proper value, and "url-fopen-open" isn't a proper key, for allow_url_fopen. Please compare your php.ini settings to this page-- http://php.net/manual/en/filesystem.configuration.php

    What is your OS?

  14. jucebone
    Member
    Posted 2 years ago #

    OS = XP Prof X3
    PHP = 5.3.13

    PHP settings = Greek to me

  15. Abhishek Ghosh
    Member
    Posted 2 years ago #

    Sometimes using IP 127.0.0.1 works instead of localhost (in wp-config.php). If WordPress is running fine otherwise ignore these 2 problems if you can not handle them. Rather download the plugins, themes manually using web browser and install them through upload function on your localhost WordPress admin panel or unzip them in plugins or themes folder and activate from WordPress admin panel.

    By the way, there is a free Software named AMPPS, it gives a cPanel or Plesk like backend. That might make you a bit easy to handle the emulated server side.

  16. jucebone
    Member
    Posted 2 years ago #

    Thank you,
    I am currently running WAMP,(with Joomla! working fine)-
    Wouldn't they conflict?
    Does this mean I must uninstall WAMP and reinstall with AMPPS?

  17. Abhishek Ghosh
    Member
    Posted 2 years ago #

    WAMP, XAMMP what ever your wish you use. I basically added an alternative with extra features.
    If you do not run both together (you have to check Windows services) there will be no problem.
    The reason is, most of these softwares uses cygwin.dll to emulate Linux environment on Windows.

  18. jucebone
    Member
    Posted 2 years ago #

    Hooray!!

    I uninstalled Wampserver 2.2 and installed AMPPS and Voila, WordPress works like a charm and so does Joomla!

    Thank you so much chaps,
    It has been a long and frustrating road, now I can get on with it

    You are stars

  19. Abhishek Ghosh
    Member
    Posted 2 years ago #

    Great.

  20. jucebone
    Member
    Posted 2 years ago #

    Hi,
    After hours of stumbling I would appear to have managed to migrate a WP website into localhost via Ampps, but when calling it up I get the following error message which is absolutely greek to me.

    PressBackup: Please change the value of prefix, on config/config.php

    Warning: Please change the value of prefix, on config/config.php in C:\Program Files\Ampps\www\ZAPolice\wp-content\plugins\pressbackup\.core\w2pf_init.php on line 54

    Fatal error: Class name must be a valid object or a string in C:\Program Files\Ampps\www\ZAPolice\wp-content\plugins\pressbackup\main.php on line 15

    Can you help once again?

  21. Abhishek Ghosh
    Member
    Posted 2 years ago #

    Rename the plugins folder for now / rename only plugin PressBackup folder.

  22. jucebone
    Member
    Posted 2 years ago #

    Wow,

    You are a star!!
    Why do you say "for now"?

  23. Abhishek Ghosh
    Member
    Posted 2 years ago #

    "For Now" because if you rename the plugin folder, plugins will not work. we had to activate one by one.

    The basic problem was - PressBack actually had the absolute path (of Linux server) to save the backups. In your PC was not matching.

    By the way, probably your database has the online site's url. If you go to Settings > General, you will see its that online ones. Replace it with the WordPress homepage (like http://localhost/ or http://localhost/wordpress/ , which actually you have.) Otherwise you will actually be redirected to online one. Next install Search and Replace Plugin and replace example.com (that is what your domain's name) with localhost's path (http://localhost/ or like that)...

  24. kanika357
    Member
    Posted 1 year ago #

    i had uploaded my website in filezilla same as in wordepress tutorial under here folder. but i am using 000wbhost.com bcoz it is free can i know the problen why it is not uploaded

  25. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @kanika357 - please start a new thread - this one is old and already marked resolved. Do so here:

    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.