WordPress.org

Ready to get started?Download WordPress

Forums

WP index stuck on first post, cannot redirect to newest post (1 post)

  1. Rick van Koert
    Member
    Posted 1 year ago #

    Hello,

    I made a mistake today and thought fixed it but from there other things went wrong and I cannot seem to find the answer, so I hope to find some help here.

    Today I "brilliantly" decided to change the general URL settings and to add "WWW" to the location of the WP folder and my site and lost the blog & admin. I fixed the subsequent lost admin access with a solution from here to add 2 lines to the function file in the themes folder, put the URL's back, removed the 2 lines from the function file and everything seemed ok. (I double checked if the file was in its original state afterwards).

    Two things happened, suddenly I got an .htaccess file in "blog" and my own .htaccess file at the root of my site was modified by WP.
    I think the trouble may be there.

    I've WP installed in "http://(www).my_site.com/site/blog/".

    Firstly if I go to http://(www).my_site.com/site/blog/ it loads my very first post from 2011. It's *not* pinned, and if I remove it by making it "private" the previous URL leads to a WP "page not found" page. Secondly the FeedBurner page is just loading the entire first post from 2011 with skin and such. So I think there's something pointing somewhere to the wrong file or directory. I just for the life of me cannot find it.

    Not sure if this helps but this is the code from the .ht file in my blog folder:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /site/blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /site/blog/index.php [L]
    </IfModule>

    # END WordPress

    And this from my sites root .ht file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /site/blog/index.php [L]
    </IfModule>

    # END WordPress

    I did some reading on .htaccess and Apache but it remains largely a mystery to me.
    Any help would be really appreciated.

    Just feeling so dumb I messed with something that worked flawlessly before. /o\
    If it ain't broken...

    --
    Rick

Topic Closed

This topic has been closed to new replies.

About this Topic