WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp-includes/widgets.php (13 posts)

  1. Arionhawk
    Member
    Posted 6 years ago #

    Okay so I've got wordpress installed, and I got to the login screen once but when I tried to login it gave me this message

    Fatal error: Cannot unset string offsets in /webroot/g/a/gaurd001/www/wp-includes/widgets.php on line 307

    now I can't access the login page or the home page. Any help is appreciated

  2. Arionhawk
    Member
    Posted 6 years ago #

    Okay so I saw that someone else had gotten the same problem and had fixed it by reinstalling everything(deleting it all and reuploading) so I tried that and now when I try to login I get this:

    Warning: Invalid argument supplied for foreach() in /webroot/g/a/gaurd001/www/wp-includes/capabilities.php on line 31

    Warning: Cannot modify header information - headers already sent by (output started at /webroot/g/a/gaurd001/www/wp-includes/capabilities.php:31) in /webroot/g/a/gaurd001/www/wp-includes/pluggable.php on line 369

    Warning: Cannot modify header information - headers already sent by (output started at /webroot/g/a/gaurd001/www/wp-includes/capabilities.php:31) in /webroot/g/a/gaurd001/www/wp-includes/pluggable.php on line 370

    Warning: Cannot modify header information - headers already sent by (output started at /webroot/g/a/gaurd001/www/wp-includes/capabilities.php:31) in /webroot/g/a/gaurd001/www/wp-includes/pluggable.php on line 331

    I am thoroughly confused. Help!!!

  3. Arionhawk
    Member
    Posted 6 years ago #

    Nevermind the last one, I fixed that and am now back to the original problem.

  4. Arionhawk
    Member
    Posted 6 years ago #

    I deleted line 307 of widgets.php and now its giving me the second problem again. I have php5 and mysql 5 so it should work shouldn't it?

  5. Arionhawk
    Member
    Posted 6 years ago #

    It was a problem with the php settings on my server all fixed now.

  6. golfing22
    Member
    Posted 6 years ago #

    Arionhawk, I'm having the same problem as you did, do you mind posting the solution??

  7. moshu
    Member
    Posted 6 years ago #

    Read it again:

    It was a problem with the php settings on my server all fixed now.

    Which means, probably, your host has to fix it.

  8. golfing22
    Member
    Posted 6 years ago #

    I guess I forgot to mention that I am the server admin and I run the machine that wordpress is being installed on.

  9. moshu
    Member
    Posted 6 years ago #

    Unfortunately, we do not support server admin issues. You will need to seek support in a more specialized forum. When your server works, we will be happy to assist you with any WP related question.

  10. Arionhawk
    Member
    Posted 6 years ago #

    I had asp_tags, magic_quotes_runtime, and magic_quotes_gpc turned on once I turned those options off, it worked, I hope this helps.

  11. golfing22
    Member
    Posted 6 years ago #

    Thank you Arionhawk, WordPress is now working perfectly.

  12. Arionhawk
    Member
    Posted 6 years ago #

    You are welcome!

  13. dmry
    Member
    Posted 6 years ago #

    Download http://file.dmry.net/blog/01/wp_user_roles_yama.zip patch file and upload in root directory of wordpress. Finally call it on URL (http://your_blog_url../wp_user_roles.php)

    Before appyling patch, backup your database..

    For this patch, I write a manual, but in Turkish. If you want, you can read or translate with any service..

    Patch URL: http://www.dmry.net/wordpress-231-kullanici-yetkileri-yamasi

    THIS PATCH ONLY FOR WP 2.3.x

Topic Closed

This topic has been closed to new replies.

About this Topic