WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP in Subdirectory changes but... (6 posts)

  1. felinawi
    Member
    Posted 1 year ago #

    The theme I am using seemingly has a ghost home page - its not a physical page under pages.

    I started my site in a subdirectory and was playing for awhile. Then decided that I was kind of ready to have it accesses just by typing in my domain netsolutionswi.com (so that may main page was in the root directory) I made sure I followed everything in the tutorial and it worked great.

    However, when you click my "home" button on the nav bar it still is trying to access home from the sub directory (netsolutionswi.com/ns_wp/ - However if you click my logo it takes you home (netsolutionswi.com) just fine. I cannot figure out what needs to be changed yet. I was trying to find out where this url was called from with the Chrome tools... but I am unsure. I was thinking it was the home.php?

    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  2. Timothy Jacobs
    Member
    Posted 1 year ago #

    Is the home button from the wordpress menu system?

  3. felinawi
    Member
    Posted 1 year ago #

    yes its like its built in to the wordpress theme?... its strange for me... I like physically having a home page - this "home" which handles the slider on the front page was just automatically part of the theme... or is it part of wordpress? I dunno... this wordpress directory structuring is something I have not yet mastered...

    When I built my menu - it was listed as Home:Home when selecting pages...

    I hope I am making sense?! Sorry if I am just being more confusing.

    Can you help? I know it must be a very easy fix.. I just do not want to go around "trying" things and then have things break.

    Thank you for your reply!

    Have a wonderful day!

  4. Timothy Jacobs
    Member
    Posted 1 year ago #

    The easiest thing to do would be do remove the home button from your menu, and then creating a custom link on the top left that points to netsolutionswi.com and just make the label Home.

    Also make sure that under Settings->General that the two urls are the same.

  5. felinawi
    Member
    Posted 1 year ago #

    LOL Timothy... thank you soo much! - See I knew it would be an easy fix.. when I went to delete that home button to remove it ... the little arrow next to it said "custom" I clicked on it and there was that url... its all fixed... I am actually embarrassed... that was a "duh" moment.. i just kept looking through code trying to figure out where that was coming from! :( So sorry - and thank you!

    Have a wonderful day... I do not know where you live but here in Wisconsin we have a blizzard!! Yikes!

  6. Timothy Jacobs
    Member
    Posted 1 year ago #

    Haha, no problem! We just got over some snow in NY. Stay safe!!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.