WordPress.org

Ready to get started?Download WordPress

Forums

WP in own directory 404 issue with static home page (5 posts)

  1. venntom
    Member
    Posted 2 years ago #

    Installed WP in subdir www.xxxx.com/wp-main
    Performed the index.php/htaccess/permalinks "Own Directory" changes per WP codex.
    WP works fine when visitors go to www.xxx.com. Admin pages work ok as well

    BUT: there is one link that doesn't work.
    Namely when a visitor goes to www.xxxx.com/wp-main they get a 404 page instead of the defined static home page.
    (www.xxxx.com/wp-main is the link that is sent to them during the registration process...even after the "Own Directory" changes)

    Anybody with ideas how to redirect www.xxxx.com/wp-main properly to www.xxxx.com?

  2. mbrsolution
    Member
    Posted 2 years ago #

    Hello, you have to change the .htaccess file and point it to the correct path.

    Have a look at this link http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

    Kind regards

  3. govpatel
    Member
    Posted 2 years ago #

    Did you copy index.php file or moved it as you still need to have index.php file in directory and did you reset your permalinks after you changed the urls Settings >>>General

  4. venntom
    Member
    Posted 2 years ago #

    Hi,

    As stated previoulsy, I followed the instructions at http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory up to the letter.
    Incl. copying index.php, .htaccess and resetting permalinks
    Settings - WP URL is http://www.xxxx.com/wp-main
    Settings - Site URL is http://www.xxxx.com
    etc...

    Everything works well(*), except this one link: www.xxxx.com/wp-main
    (*) for example even www.xxxx.com/wp-main/contact will redirect nicely to www.xxxx.com/contact. And my backend is correctly accessible via www.xxxx.com/wp-main/wp-admin.
    But www.xxxx.com/wp-main will result in 404 instead of the static home page that is shown correctly with www.xxxx.com

    My .htaccess in / is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    My .htaccess in /wp-main is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /wp-main/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /wp-main/index.php [L]
    </IfModule>
    # END WordPress

    Appreciate any input towards resolution...or is this a known flaw as indicated in some other posts ;-(

  5. mbrsolution
    Member
    Posted 2 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic