WordPress.org

Ready to get started?Download WordPress

Forums

WP-Facebookconnect and comments avatar (3 posts)

  1. pogo84
    Member
    Posted 1 year ago #

    hi there,

    I've bought a pinpress theme made some modifications but I'm stuck on one thing... and it's seems developer can't handle the problem...

    There'is build in WP-Facebook Connect plugin... it's working fine, for connecting with your FB account, but when you add local avatar it's only visible when typing comment, when you add/confirm comment and refresh site it's showing... default no-avatar image... (fb user picture also not showing)

    comments.php file looks like

    <?php if (have_comments()): ?>
    	<div class="commentslist">
    
    		<ul>
    			<?php wp_list_comments( array( 'callback' => 'comments_on_page' ) ); ?>
    		</ul>
    		<div class="clear"></div>
    
    	</div>
    <?php endif;?>
    
    <?php if ('open' == $post->comment_status) : ?>
    
    <?php if ( is_user_logged_in() ) : ?>
    
    	<?php global $current_user; get_currentuserinfo(); ?>
    
    	<div class="comment-form <?php if (!have_comments()): echo "comment-form-border"; endif; ?>">
    		<ul>
    			<li>
    				<p class="avatarimg">
    
    					<?php if (/*avatarcheck($current_user->ID, $current_user->user_email) &&*/ strlen(get_avatar($current_user->ID, 50)) > 0) { ?>
    
    					<?php echo get_avatar($current_user->ID, 50); ?>
    					<?php } else { ?>
    						<img src="<?php bloginfo("template_url"); ?>/images/no-avatar-50-50.png" alt="No Avatar" class="avatar photo"  width="50" height="50" />
    					<?php } ?>
    				</p>
    				<div class="form">
    					<form action="<?php echo get_option('siteurl'); ?>/wp-comments-post.php" method="post" id="commentform">
    					<p>
    						<label for="comment" class="hide">Comment:<br /></label>
    						<textarea name="comment" id="comment" rows="5" cols="30" class="<?php // if (!get_avatar( $current_user->ID, 50 )) { echo "textarea-full"; } ?>"></textarea>
    					</p>
    					<p class="submit <?php // if (!get_avatar( $current_user->ID, 50 )) { echo "submit-full"; } ?>">
    						<input name="submit" type="submit" id="submit" value="Skomentuj" /> <span class="required"> * wpisz komentarz</span>
    						<?php comment_id_fields(); ?>
    						<?php do_action('comment_form', $post->ID); ?>
    					</p>
    					</form>
    				</div>
    				<div class="clear"></div>
    			</li>
    		</ul>
    		<div class="clear"></div>
    	</div>
    
    <?php else: ?>
    
    	<p class="noregistered <?php if (have_comments()): echo "noregistered-comments" ; endif; ?>" style="color:<?php echo get_option('pinpress_' . $GLOBALS['themeprefix'] . '_post_text_color'); ?>"><a href="<?php bloginfo("url"); ?>/wp-login.php">Zaloguj sie</a> by skomentowac.</p>
    
    <?php endif; ?> 
    
    <?php endif; ?>
  2. samz2021
    Member
    Posted 1 year ago #

    @pogo84 i have a friend with lots of issues with pinpress theme. You not get response because it is anew & buggy theme. I have a taking a closer look at the theme. Will get back to you soon I figure out what the issue are.

  3. pogo84
    Member
    Posted 1 year ago #

    @samz2021 I've deactivated WP-Facebook Connect plugin, deleted code from theme and installed AWD facebook plugin, and for now it's working good :)
    you can see it on pingirl.pl

Topic Closed

This topic has been closed to new replies.

About this Topic