WordPress.org

Ready to get started?Download WordPress

Forums

WP Editor is broken - BUG? (8 posts)

  1. Treebeard
    Member
    Posted 1 year ago #

    Since the upgrade the WP editor went nuts!!

    I tried Preserved HTML Editor Markup, but didn't fix the issue either. Lines are all crazy, separating P and BR doesn't work (can't really control it, it sort of does whatever it wants). I can't even add links anymore, without it breaking it up into broken HTML, separating the beginning link tag, then the p tag, then an ending p tag, before the end of the link begins, it's totally crazy in there.

    I'm using TinyMCE Advanced, but even when I turn it off, the editor is still messed up. Does anyone know what's going on?

    I have several sites like this - not just the one site, I'm a web developer, so I'm working on a handful of sites right now that all have the same editor issues, and they all have different plugins installed so I can't even begin to narrow down a plugin for this one, there's too many.

    Anyone know what happened to the editor, a way to fix it or if they're going to release a WP update soon with a fix?

  2. Have you looked at the 3.5 Master List? You may be having javascript issues.

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    You can enable your browser's console using these instructions.

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    Let us know if you are having js problems.

  3. Hi @ malawimama

    Sorry to hear that you are having these issues since the upgrade.

    What I would do if I were you is pick one of your site that's doing this.
    Deactivate all the plugins on that site and see if that helps. If it does, then reactivate your plugins one by one to try to find the culprit

    If once you've deactivated all the plugins you still get errors, the try to switch to the Twenty Twelve theme and see if that fixes it.

    You may want to look at the 3.5 Master list as well - http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list?replies=4

    If your theme is not enqueuing jQuery properly that could be the issue.

  4. Treebeard
    Member
    Posted 1 year ago #

    Thanks, I'll check those links out and see if anything stands out, and also try deactivating all plugins on one of these. I code templates from scratch, simple coding, nothing extravagant, maybe CSS3 stuff, but no major php or anything, and I don't enqueue javascript at all in there, but maybe it's something else.

  5. dcapb
    Member
    Posted 1 year ago #

    I'm having trouble, too, with how the WP Post Editor displays since I updated to WP 3.5. The text/visual toggle button does nothing--only html code displays--and the code is crammed in a narrow little window that makes it tedious to edit. You can see a screenshot here: http://ifchristiansknew.org/wpeditorwindow.png

    Here's what I've tried so far; none of thse made any difference:
    1) I've used two different updated browsers--Opera & Firefox.
    2) I deactivated all plugins.
    3) I switched to the TwentyEleven theme
    4) I followed all the steps in "Using Your Browser to Diagnose JavaScript Errors"

    Initially, after updating to 3.5, I could not edit post text or create a new post. I sovled that problem by removing all of the BulletProof Security code from my .htaccess Below you will find my current .htaccess and wp-config.php (brackets [] enclose stuff I've changed for security reasons).

    # BEGIN Better WP Security
    Options All -Indexes
    
    <files .htaccess>
    Order allow,deny
    Deny from all
    </files>
    
    <files readme.html>
    Order allow,deny
    Deny from all
    </files>
    
    <files install.php>
    Order allow,deny
    Deny from all
    </files>
    
    <files wp-config.php>
    Order allow,deny
    Deny from all
    </files>
    
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    
    RewriteCond %{REQUEST_METHOD} ^(HEAD|TRACE|DELETE|TRACK) [NC]
    RewriteRule ^(.*)$ - [F,L]
    RewriteCond %{QUERY_STRING} \.\.\/ [NC,OR]
    RewriteCond %{QUERY_STRING} boot\.ini [NC,OR]
    RewriteCond %{QUERY_STRING} tag\= [NC,OR]
    RewriteCond %{QUERY_STRING} ftp\:  [NC,OR]
    RewriteCond %{QUERY_STRING} http\:  [NC,OR]
    RewriteCond %{QUERY_STRING} https\:  [NC,OR]
    RewriteCond %{QUERY_STRING} (\<|%3C).*script.*(\>|%3E) [NC,OR]
    RewriteCond %{QUERY_STRING} mosConfig_[a-zA-Z_]{1,21}(=|%3D) [NC,OR]
    RewriteCond %{QUERY_STRING} base64_encode.*\(.*\) [NC,OR]
    RewriteCond %{QUERY_STRING} ^.*(\[|\]|\(|\)|<|>|ê|"|;|\?|\*|=$).* [NC,OR]
    RewriteCond %{QUERY_STRING} ^.*("|'|<|>|\|{||).* [NC,OR]
    RewriteCond %{QUERY_STRING} ^.*(%24&x).* [NC,OR]
    RewriteCond %{QUERY_STRING} ^.*(%0|%A|%B|%C|%D|%E|%F|127\.0).* [NC,OR]
    RewriteCond %{QUERY_STRING} ^.*(globals|encode|localhost|loopback).* [NC,OR]
    RewriteCond %{QUERY_STRING} ^.*(request|select|insert|union|declare).* [NC]
    RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in_.*$
    RewriteRule ^(.*)$ - [F,L]
    RewriteRule ^dyrlogin wp-login.php?[REDACTED] [R,L]
    RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in_.*$
    RewriteRule ^[REDACTED] wp-login.php?[REDACTED]&redirect_to=/wp-admin/ [R,L]
    RewriteRule ^[REDACTED] wp-admin/?[REDACTED] [R,L]
    RewriteRule ^register wp-login.php?[REDACTED]&action=register [R,L]
    RewriteCond %{HTTP_REFERER} !^(.*)[MY SITE URL]/wp-admin
    RewriteCond %{HTTP_REFERER} !^(.*)[MY SITE URL]/wp-login\.php
    RewriteCond %{HTTP_REFERER} !^(.*)[MY SITE URL]/dyrlogin
    RewriteCond %{HTTP_REFERER} !^(.*)[MY SITE URL]/[REDACTED]
    RewriteCond %{HTTP_REFERER} !^(.*)[MY SITE URL]/register
    RewriteCond %{QUERY_STRING} !^[REDACTED]
    RewriteCond %{QUERY_STRING} !^action=logout
    RewriteCond %{QUERY_STRING} !^action=register
    RewriteCond %{HTTP_COOKIE} !^.*wordpress_logged_in_.*$
    #RewriteRule ^wp-login\.php not_found [L]
    </IfModule>
    
    # END Better WP Security
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    
    <?php
    /** WordPress's config file **/
    /** http://wordpress.org/   **/
    
    // ** MySQL settings ** //
    define('WP_CACHE', true); //Added by WP-Cache Manager
    define('DB_NAME', '[MY BLOG'S DBASE]');     // The name of the database
    define('DB_USER', '[MY USERNAME]');     // Your MySQL username
    define('DB_PASSWORD', '[MY PASSWORD]'); // ...and password
    define('DB_HOST', '[MY DBASE HOST]');     // ...and the server MySQL is running on
    define('EMPTY_TRASH_DAYS', 7 );
    define('AUTH_KEY',         '[REDACTED]');
    define('SECURE_AUTH_KEY',  '[REDACTED]');
    define('LOGGED_IN_KEY',    '[REDACTED]');
    define('NONCE_KEY',        '[REDACTED]');
    define('AUTH_SALT',        '[REDACTED]');
    define('SECURE_AUTH_SALT', '[REDACTED]');
    define('LOGGED_IN_SALT',   '[REDACTED]');
    define('NONCE_SALT',       '[REDACTED]');
    
    // Change the prefix if you want to have multiple blogs in a single database.
    
    $table_prefix  = 'wp_fy3dcz_';   // example: 'wp_' or 'b2' or 'mylogin_'
    
    // Change this to localize WordPress.  A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');
    
    /* Stop editing */
    
    $server = DB_HOST;
    $loginsql = DB_USER;
    $passsql = DB_PASSWORD;
    $base = DB_NAME;
    
    define('ABSPATH', dirname(__FILE__).'/');
    // define('SCRIPT_DEBUG', true);
    
    // Get everything else
    require_once(ABSPATH.'wp-settings.php');

    ?>

  6. dcapb
    Member
    Posted 1 year ago #

    P.S. I deactivated and removed BulletProof Security some months ago.

  7. dcapb Could you please start your own topic? It's considered impolite when you interrupt someone else's that way.

    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    Your problem may not have anything to do with the OP.

  8. dcapb
    Member
    Posted 1 year ago #

    Sorry, Jan, I didn't realize I was being impolite. I thought I was having the same problem as malawimama. Maybe not. I don't know what "the OP" is. In any case, my problem was resolved when I changed permissions on the wp-include directory to 755 from 750.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.