WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
wp-e-commerce/readme.txt (6 posts)

  1. bamajr
    Member
    Posted 3 years ago #

    The WP e-Commerce plug-in does not specify that it has been tested in version 3.2.1 in the readme.txt file.

    Requires at least: 3.0
    Tested up to: 3.2

    Has it or hasn't it?

    If it has, why is the "Tested up to:" line only reflecting version 3.2?

    The information listed on the WordPress Plugin page says its compatible up to version 3.2.1 but the readme.txt file doesn't state that it has been tested in version 3.2.1 - so I'm wondering how you know it is compatible with the version 3.2.1 of WordPress if it hasn't been tested in version 3.2.1?

  2. Lee Willis
    Member
    Plugin Author

    Posted 3 years ago #

    If it has, why is the "Tested up to:" line only reflecting version 3.2?

    It only tends to get updated when the plugin itself gets a new version.

    The information listed on the WordPress Plugin page says its compatible up to version 3.2.1 but the readme.txt file doesn't state that it has been tested in version 3.2.1 - so I'm wondering how you know it is compatible with the version 3.2.1 of WordPress if it hasn't been tested in version 3.2.1?

    The compatibility box is "user-voted" rather than provided by the plugin authors, so I guess it's because plenty of people are using it I guess :)

  3. bamajr
    Member
    Posted 3 years ago #

    You are referring to the "Compatibility" box...

    4 people say it works.
    3 people say it's broken.

    where users vote for "Broken" or "Works" and I'm referring "Compatible up to:" section...

    Requires WordPress Version: 3.0 or higher
    Compatible up to: 3.2.1
    Last Updated: 2011-7-7
    Downloads: 1,225,405

    directly above the rating system. As far as I'm aware, that area is where the developer advertises which versions of WordPress their plug-in will work with.

  4. Lee Willis
    Member
    Plugin Author

    Posted 3 years ago #

    Ah, ok. I see what you mean now. The section that says:

    Compatible up to: 3.2.1

    is in fact driven from the readme.txt file that the developer populates. However - the wordpress.org site takes its information from the "trunk" release in SVN, not the latest tagged release. This allows the developers to flag things like this without doing a whole new release.

    The reason that the downloaded plugin says differently is because that was the status when it was "tagged" and packaged up.

  5. bamajr
    Member
    Posted 3 years ago #

    I find this weird and annoying. Some plug-in developers get this right, others do not.

    I use a plugin called Better Plugin Compatibility Control which supposedly uses a mix of the voting area and the readme.txt file, yet they don't even updated their own plug-in correctly.

    I posted this same issue for them here: Better Plugin Compatibility Control

    It is odd to me how some plug-in developers have no problem with this, but many (I'd go as far as saying most) do.

  6. Lee Willis
    Member
    Plugin Author

    Posted 3 years ago #

    I'm sorry, but I just don't understand what the problem is?

    When deciding to install, or update a plugin go with the information provided on the download page. It should be the most up-to-date. You shouldn't need to concern yourself with what's in the readme.txt of the zip you actually download?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic