WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
wp-e-commerce installation fails (5 posts)

  1. Pat K
    Member
    Posted 2 years ago #

    I attempted to install wp-e-commerce and it failed during installation.
    As a result, I could not access admin (I encountered a blank screen with an error message - sorry, I didn't save the error message. To restore admin function, I had to delete the plugin from wp-content/plugins/

    http://wordpress.org/extend/plugins/wp-e-commerce/

  2. Pat K
    Member
    Posted 2 years ago #

    Update: it's not the plugin - it's a memory problem.

    I was able to install wp-e-commerce only after doing each of the following (I tried this MANY different ways before getting it to work):
    1) create a file called php.ini (using a text editor) and adding the following:

    ;; set memory limit for cache.php
    memory_limit = 128M

    ...upload (FTP or cPanel File Manager) the php.ini file in 3 places;
    - above the root directory
    - in the root directory (public_html or www)
    - and in the wp-includes directory

    2) Add the following line below the opening <?php tag in the file wp-includes/cache.php:
    ini_set('memory_limit','128M'); // set memory to prevent fatal errors

    (...yes it's modifying a core file, but it works!...just make a note of the modification)

    After that, create an htaccess file for the wp-includes directory and insert the following directive:

    3) Use a text editor to create a .htaccess file and add the following:

    # set memory limit for cache.php
    php_value memory_limit 128M

    ...upload the .htaccess file to the wp-includes directory.

    Log out of admin, clear browser cache, login and install the module.

    See the following for details:
    http://perishablepress.com/press/2008/02/17/wordpress-error-fix-increase-php-memory-for-cachephp/

    I hope this helps...

  3. Pat K
    Member
    Posted 2 years ago #

    Udate: adding the .htaccess file to the /wp-includes/ directory broke the WYSIWYG editor. Try removing it after installing the wp-e-commerce plugin...WYSIWYG mode should work again.

  4. ahoyroo
    Member
    Posted 1 year ago #

    I have the same white / blank screen issue after trying to install either wp e-commerce or Ready! eCommerce plugins. Basically the back office disappears when you install or activate these plugins and the only way to get it back is to delete the entire folder from the plugins directory using FTP. With WP Ecommerce both the website front end and back office crashed but with Ready Ecommerce only the back office screens for Pages and Plugins / Pages / Appearance / Settings become inaccessible (I can still log in and see the Dashboard home page but little else).

    My host assures me that the problem is not memory related and indeed I have Plesk server admin tool access and have double checked memory allocations for the domain name several times.

    So I wonder if it is a conflict with another plugin? Here's what I have installed, with Theme 'Responsive' and a very basic 3 page website so far:
    Accordion Shortcode
    All in One SEO Pack
    Contact Form 7
    Custom Permalinks (number 1 suspect for conflict with WP Ecommerce)

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    Please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic