WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP doesn't like my domain masking (2 posts)

  1. jeremyduffy
    Member
    Posted 5 years ago #

    My site is hosted at http://cox.battleclinic.com but I want it to be accessed via http://www.jordans-town.com.

    I have the domain and I'm using port forwarding and masking. The problem is that my masking is done by showing my target site in a frame. I don't know if that's normal or not (I suspect not), but WP doesn't like it.

    If I try to set WP to use the jordans-town domain, my data is there, but not the stylesheet and I can't log in either. If I set it for the battleclinic domain, everything works fine, but because it's in a frame, when I click links, I don't see anything but jordans-town.com in the address bar which breaks both permalinks and passing data with forms.

    The simplest thing I can think of to do is hack the permalink function to return the desired site instead of battleclinic or possibly change the value that get_bloginfo("url") returns (if that's possible). Hopefully if I do that in my header.php file, it won't break the rest of the page, just change the links from battleclinic to jordans-town

    Or is there a much easier way to do this that I'm not thinking of? Is there something screwy with my domain masking (it shouldn't work that way should it?)

  2. jeremyduffy
    Member
    Posted 5 years ago #

    Nvm. Domain masking isn't the way to do what I was trying to do.

Topic Closed

This topic has been closed to new replies.

About this Topic