WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp-db-backup schedule not working (4 posts)

  1. galbaras
    Member
    Posted 4 years ago #

    When I set the time for the next backup, select "weekly" and hit "schedule backup", the next backup time is advanced to exactly 1 week from NOW, instead of the time I've set.

    Regardless (and more importantly), when the time comes, the backup is not performed.

  2. galbaras
    Member
    Posted 4 years ago #

    Calling ilfilosofo / Austin Matzko,

    I've experimented some more and looked at the code. Both when the next schedule time is displayed and when it's saved, the following expression is used to determine or set the time:

    $time + (get_option('gmt_offset') * 3600))

    The problem is that this always ADDS the GMT Offset and keeps advancing the time whenever I click "Change".

    Also, when a names timezone is selected on the General options page (new feature), such as "Brisbane", the gmt_offset option is CLEARED (the time zone is saved in the option 'timezone_string'), which means the backup will run at the wrong time, unless manually adjusted.

    A workaround I'm using now is setting the gmt_offset to 0 manually. It's incorrect, but I'm hoping it'll work.

  3. NickCorcodilos
    Member
    Posted 4 years ago #

    @galbaras: Yours is the only identification of the problem and the only solution I've been able to find. However, I'm not a PHP expert by a long shot! I wonder if you would explain exactly how to make this modification so this plugin will work? Thanks for your consideration, and if you don't have time to do this, thanks anyway for pointing out the problem!

  4. galbaras
    Member
    Posted 4 years ago #

    @NickCorcodilos: oddly enough, my problem now seems to be gone, which tells me that maybe something was fixed by my upgrade to WP 3.0, the many plugin updates since then or something on my (hosted) server.

    I would hesitate to change the code without the developer's blessing, which is why I didn't change my own sites, so this is not something I can tell anyone else how to do.

    Sorry.

    One thing I've noticed was that the "next scheduled time" always seems to be relative to "now", so I just wait for the right time, set it correctly and then I don't worry about it anymore, because it keeps working.

Topic Closed

This topic has been closed to new replies.

About this Topic