WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP-db-backup creates file, but no email is sent (20 posts)

  1. galbaras
    Member
    Posted 3 years ago #

    After updating the plugin (twice) in the past couple of weeks, two of my blogs have stopped sending me the backup email. I've just checked their backup directories and backups were created, one was even compressed, but they weren't sent.

    I'm using the WP Mail Queue plugin, if it makes any difference, but only on one of these blogs and it doesn't explain why some backups aren't even compressed.

  2. Austin Matzko
    Member
    Posted 3 years ago #

    How big are the uncompressed backup files? If they're huge it might be that your server times out before it can complete the compression.

    I'm not familiar with the WP Mail Queue plugin, but I wouldn't be surprised if it caused the backup emails not to be sent.

  3. obliviousinvestor
    Member
    Posted 3 years ago #

    I'm having a similar problem in that it appears that the files are being created, but no email is being sent.

    I'm not using any mail-related plugins.

    At least, I think those are the right files. They're .sql files that end in the date, then an underscore, then 3 more digits. The files are each ~ 19,600KB.

    Any ideas?

  4. Austin Matzko
    Member
    Posted 3 years ago #

    19MB is pretty big for an attachment. I wouldn't be surprised if your host's email server was rejecting them. You should contact your host and ask if there's a maximum allowed size in sent emails.

  5. obliviousinvestor
    Member
    Posted 3 years ago #

    Hi Austin. Thanks for such a speedy reply. :)

    I'm on a "dedicated virtual" server with Media Temple. According to their knowledge base, there's no limitation on email size for DV users.

  6. Austin Matzko
    Member
    Posted 3 years ago #

    Can you check the web server logs, then, and see if there are any error messages?

  7. obliviousinvestor
    Member
    Posted 3 years ago #

    Sorry, took a bit to figure out how/where to do that. :)

    I have this error message: PHP Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 20115289 bytes) in /var/www/vhosts/obliviousinvestor.com/httpdocs/wp-content/plugins/wp-db-backup/wp-db-backup.php on line 1025, referer: http://www.obliviousinvestor.com/wp-admin/tools.php?page=wp-db-backup

    Admittedly, I don't really know what that means or what to do about it. I'm guessing it means you're right re: email size. But is there any option at that point other than doing backups manually all the time?

  8. Austin Matzko
    Member
    Posted 3 years ago #

    Your PHP memory size of ~33MB is really low for WordPress. I'm surprised you haven't run into other problems. I would set that no lower than 128MB. Normally, you would do this by setting the line memory_limit = 128MB in php.ini, but I don't know if there's a control panel way of doing that for your virtual server.

  9. Austin Matzko
    Member
    Posted 3 years ago #

    Looking around, I guess a number of people recommend 64MB for WP, but I would go higher if your system has the resources. 64MB might be sufficient for solving this issue, though. Basically the problem is that the server is trying to read that file into memory so it can make a gzipped version, and 19MB takes up the majority of the allotted 32MB, which is being used elsewhere.

  10. obliviousinvestor
    Member
    Posted 3 years ago #

    Sorry, took me a while again to figure out exactly what to do to set the memory limit higher.

    But...it worked! Thank you for your help. :D

  11. mardi@eatlivetravelwrite
    Member
    Posted 3 years ago #

    I have the same problem - even when I manually do a backup, it will not sent to my email, though it says it has. I have unlimited memory limit allotment so not sure what to do now.

  12. Austin Matzko
    Member
    Posted 3 years ago #

    mardi, if you say "unlimited memory" I think you must mean disk space, not server memory. PHP memory must be limited to something; your host should know what that number is.

  13. mardi@eatlivetravelwrite
    Member
    Posted 3 years ago #

    Thank you - I had my web person change the memory allocation and doubled it from 64 to 128. Backup worked!

  14. f00f
    Member
    Posted 3 years ago #

    I think there is a way to compress files in chunks, see my post here:
    http://wordpress.org/support/topic/plugin-wp-db-backup-the-backup-file-is-not-compressed#post-1882135

  15. galbaras
    Member
    Posted 3 years ago #

    I use 64M on all my blogs, yet some of them fail (granted, it's only the biggest one now) and most don't.

    When gzipping manually, there's no problem and the compressed file is fine.

    Do I also need to change the setting in wp-config.php?

  16. galbaras
    Member
    Posted 3 years ago #

    So now I'm on 128M and the scheduled backup worked OK. Maybe that's what it was. Another blog that's still on 64M produced nothing, although it updated its schedule.

    Austin, what about improving the logging of errors?

  17. Fitzroyalty
    Member
    Posted 3 years ago #

    Same problem with single install of 3.04. Downgrading to 2.2.2 fixed the problem. My zipped backup is only 3mb. I think the problem is with 2.2.3.

  18. galbaras
    Member
    Posted 3 years ago #

    As embarrassing as it is to admit, I've just found my last backups, complete and zipped, in my ... suspected spam folder :P

    New computer, new setup. Sorry, Austin. Your plugin works on all my sites and having enough memory fixed it for me (with 128M for the larger site). Thank you for your support.

  19. orenlebbo
    Member
    Posted 3 years ago #

    hi.
    i'm having the same problem..
    how can i change the php memory to 128mb ?
    thanks

  20. galbaras
    Member
    Posted 3 years ago #

    In your .htaccess file, add the following line:

    php_value memory_limit 128M

    In your wp-config.php file, add the following line:

    define(’WP_MEMORY_LIMIT’, ’128M’);

    Both files should be located in your public_html directory on the server and you can access them through your hosting interface's file manager or via FTP.

    If this doesn't mean anything to you, get someone to help you, because you don't want to do the wrong thing to either file.

    Either way, BACK THEM UP before you make the changes.

Topic Closed

This topic has been closed to new replies.

About this Topic