WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP-Cumulus problems with widith (7 posts)

  1. olafpix
    Member
    Posted 4 years ago #

    Hello, I have a problem including Cumulus on a blog, since it doesnt seem to read width and height parameters.
    I have no problems inserting it in index.php, but it just does not read the following parameters:

    //initially set the options
    function wp_cumulus_install () {
    $newoptions = get_option('wpcumulus_options');
    $newoptions['width'] = '220';
    $newoptions['height'] = '180';

    My theme has no sidebar, so I'm not allowed to use the widget, I just put <?php wp_cumulus_insert(); ?> in index.php code.

    Here's the page: http://www.iuter.com/blog, but i'm going to hide the tag cloud again in a couple of hours.

    Thank you very much in advice, Olaf

  2. Roy Tanck
    Member
    Posted 4 years ago #

    There's no need to edit the plugin's code. Simply go to Settings -> WP-Cumulus and change the width there.

  3. olafpix
    Member
    Posted 4 years ago #

    thank you!

  4. BergyOnWP
    Member
    Posted 4 years ago #

    Hi. I am also having size problems. I am using your very latest (version 1.23 of WP-C and also v2.8.6 of WP) and have not been able to control the size by using the dashboard controls under Settings -> WP-Cumulus as instructed. Through Firebug I can see where the width is set are within the code - and If I change it with Firebug, I get the size I am looking for, but I cannot change them permanently within the app. I use Thesis as my theme, so I don't know if that is interfering in any way (It shouldn't). It's just not picking up the settings and applying them. I tried with and without compatibility mode checked. Stuck at a 160 x 160 cloud when the parameter is set for 220 x 165. The colors are also not changing from the settings control, nor are the controls over tags/categories/both. And I also tried deactivating/deleting and reinstalling with no impact. Please help. - Thank you, Alan

  5. Roy Tanck
    Member
    Posted 4 years ago #

    Alan, are you using the widget? It has its own set of settings. Simple click the small arrow to open it up and change them.

    Because you can use Cumulus on pages (by using the [wp-cumulus] shortcode) and as a widget, both with different sizes and colors, I had to implement separate settings screens for both options.

  6. BergyOnWP
    Member
    Posted 4 years ago #

    Hi. You nailed it. I was making the changes in the settings, not on the widget. Much better now. You're a genius!

    One more question - How can I eliminate any posting marked as "unclassified" so that "unclassified does not show up in the cloud?

    thanks for your help - Alan

  7. Roy Tanck
    Member
    Posted 4 years ago #

    If 'unclassified' is a tag you can use the wp_tag_cloud parameters to filter it out. If it's a category you'd have to edit the plugin code I'm afraid (and your changes would be overwritten every time the plugin is updated.

Topic Closed

This topic has been closed to new replies.

About this Topic