WordPress.org

Ready to get started?Download WordPress

Forums

WP converts characters - how to turn off? (22 posts)

  1. xrlq
    Member
    Posted 10 years ago #

    I cited subsection (c) [left paren, c, right paren] of a statute, only to have WP "correct" that reference to the symbol ©. Is there a way to turn off this dreadful "feature?"

  2. Mark (podz)
    Support Maven
    Posted 10 years ago #

    If it's only a few characters that do this, could you just input the ascii codes instead ?
    (c)
    (c)

  3. xrlq
    Member
    Posted 10 years ago #

    I suppose that would work, but it's a bit cumbersome. Is there no way to tell WP simply to take characters at face value?

  4. carthik
    Member
    Posted 10 years ago #

    May I suggest using the WP encoder to convert characters to codes?
    WP intelligently converts boring text into well formatted text, and like any intelligent system, has it's blind spots, I guess. This reminds of Microsoft word, which provides some unsolicited formatting help, ever so often.

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    Heck. Lets hope WP does not remind us of Word too often. :-)

  6. randybrown
    Member
    Posted 10 years ago #

    It might be a good idea to incorporate an "encode" button on the "Quicktags" panel.
    <rb>

  7. Anonymous
    Unregistered
    Posted 10 years ago #

    Why? That is the correct character for copyright, after all.

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    Try to read and edit long posts containing á é í ó ú à ã â with this characters converted to ASCII codes...

  9. xrlq
    Member
    Posted 10 years ago #

    Well, gee, if it's the correct code for copyright, I guess that must mean it's also the correct code for any other reason one might have for typing the sequence "(c)." My readers will never know what Section 18-9-204.5(c) of the Colorado Revised Statutes says, but hey, at least they'll know that Section 18-9-204.5 is copyrighted.

  10. carthik
    Member
    Posted 10 years ago #

    anon must have been confused, xrlq.

  11. carthik
    Member
    Posted 10 years ago #

    That's wp-includes/vars.php :). This will disable the texturize engine for all posts.

  12. OmarBradley
    Member
    Posted 10 years ago #

    When I type in a new post and include the characters, "It's " the blog shows "It’s"
    Is this a browser issue, or WP converting things?

  13. carthik
    Member
    Posted 10 years ago #

    Neither, I guess. It must have to do with the character encoding used by your weblog. UTF-8 will perhaps give you the most mileage, since a lot many characters can be represented using it.
    WordPress converts the plain ' to a more curly ' which looks better. The curly ' is a different character from the plain jane ' and so it requires to be displayed properly. You can be assured it is not a browser problem, since most WordPress users use curly ' by default, thanks to WordPress.
    You should probably choose a character encoding and specify it in the options page.

  14. OmarBradley
    Member
    Posted 10 years ago #

    Hmmmm. I wrote the post in MS Word (perhaps a bad idea), then pasted into notepad, and then into WP post box.
    When I re-type the entry by hand, everything works out fine.
    Does anyone else use a different editor, then paste into WP?

  15. carthik
    Member
    Posted 10 years ago #

    You can use some text editor that does not do any styling and saves the data as pure ascii.
    I often use notepad, or even wordpad, if that's what you are looking for.

  16. OperaManiac
    Member
    Posted 10 years ago #

    just search and replace word's curly quotes ’ to '

  17. lars
    Member
    Posted 10 years ago #

    I use remove_filter() in myhacks.php

  18. xrlq
    Member
    Posted 9 years ago #

    Short of disabling the texturize engine altogether, is there any way to disable specific substitutions or enable others? I like the feature when it's applied to strings I would <i>never</i> want to appear verbatim, e.g., \c\ rather than (c).

  19. here
    Member
    Posted 9 years ago #

    This (apparently?) remains an open issue causing trouble for all sorts of reasons, most recently an attempt to post code to my blog. (A wordpress hack no less!) I have been unable to find any reliable documentation / explanation of how to work around the usually handy, occasionally infuriating aspect of wordpress. A simple checkbox, 'use texturize for this post' would likely do it in the case of code, without which posting code is impossible as far as I can tell. The wordpress docs wiki has not even a page for texturize. Hopefully I can put some time into helping to remedy this situation, but in the meantime -- links?

  20. xrlq
    Member
    Posted 9 years ago #

    I'm having the same problem again with the newer version, and the old links to the solutions no longer work. Ideas?

  21. yami
    Member
    Posted 9 years ago #

    I've had some luck using Text Control.

  22. richardc020
    Member
    Posted 9 years ago #

    Per my http://wordpress.org/support/topic/15118#post-191873 , I ask again
    How do I deactive texturizer, in a step-by-step fashion?

    I don't have the time to figure out every include relationship to see where texturizer is or character set encoding details, but you probably know.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.