WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp-config.php (17 posts)

  1. Anonymous
    Unregistered
    Posted 9 years ago #

    i looked the the past entries, but alas my question was not answered. please hope me.
    step 1: download and extract wp 1.2.1
    step 2: update wp-config-sample.php
    define('DB_NAME', 'rxreeddb');
    define('DB_USER', 'rxreed');
    define('DB_PASSWORD', '******');
    define('DB_HOST', 'mysql.rxreed.net');
    save as wp-config.php
    step 3: upload
    step 4: wp-admin/install.php
    You also need to set up the database connection information in wp-config.php
    step 5: go to wp-admin/setup-config.php
    repeat...same error.
    step 6: uninstall and re-do... same result.
    step 7: go to wordpress support forum

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Are you uploading 'wp-config.php' to the same directory as 'wp-layout.css' and doing so in ASCII mode ?

  3. Anonymous
    Unregistered
    Posted 9 years ago #

    yes

  4. Matt Mullenweg
    Troublemaker
    Posted 9 years ago #

    If you're manually creating the wp-config.php you shouldn't touch setup-config.php.

  5. Anonymous
    Unregistered
    Posted 9 years ago #

    when i go to install.php, i receive a string of messages before the wordpress logo:
    wp-config.php file. I need this before we can get started. Need more help? We got it. You can create a wp-config.php file through a web interface, but this doesn't work for all server setups. The safest way is to manually create the file."); require_once('../wp-config.php'); require('upgrade-functions.php'); if (isset($_GET['step'])) $step = $_GET['step']; else $step = 0; ?>
    **WORDPRESS LOGO**
    hide_errors(); $installed = $wpdb->get_results("SELECT * FROM $tableusers"); if ($installed) die(__('
    You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first.
    ')); $wpdb->show_errors(); switch($step) { case 0: ?>
    Welcome to WordPress. We’re now going to go through a few steps to get you up and running with the latest in personal publishing platforms. Before we get started, remember that we require a PHP version of at least 4.1.0, you have . Look good? You also need to set up the database connection information in wp-config.php. Have you looked at the readme? If you’re all ready, let's go!
    Step 1

  6. Mark (podz)
    Support Maven
    Posted 9 years ago #

    "st 4.1.0, you have . Look "
    You've not got PHP installed, so WP can't install.
    There should be a number after the word 'have' ..

  7. Anonymous
    Unregistered
    Posted 9 years ago #

    i assumed it was part of the dreamhost package.

  8. Anonymous
    Unregistered
    Posted 9 years ago #

    dreamhost faq:
    What's PHP?
    PHP is a scripting language like ASP, which allows you to make dynamic web pages quickly and easily.
    PHP support is a standard feature for all DreamHost web hosting accounts.

  9. Joni
    Member
    Posted 9 years ago #

    I am not "technically savvy" enough to answer this question, but I throw it out as a possible reason for Anon's woes. Looks like dreamhost defaults to running PHP as a CGI rather than as an Apache module, but the user can change it. Could this be the problem?
    https://panel.dreamhost.com/kbase/index.cgi?area=2934

    How do I switch my PHP between running as a CGI and an Apache module?
    Of course you've already read all about the differences in PHP-CGI and PHP as an Apache module, right? And you know that the default set up is as PHP-CGI, which is heavily preferred, right?
    If you still want to change your PHP setup, here's how!
    * Go to the "Domains > Web" area of the web panel.
    * Click the "Edit" link for the http(s) service for your domain you'd like to switch PHP's type on.
    * Underneath the "Fully Hosted Domain" section that comes up, there is a checkbox which says "Run PHP as a CGI?". Just uncheck (or check) that, and then submit that page!
    Within about a half hour, your PHP setting will be changed for your domain!

  10. James
    Happiness Engineer
    Posted 9 years ago #

    it is part of the DreamHost package, and my three are working just fine. Are you trying to upload the files into a cgi-bin folder? A lot of people make that mistake and with DreamHost it simply won't work. Try putting the 'wordpress' folder (with all the files into it) inside your "rxreed.net" folder. This will put the files at rxreed.net/wordpress/ (this is how I did mine).

  11. Anonymous
    Unregistered
    Posted 9 years ago #

    it MUST be something at dreamhost. i have contacted customer support.
    thanks tons for the tips. i changed the php settings. the wordpress folder is saved in rxreed.net/wordpress. the DB_HOST is correct, yes?
    guess i'll find out tomorrow when i hear from dreamhost.

  12. James
    Happiness Engineer
    Posted 9 years ago #

    It looks right. All the info comes from your MySQl manager, so assuming that's correct, you've done everything right.

  13. Anonymous
    Unregistered
    Posted 9 years ago #

    dreamhost cannot comment on 3rd party software. i have contacted this guy
    http://www.wombatnation.com/misc/installWordPressDreamHost.html

  14. Anonymous
    Unregistered
    Posted 9 years ago #

    Success!
    There was a problem accessing the mysql database. The folks at DreamHost fixed it quickly and all went smoothly after.
    Thanks again for all the tips and especially to Robert at wombatnation. All DreamHost users should utilize his tips.
    He suggested that I check the db connection at:
    http://www.example.com/dh_phpmyadmin/mysql.example.com/
    Once I figuered out that wp couldn't reach the database, all came clear.

  15. ccheaton
    Member
    Posted 9 years ago #

    Hmm. I'm trying to migrate my blog over to dreamhost, and I can't reach the database with my WP install, though I can reach it with some other software I have installed. The settings are all correct... Frustration.

  16. ccheaton
    Member
    Posted 9 years ago #

    Ok, the issue is that I had my psnGallery plugin active, and when I tried to connect to my blog, it tried to find my Coppermine database, which I haven't migrated over yet, and returned the error that my database settings were incorrect.
    Sorta fixed now, moving my coppermine stuff over as we speak.

  17. James
    Happiness Engineer
    Posted 9 years ago #

    Good luck, and welcome to Dreamhost. It's a great company.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.