WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp-config/install.php yields blank page (9 posts)

  1. matt_doe
    Member
    Posted 4 years ago #

    At the step where you enter 'http://example.com/wp-admin/install.php' into the browser (with my url, not example.com) the page that comes up is blank and the browser (firefox) changes the address back to http://www.mergevisual.com

    I have all the files uploaded, and the wp-config.php is correct. What am I missing?

  2. MichaelH
    Member
    Posted 4 years ago #

    Typically, a blank screen during install means you didn't get a complete and intact set of WordPress files uploaded to your host. I'd consider downloading a fresh copy of WordPress from the Download tab at the top of this page, then use something like 7-Zip to extract the files. Then reupload the files to your host. Review Uploading WordPress to a remote host and make sure you are using ASCII transfer mode in your FTP client.

    If you have an .htaccess file, that too could be causing the problem--rename that if necessary.

  3. matt_doe
    Member
    Posted 4 years ago #

    That got me able to install, but now when I go to visit site all I see is "Index of/" page with all the files listed (www.mergevisual.com)

    Is it a problem with the theme? Am I still missing a file?

  4. Samuel B
    moderator
    Posted 4 years ago #

    add this line to top of your .htaccess

    DirectoryIndex index.php index.htm

  5. dennisp@dennisp.com
    Member
    Posted 4 years ago #

    Your post solved my problem. I was using a local version. When I added index.php to the Apache httpd.conf file and restarted, my Blog page came up. Thanks.

  6. pbspirits
    Member
    Posted 4 years ago #

    I got rid of blank page by ensuring my server setting: 'PHP Safe Mode' was set to off. I searched high and low for this answer and finally figured it out and am doing a little paying-it-forward :)

  7. leewal
    Member
    Posted 4 years ago #

    Thanks samboll - I had the same problem matt_doe mentions, seeing index of folder instead of index.php

    The line in my .htaccess did it..
    for future reference what is the cause of this?

  8. steffenj
    Member
    Posted 4 years ago #

    I had the same issue, blank page (Safari) or File not Found (Opera).

    Turns out none of the help here was related to my problem. What was causing it for me was WP-SuperCache. I had disabled it and removed all cache files before transfer. I had to fully disable the plugin by renaming the folder, removing the supercache line from wp-config.php and also deleteing the cache folder altogether (it contains a .htaccess file which i believe was the culprit).

  9. Knezevic
    Member
    Posted 4 years ago #

    I had this error displayed. How do I fix this?

    Warning: require_once(/home/turnkeys/public_html/wp-load.php) [function.require-once]: failed to open stream: No such file or directory in /home/turnkeys/public_html/wp-admin/install.php on line 18

    Fatal error: require_once() [function.require]: Failed opening required '/home/turnkeys/public_html/wp-load.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/turnkeys/public_html/wp-admin/install.php on line 18

Topic Closed

This topic has been closed to new replies.

About this Topic