WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] WP Config Values for DB Host... (5 posts)

  1. WebFadds
    Member
    Posted 6 years ago #

    Hi -

    I would appreciate your help with a WP installation, where I believe we need a custom Database Host configuration, since "localhost" is not working.

    HOST for MySQL: synux.sqlserverdomain.com
    HOST for Install: tahoeparadiserealty.com/blog (virtual host on same parent server as data base)

    I have access to setting MySql permissions, and have attempted to do so with 'localhost' as the DB_HOST value. I can see that a couple of other databases on the server are set that same way, and I have done the same. However... I get:
    "Error establishing a database connection - This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at localhost."

    Your help with a troubleshoot process will be appreciated.

    - Scott

  2. whooami
    Member
    Posted 6 years ago #

    use: synux.sqlserverdomain.com

    whats the problem??

    And for pete's sake, if youre going to advertise that you know how to do this and can do this, and you plan on getting paid to do it, learn to search the forums here.

    this is a very common problem, its the most common problem, and theres only so many things to troubleshoot.

    There are 4 settings that affect that.

    If you cannot figure that out, and beyond that are too over the top to suggest contacting the host for the proper information, you need to get another gig.

    honestly.

  3. WebFadds
    Member
    Posted 6 years ago #

    Hi -

    Problem is, I've already tried the two things you suggested:
    1) use: synux.sqlserverdomain.com
    2) Contact host (they don't have anyone that knows how their server is set up to connect to MySQL -- go figure).

    Will do some more hunting through forums. No problems installing on normally configured hosts all the time. This one is a bit peculiar.

    Thanks - Scott

  4. WebFadds
    Member
    Posted 6 years ago #

    Hi -

    RESOLVED.

    FYI... the issue was not the "four things" mentioned above:

    1. The name of the database
    2. Your MySQL username
    3. and password
    4. Database values

    It was the permissions on the MySQL server which was set-up customized and in an unusual configuration (no PHPmyadmin, etc.). The host operators did not know how to deal with it, so they gave us access. We resolved it by setting permissions ('localhost' -- not 'synux.sqlserverdomain.com') ourselves.

    Thanks -
    Scott

  5. homeycomb
    Member
    Posted 6 years ago #

    .. and you managed to work that out yourself -- good for you !! Youre making money, so I reckon a little troubleshooting skills would do you good.

    -- whooami (at work)

Topic Closed

This topic has been closed to new replies.

About this Topic