WordPress.org

Ready to get started?Download WordPress

Forums

WP-CONFIG file (5 posts)

  1. egdesign_oz
    Member
    Posted 1 year ago #

    So it's probably the rookie mistake with all of us virgin WP users, but just having a crack at WP now for the first time. I am configuring the wp-config file in dreamweaver. I have created my database and user, and I get the message:

    Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the egdesign_myblog database.........

    I have changed the username to include (or not) the database name as suggested but makes no diff, the thing won't work. If anyone has helped with this sort of prob, i'd love to hear from you!

  2. michael.mariart
    Member
    Posted 1 year ago #

    That means that you have not got the database name correct in your wp-config.php file. It's a very common mistake, that even the best of us make when we are typing things in by hand. If you are sure that you have got the details correct, ask your hosting comapny and get them to double-check the database connection details. They'll be able to tell you if it's correct or not.

  3. Johnb81
    Member
    Posted 1 year ago #

    The problem seems not to be incorrect incorrect details in the wp-config.php file but it seems more of a MySQL configuration.

    Are you using the same MySQL username to access more than 1 database? It seems that the user you are using or has access to multiple databases or does not have access to the database you are using.

    Ideally you should use 1 MySQL user for each database and set the WordPress database as a default database for the user.

  4. egdesign_oz
    Member
    Posted 1 year ago #

    Thanks for the prompt replies, I have set up the MySQL database (only 1) and have only 1 user. It is set up in Cpanel and there are no options in the settings to select WordPress as a default :/
    Cheers :)

  5. Johnb81
    Member
    Posted 1 year ago #

    So in that case the best option is to contact the hosting provider. I've seen several cases before where it was a misconfiguration from their end.

    Sorry we cannot help more.

Topic Closed

This topic has been closed to new replies.

About this Topic