WordPress.org

Ready to get started?Download WordPress

Forums

wp-comments-post.php problem (23 posts)

  1. truantrebel
    Member
    Posted 6 years ago #

    I'm having problems with posting comments. Nobody can post comments, because after writing them the wp-comments-post.php page ends up being white & a dead end. No code, no error.

    Help! This worked until I changed my layout!

  2. bamapachyderm
    Member
    Posted 6 years ago #

    Bump

    I'm having the same problem, but it's not the theme.

    Truantrebel, have you tried commenting with the WP default theme? I did, and still have the problem. I just get stuck at wp-comments-post.php and the redirect to the post doesn't happen. No comment is posted either.

    I have looked at what seems like everything on teh internets to figure this one out.

    I don't even remember why I thought it had to do with the 2.3 canonical URL change, but I played around with that to no avail as well (that isn't a problem; I did a backup before I edited the htaccess file so I wouldn't compound the problem).

    Help please, anyone?

  3. bamapachyderm
    Member
    Posted 6 years ago #

    I tried a comment with IE, and found it's a 405 error.
    Not that it's solved anything, but it's another clue, I guess.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Very few things generate a 405 error. WordPress is not one of them.

    Are you running mod_security on your server?

  5. bamapachyderm
    Member
    Posted 6 years ago #

    I couldn't tell you for sure. What's that look like?
    I do have certain files and the directories protected in .htaccess, if that means anything.

  6. bamapachyderm
    Member
    Posted 6 years ago #

    Actually, my issue is probably because I have two blogs with different URLs on my server, but the main blog works fine with a nearly identical .htaccess file (domains changed, of course). I don't wanna hijack truantrebel's thread, though--I'm sort of hoping something will give me an aha! moment, 'cause I'm pretty stumped.

  7. bamapachyderm
    Member
    Posted 6 years ago #

    It works now! Thanks Otto!

    What I did (for anyone else with the problem, if you have a similar setup)--
    I just had to change my WordPress URL in Admin/Options. I had it set to http://mainblogurl.com/addondomainurl.com/ and I changed it to http://addondomainurl.com (just as the blog address URL was).

    Thanks again!

  8. Honhaar
    Member
    Posted 5 years ago #

    We are having a similar problem; also we cannot login into our accounts (unless it is already cached). We are yet to identify the cause! So do not know how to solve the problem. We have tried the suggestion, but it didn't work.

  9. Mladjo
    Member
    Posted 5 years ago #

    My problem is like this: When I'm loged and don't write anything I have The website cannot display the page HTTP 500. Wp is 2.5.1 and page is /wp-comments-post.php. No idea.

  10. victorfranco
    Member
    Posted 5 years ago #

    I experienced the same problem as leonl, but it happened when the visitor was not loged in. So nobody could comment on my blog. I don't know what to do, but while i don't find an answer I have to use Disqus.

  11. tlw
    Member
    Posted 5 years ago #

    I'm having this problem as well. I thought it may be my old theme, but I've checked through everything and there isn't anything wrong with it..

    This is only happening to people that are not registered. They are usually on IE as well. I checked it in IE logged out and ended up with the 405 error as well as a 500 error.

    Unlike bama, my blog is already set up with the proper URL.

    Also, if one that has the error refreshes the page and tries to comment again, it usually goes through.

    I'm attempting to find a plugin that can correct the problem, but I haven't found anything as of yet.

  12. preetamp1984
    Member
    Posted 5 years ago #

    i am also having same problem
    my site 100india.com

  13. techiesouls
    Member
    Posted 5 years ago #

    i also had the same problem but one of my friend suggested me to update to new version but it also did't worked i backed up my DB and fresh installed the latest version and my problem solved you can have a look here TechieSouls

  14. janebush08
    Member
    Posted 5 years ago #

    i am also having same problem

    net framework development

  15. TrashMajor
    Member
    Posted 5 years ago #

    And the same. I have last version of wordpress (2.6.1) installed first time at the domain.

  16. tearoom
    Member
    Posted 5 years ago #

    OK, just had this same issue, and fixed it with a bit of PHP, right under the comment

    $user = wp_get_current_user();
    if ( $user->ID ) {
    	$comment_author       = $wpdb->escape($user->display_name);
    	$comment_author_email = $wpdb->escape($user->user_email);
    	$comment_author_url   = $wpdb->escape($user->user_url);
    	if ( current_user_can('unfiltered_html') ) {
    		if ( wp_create_nonce('unfiltered-html-comment_' . $comment_post_ID) != $_POST['_wp_unfiltered_html_comment'] ) {
    			kses_remove_filters(); // start with a clean slate
    			kses_init_filters(); // set up the filters
    		}
    	}
    } else {
    	if ( get_option('comment_registration') )
    		wp_die( __('Sorry, you must be logged in to post a comment.') );
    }

    I changed this to:

    $user = wp_get_current_user();
    if ( $user->ID ) {
    	$comment_author       = $wpdb->escape($user->display_name);
    	$comment_author_email = $wpdb->escape($user->user_email);
    	$comment_author_url   = $wpdb->escape($user->user_url);
    	if ( current_user_can('unfiltered_html') ) {
    		if ( wp_create_nonce('unfiltered-html-comment_' . $comment_post_ID) != $_POST['_wp_unfiltered_html_comment'] ) {
    			kses_remove_filters(); // start with a clean slate
    			kses_init_filters(); // set up the filters
    		}
    	}
    } else {
    <strong>	echo("Oops, looks like you didn't <a href=\"http://www.YOURDOMAINNAME.com/wp-login.php\">register (or sign in)</a>!");</strong>
    
    	if ( get_option('comment_registration') )
    		wp_die( __('Sorry, you must be logged in to post a comment.') );
    }

    This assumes wp is under the main directory, if you need to put a sub directory, change the url http://www.YOURDOMAINNAME.com/wp-login.php to http://www.YOURDOMAINNAME.com/YOUR_SUB-DIRECTORY/wp-login.php

    This might cause some other unforseen issue, but so far I haven't come across one (please let me know if you do!)

  17. TrashMajor
    Member
    Posted 5 years ago #

    tearoom, it doesnt solve the problem.

  18. TrashMajor
    Member
    Posted 5 years ago #

    hey! there is solve of the prob. just disable "send letter to admin when somebody did comment" in your admin dashboard.

    describe in russian

  19. essaouira
    Member
    Posted 5 years ago #

    similar problem i can't post comments v 2.6.1

  20. relusa
    Member
    Posted 5 years ago #

    I just had the same problem and here is my fix. I found that it only did this when I had the theme changed. In my case it is the blue-mist.1.5.zip theme. I am using WordPress version 2.6.2, so I am sure the theme was old. Anyway I got into design/theme editor and clicked on the comments template and simple pasted in the comments template from the comment template from WordPress' default theme. Here is my WordPress blog so far. I just installed it a few hours ago: http://www.greatmemories.info/wordpress

  21. rikonick2
    Member
    Posted 5 years ago #

  22. Skratman
    Member
    Posted 5 years ago #

    I can post comments but after posting it redirects me to the "Oops" URL not found page. This has only happened since the upgrade and it's annoying for my visitors. Any ideas on how to fix this?

  23. Skratman
    Member
    Posted 5 years ago #

    By the way, I did visit the URL posted above, but mine didn't have that problem so I can't fix it that way.

Topic Closed

This topic has been closed to new replies.

About this Topic