WordPress.org

Ready to get started?Download WordPress

Forums

WP Calendar
[resolved] Wp Calendar - Edit Events page - JS not working? (2 posts)

  1. anairamzap
    Member
    Posted 3 years ago #

    Hi!
    First of all, this plugin is great! Thanks for maintain it.
    Now, the error I'm getting:
    1- I installed and activated the plugin -> No errors.
    2. I add an event, filling title, description, date and category and save changes -> I got the message: "New event saved Event published"
    3. Here it comes the error: I go to "Edit" under Calendar menu in wp (fsCalendar.php template) and I can see that I have 3 published events, but I do not get the list of events (here is a screenshot).
    Also, the arrows to exapand dashboard items are not working, which sound to me like a js problem...
    4. The other thing is that in full calendar page ( http://ladrans.hosting.amidamaru.com.ar/?page_id=62 ) I have no calendar displaying, but if you take a look at the source the some html and js related to calendar is generating, here is an extract:
    <p><div id="fscal-4dcf25"></div><script type="text/javascript">jQuery(document).ready(function() {jQuery('#fscal-4dcf25').fullCalendar({firstDay: 1,timeFormat: "h:mm tt",monthNames: ["January","February","March","April","May","June","July","August","September","October","November","December"],monthNamesShort
    5. The firebuf error console throws: "Error: jQuery("#fscal-4dcf25").fullCalendar is not a function
    Source File: http://ladrans.hosting.amidamaru.com.ar/?page_id=62
    Line: 56"

    So, could these two problems be related? And, do you have any clue how to fix it?
    I have already tried to desactivate all the other plugins and the error persists, I have also deactivated and reactivated and uninstall and re install the plugin. Nothing helped.
    Ah, by the way, the template I'm using is: Spectacular 1.0.
    But I have a local wordpress installation using this template and the calendar is working as expected!

    This is driving me crazy, I hope somebody can give me some ideas to fix it.

    Thanks,

    m

  2. anairamzap
    Member
    Posted 3 years ago #

    Ok, after 5 days (!) of research I could not found the reason for this error.
    BUT the good thing is that I have the plugin working as expected in a clean installation of wordpress 3.1.2.

    So... I guess I can "resolve" this issue now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic