WordPress.org

Ready to get started?Download WordPress

Forums

wp-cache - not your typical blank page - "whooami" help please! (9 posts)

  1. stranflow
    Member
    Posted 7 years ago #

    Ok...I've been through the forums and developer's site for the instructions. Here's what I have so far.

    1. I have the install in place and have activated the plug-in with all settings set to default
    2. I have the symbolic link between the two files. advanced-cache.php and wp-cache-phase1.php
    3. I see the "cache" directory
    4. When I surf the site to cache some pages, everything is fine and fast but when I clear my local cache and try to surf the site, it comes up with blank pages.
    5. I check the cache directory and do see cache pages written to it. However, the html pages that are written to it have a base url of my main account of a shared hosting. For example: http://www.mainaccount.com/subaccount/....

    I set up a directory redirect so that everything going to http://www.mainaccount.com/subaccount/ would get redirect to http://subaccount.com but that didn't work either. Still...blank pages.

    Is there a way that I can explicitly set the base URL that is written to the cache files, so that instead of http://www.mainaccount.com/subaccount/ it'd have a base URL of http://subaccount ?
    can I edit any of the wp-cache files to change that setting?

  2. whooami
    Member
    Posted 7 years ago #

    stranflow,

    I appreciate the topic title, really i do :) but, unfortunately, I can't help you. :(

    I don't know any more about that plugin than what I've read on these forums, on the author's site, and in the readmes he included in the zipfile. IN fact, you probably know more than me. :)

    I would think that the plugin would be intuitive enough to use your blog settings to create all the cached files.

    The changes you have made, are you redirecting server side, or have you actually gone in and changed the 2 uri values in your admin area?

  3. stranflow
    Member
    Posted 7 years ago #

    Lovely of you to respond! I saw your suggestions and patience with some other people so I was hoping to hook your eyes to my plight. ;-)

    I've set up the redirect on the server side.

    You see, you do know more than I do. I don't how I should set up the URI values. Got some suggestions for me to try out?

    Thanks.

  4. whooami
    Member
    Posted 7 years ago #

    oke. so what you have done thus far is this then ..

    you have a blog thats actually located at http://www.somewhere.com

    and you are redirecting using your .htaccess to a subdomin?

    like http://here.somehwere.com ??

  5. stranflow
    Member
    Posted 7 years ago #

    Not quite. I have a shared hosting account on bluehost. With one account, I can host up to 5 domains but one of the domains is considered the primary account. So for example, mainaccount.com is the primary account. I can access this account and set up an add-on domain. That essentially gives me a subdirectory off the primary account. File structure wise, it'd look like this, mainaccount.com/subaccount but I'd surf it up as subaccount.com and get to the proper root directory for that domain/subaccount.

    I didn't edit any .htaccess files to add a subdomain. I added the sub account via a control panel so I am not sure how it's handled. I suspect on the server side.

    Does that info help?

  6. whooami
    Member
    Posted 7 years ago #

    ok, so you have basically added on another completely different domain name then, correct?

    If i were to look at your cpanel, then I could click on addon domains, and I would see another domain in there?

    when you look in your addon domain link inside cpanel, do you see any redirection options in there?

    basically what it comes down to is this. If you are redirecting http://www.1.com to http://www.2.com you need to tell wordpress that. While wordpress will probably handle the redirections invisibly, plugins that require knowing that information might not.

    the settings you are looking for under the options tab,

    WordPress address and Blog address

    I cannot guarantee that changing them will not result in your admin or your entire blog being inaccessable given what you have already done. But if that does happen, it's fixable after the fact.

  7. stranflow
    Member
    Posted 7 years ago #

    There are redirection options available. The scenario you described with http://www.1.com being redirected to http://www.2.com is not correct. It's more like... on the server side, the caching files are being written like, http://www.1.com/2/ when it should be writing them http://www.2.com/ Follow? I think that's the snag. If the cache files were writing http://www.2.com/ , I'd be fine. That's why I tried setting up a redirect of http://www.1.com/2 to go to http://www.2.com but that didn't help. I even tried clearing the cached pages afterward to make sure.

    Frusting...seems like there's some variables that tell wp-cache how to find it's blog root directoy. If I knew that, I'd be ok. I also emailed the developer to see if he could help. Any other thoughts?

    Thanks again. for your quick responses and energy.

  8. whooami
    Member
    Posted 7 years ago #

    yes, i do follow, which is why I said what I said.

    When you do into that cpanel screen so you see a domain ???

    You set that up, correct??

    You have to tell wordpress. the plugin only know what wordpress tells it.

  9. stranflow
    Member
    Posted 7 years ago #

    Yep, the domain is set and wordpress also knows which domain to point to.

Topic Closed

This topic has been closed to new replies.

About this Topic