WordPress.org

Ready to get started?Download WordPress

Forums

WP Biographia
[resolved] WP Biographia appearing twice on posts (6 posts)

  1. basvan
    Member
    Posted 2 years ago #

    On the Q&A for this plugin I saw the issue that I am having but I don't see a clear explanation on how to fix it:

    I've installed and configured WP Biographia and now I see not one but two differing Biography Boxes; what's going on?

    There's probably one of two things going on here. Firstly, you've already got another plugin that makes a Biography Box installed and active and this plugin, as well as WP Biographia, are doing their job properly. Secondly, the theme you're using hard codes a Biography Box into the theme templates. Both the TwentyTen and TwentyEleven themes supplied as part of a standard WordPress install do this.

    I don't have any other similar plugins running, so that is not the issue. I'm assuming that the fact that this template is running static blocks is causing this to happen. I tried to disable WP Biographia for static blocks, since it is an option on the settings page, but it is still doing it.

    I tried adding the shortcode [wp_biographia] to each post, which worked perfectly, but that would mean I would have to remember to add it every time I create a post. I trying adding the shortcode to the post template files in Editor, but nothing happened. I probably need more code, right? What would be the entire code I would need to enter in the post template?

    By the way, you can take a look at what it's doing here: http://femininesoul.com/song-of-the-week-just-the-way-you-are-by-bruno-mars/

    Any suggestions you can provide to fix this issue would be greatly appreciated. I love this plugin and would like to keep in on my site.

    Thanks so much!

    http://wordpress.org/extend/plugins/wp-biographia/

  2. vicchi
    Member
    Plugin Author

    Posted 2 years ago #

    Hi,

    So I've had a look at the page that you've linked to but it's not clear what's happening.

    From digging in the source of that page it looks like you're running the Salutation theme ... as this is a premium/paid theme, that makes it difficult for me to see what's going on in the background.

    I'm assuming that the fact that this template is running static blocks is causing this to happen. I tried to disable WP Biographia for static blocks, since it is an option on the settings page, but it is still doing it.

    ... static blocks aren't a feature of WP Biographia, is this part of the theme's settings?

    From what I can see, the first of the Biography Boxes is being automatically added by WP Biographia, but the second Biography Box shouldn't be unless it's been manually added in via a shortcode; you mention this in your original post ... is this what's been done? The second Biography Box looks to be in the page footer, which WP Biographia won't do unless there's been some shortcode customisation done?

    If this is the case it would be helpful to see the site with no customisations/shortcode additions to see whether this is a customisation problem or an odd side effect of the theme plus WP Biographia.

    Also, I can see that the theme is flagged as being BuddyPress compatible ... have you installed/configured BuddyPress?

    Sorry to reply with more questions; hopefully we'll get to the bottom of this.

  3. basvan
    Member
    Posted 2 years ago #

    Thanks so much for your reply!

    Here's the option I was referring to that is on the settings page:

    Display On Individual Static Content Blocks
    Displays the Biography Box on individual instances of custom post type Static Content Blocks.

    Maybe it shows on the settings page because the settings because this theme has static content.

    By the way, I didn't add the shortcode to the footer. It's just showing up there automatically, I guess because it's a static content. What I did that worked was that I unchecked all the options on the settings page, so the bio box was not appearing anywhere, and then added the shortcode to each individual posts. That worked perfectly. It's just that this is a very manual process. So I was thinking that if I could add the shortcode to the template-post.php file I could make it work. I tried just adding [wp_biographia] but it wasn't enough. I think it needs more code to it. I'm also not 100% sure where the code should go. Any suggestions?

    Thanks!

  4. vicchi
    Member
    Plugin Author

    Posted 2 years ago #

    Ah ... I see. That makes a bit more sense. So your theme defines a custom post type called "Static Content Block". Hmm ... If you deselect all options for this custom post type in the WP Biographia settings does this still happen? I'm wondering if your theme does something "clever" with this post type (unless you've created it yourself) which is bound up with the post footer. There should be a way around this without the need to hack the theme templates, I'm just not clear (yet) what that is.

    If you're adding the shortcode to the theme template, the part of the WordPress core that "expands" shortcodes has probably already run by the time [wp_biographia] is being "seen". The usual workaround to this is to use do_shortcode('[wp_biographia]'); from within a hook handler, but without seeing your theme's code and structure it's not easy to say which hook you should be using.

    It might be easier to either grant me temporary access to a test version of your site or to let me "borrow" a copy of the theme's code to see what is actually happening here?

    -Gary

  5. basvan
    Member
    Posted 2 years ago #

    I have a backup site to this site (femininesoul.com/backup) that I can give you access to if you'd like to test it. Or I can provide you with the code for the theme. Whatever is better for you. It would probably be easier if you email me directly so I can give you these details. Here's my email address: info AT femininesoul.com.

    Thanks again,
    Vanessa

  6. vicchi
    Member
    Plugin Author

    Posted 1 year ago #

    Haven't heard back from you in over 9 months so I'm going to assume you've either fixed this or it isn't an issue any more. Feel free to get back in touch if it still is.

    -Gary

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic