WordPress.org

Ready to get started?Download WordPress

Forums

Wp and 'wp-includes/Js' trouble (19 posts)

  1. fioitv
    Member
    Posted 5 years ago #

    Hi folks,

    here is the problem:
    when i try to write a post wp replies:

    "Uno script in questa pagina potrebbe essere occupato o aver smesso di rispondere. È possibile fermare lo script adesso o attendere per vedere se lo script conclude la sua esecuzione.(brief translation: a script in this page does not work. you can stop it or wait for it to work :-(

    Script: http://giallofastidio.net/wp-includes/js/jquery/jquery.js?ver=1.2.6:11"

    when i click alternatively on 'stop' or 'continue' a white page appears saying 'internal error'

    please, help me!!

    thanks in advance

  2. mazedlx
    Member
    Posted 5 years ago #

    that must be a wordpress 2.6 bug. i can't see the "add media" button when writing a new post/page, selecting all plugins doesn't work either.

  3. iamthechosenone
    Member
    Posted 5 years ago #

    I have a similar problem. Same error message except when I click stop, I get the completed post.
    The strange thing is that I use one wordpress installation for over 30 blogs, but I only get this error on one domain. i have deleted everything and started again with fresh files directly from wordpress and I still get the same.

    Very strange and very annoying

  4. Gary Walsh
    Member
    Posted 5 years ago #

    Hello,
    I found the problem with my site was that on writing a NEW post (not editing an existing one) there was a script that was loading the post meta for EVERY post-id in the whole database. In my case about 30,000 records. This killed the system. What I did was prevent the load of post meta by modifying the wp-admin\edit-form-advanced.php and removing the load of the custom fields meta.
    <?php
    $metadata = has_meta($post->ID);
    list_meta($metadata);
    ?>
    This fixed the problem and it loads very quickly now. May not be elegant but then again neither is loading every post in the meta!
    GW

  5. craigchilds
    Member
    Posted 5 years ago #

    thanks Gary.
    that worked perfectly - removing that line.
    such a funny thing to happen on only one installation suddenly. cheers bro.

  6. DJWILLIS
    Member
    Posted 5 years ago #

    I had the same issue, thank god I found this thread! It worked perfectly for me as well! My posting time now goes from 3 minutes to 3 seconds! Can't thank you enough!

    Willis
    http://www.williswho.com

  7. Guppy411
    Member
    Posted 5 years ago #

    Gary,

    You are awesome, I new it had something to do with the Custom Fields Meta as it was loading hundreds of fields that some were created in the database when I upgraded. I deleted them all but was still getting the JS error. The problem is I could not figure out how to disable it (I am fairly new to WP and it was like finding a needle in rain forest).

    Guppy

  8. summerbreeze
    Member
    Posted 5 years ago #

    Hi, I am having the same trouble. I am not sure what I am looking for in the file I brought up my php editor and I can't find anything about meta data fields. Any help would be great thanks Jenn

  9. mountainsage
    Member
    Posted 5 years ago #

    Thanks...it worked perfectly!

  10. cock
    Member
    Posted 5 years ago #

    Gary you're the man
    works perfect but? are there any loading performances on the front end because of the

    wp-includes/js/jquery/jquery.js?ver=1.2.6:11
    Skript?

  11. mountainsage
    Member
    Posted 5 years ago #

    How might I stop custom fields from loading when writing a new page? It's loading hundreds of customs fields and I don't know why.

  12. dcpanganiban
    Member
    Posted 5 years ago #

    Just a question will this affect the All in one SEO Plug in... ? or is there any implication for SEO.

  13. dcpanganiban
    Member
    Posted 5 years ago #

    I just made some experiments and I think " All in One SEO Pack Plug in " still woks fine ( here is my experiment : Error in WordPress 2.7 )

    Dexter
    http://techathand.net

  14. heriz
    Member
    Posted 5 years ago #

    Cheers for this Gary - this just started happening after I imported my old post metadata

    However it does now mean that the custom fields you HAVE assigned to a post deliberately are also hidden, which is a bit of a nightmare, albeit a lesser one.

    Why do the custom fields load the post meta in this situation anyway? It's weird...

  15. heriz
    Member
    Posted 5 years ago #

    Ok - I seem to have fixed it.

    I went into my database to look at the metadata in a bit more detail. In the postmeta table, I noticed there were reams and reams of entries with post_id reference '0'. This suggested to me that it was actually these posts' meta (rather than ALL posts' meta) that were being pulled into the custom fields because they had no specific post id, so they acted like a wildcard.

    Soooo... I deleted them all by hand. An absolute ball-ache, but as I'm new to all this, it was the only way (a search query threw up nothing).

    After checking that there were no '0' post_id'd entries left, I backed it all up again, checked my site to see if any of the custom field-related items were affected (they weren't), re-added the code Gary took out of edit-form-advanced.php and checked the Write Post once again. No renegade custom fields. Checked the Manage Posts again, and the custom fields were back.

    I don't want people to see this as 'the answer' because I really am a novice at databases and wouldn't want to put false information out there. But this did work for me, and I think its quite important because using Gary's hack will mean that a wrongly-entered custom field will disappear into the database, and potentially cause problems if you can't edit it from the post page itself.

    I hope this is helpful, or at least interesting to someone!

  16. annoiato
    Member
    Posted 5 years ago #

    If you don't want to do this manually you can execute this query:
    DELETE FROM wp_postmeta WHERE post_id=0;

  17. KnicKnac
    Member
    Posted 5 years ago #

    heriz - I tried Gary's fix and it didn't work, so I did yours and it did, so I would say it was a winning answer, thanks for sharing that so that it could help someone, mainly ME!

  18. GrizzlyGroundswell
    Member
    Posted 5 years ago #

    worked like a charm my friends! This has been nagging me since December of last year! Thanks heriz and annaiato for making my install of wpmu so much more Grizzly then before!

  19. Roadiee
    Member
    Posted 5 years ago #

    annoiato thanks so much this fixed the problem for me..

Topic Closed

This topic has been closed to new replies.

About this Topic