WordPress.org

Ready to get started?Download WordPress

Forums

WP and MediaTemple (13 posts)

  1. MsngLink
    Member
    Posted 9 years ago #

    Has anyone had success installing and running WP at MediaTemple? I keep getting the following error, "We were able to connect to the database server (which means your username and password is okay) but not able to select the mysite_-_blog database."

    Their support has been less than mediocre.

  2. Rob Poitras
    Member
    Posted 9 years ago #

    maybe they have a different name for the database server. instead of "localhost" it could be something else most likely.

  3. MsngLink
    Member
    Posted 9 years ago #

    Yeah, I immediately thought the same thing. But from what MTemple support tells me the database server is correct. They then suggested I delete the ./ before the DB path. I did this and as you can see from the returned error above I get nada.

  4. prissed
    Member
    Posted 9 years ago #

    Did you create the database first, and assign a user/password to the database?

  5. MsngLink
    Member
    Posted 9 years ago #

    Yes, I did exactly that. I followed the Famous 5-Minuute Install verbatim. Are you suggesting the order of creating a database first then assigning a user/pass second might have something to do with it. Because MTemple's cPanel won't allow you to set a user/pass until a new DB is created. The user is the same as the adim so after creating a new DB it only ask for a pass.

  6. moshu
    Member
    Posted 9 years ago #

    You might have missed the most important step with cPanel: ADD the user to the database...

  7. demesne
    Member
    Posted 9 years ago #

    What sort of plan are you on? I am on the (ss) Shared-Server 4.0 Advanced, and am having difficulties trying to install WordPress. The issues arise because the MySQL database is a multi-user configuration on the Shared-Server, meaning database names need to follow their convention to remain unique (mysite_com_-_databasename). Not only that, we aren't allowed to create extra users to access the database - only the administrator account is granted access. I am having trouble with granting the privileges to the database. Has anyone out there managed to install it successfully on MediaTemple Shared-Servers?

  8. DrShim
    Member
    Posted 8 years ago #

    I have a simulare MediaTemple configuration.

    Did you...
    (1) check that you created the database & that the name is correct,
    (2) check that the username matches the database username that MediaTemple gave you in an e-mail when you signed up for the service,
    (3) and also check the password.

    That may seem rather trivial, but I've checked my own WP configuration and I can't find anything that might indicate a problem.

    Here's my configuration in the wp-config.php file:

    define('DB_NAME', 'subdomain_-_masterdomain');
    define('DB_USERNAME', 'myusername');
    define('DB_PASSWORD', 'mypassword');
    define('DB_HOST', 'localhost');

    Hope this helps, hombre!

  9. MySchizoBuddy
    Member
    Posted 8 years ago #

    MT says that if wp requires root access then I cannot install it. Since you guy are already installing it. So i guess WP doesn't require root access. correct me if i'm wrong

  10. rmrz
    Member
    Posted 8 years ago #

    i have recently the same problem, the cause was i change the password for the administrator of mediatemple.net host plan.

    but in the email send by they, before make the change appears:

    ** HELPFUL TIPS **
    - Changing the Site Administrator password does not change your MySQL password. This helps applications and connection scripts from failing abruptly. You may change your MySQL database password at anytime using the WebControl panel.

    so, the password is the initial.

    now the blog is working
    http://www.copypeist.com

  11. letche
    Member
    Posted 8 years ago #

    Jajajaja, i had the same problem!!!!!! the SAME, im using the same plan, the same hosting and all, i was trying change all for nothing, all you have to do is:
    Create a database with the name: blog, wordpress, etc, doesnt matter, and in the wp-config edit, just the name that u gave to the database, without domain_-_blog,, just write the name you wrote.

    define('DB_NAME', 'blog');
    define('DB_USERNAME', 'myusername');
    define('DB_PASSWORD', 'mypassword');
    define('DB_HOST', 'localhost');

    My blog is working, thanx for the help, and i hope my info work on u.

  12. sithicus
    Member
    Posted 8 years ago #

    I get this error..

    Warning: main(): Unable to access /home/virtual/site454/fst/var/www/html/wp-includes/wp-db.php in /home/virtual/site454/fst/var/www/html/wp-settings.php on line 73

    any thoughts?

  13. DesignPastor
    Member
    Posted 8 years ago #

    i still tend to think that the independents give the best value and support for any and all technical issues.

Topic Closed

This topic has been closed to new replies.

About this Topic