WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin/update-core.php gives a "You are not allowed to call this page directl" (17 posts)

  1. Marc73
    Member
    Posted 4 years ago #

    hi. After the last update of my plug-ins, suddenly I am unable to access this page.

    /wp-admin/update-core.php

    I get this error message:
    You are not allowed to call this page directly.

    I am logged in , and I can access all of my blog and admin panel..... but not that page.

    any help ?

  2. olorinpc
    Member
    Posted 4 years ago #

    Having this same issue myself... haven't found a solution anywhere.

  3. olorinpc
    Member
    Posted 4 years ago #

    NextGEN ImageFlow - That is the plugin that kills the update-core page for me.

    So to update, I disabled that plugin, updated, and re-enabled it.

  4. Marc73
    Member
    Posted 4 years ago #

    Bravo !

    Thank you very much.

    It is indeed....

    simply deactivating that plugin was enough for me to be able to access wp-admin/update-core.php

    But ...... wait. let me ask you ..... how did you find out that ?

    Which error log did you check to find out which plug-in was to blame ?

    or did you do that by trial and error ? deactivating a plug-in and seeing if now you can access wp-admin/update-core.php ??

  5. Marc73
    Member
    Posted 4 years ago #

    did you inform the authors of next-gen image flow ?

  6. webbhotell
    Member
    Posted 4 years ago #

    Thank you I had that issue with updating
    WordPress 3.0-RC3-15260.
    to
    WordPress 3.0

    after disabling NextGEN ImageFlow

    it works :-)

  7. mustanger
    Member
    Posted 4 years ago #

    Awesome, thanks! This solved my problem! Someone should certainly inform the author of that plugin. I'll head that way now!

  8. mathew123
    Member
    Posted 4 years ago #

    thanks olorinpc. works

  9. wp0
    Member
    Posted 4 years ago #

    I disabled all plugin, but it's still same. Any other idea for this?

    Thanks.

  10. rlinden
    Member
    Posted 3 years ago #

    kuddos' to "olorinpc". I can Now upgrade my WP installation. Thankx

  11. KentUser
    Member
    Posted 3 years ago #

    NextGEN ImageFlow - yes, that is the problem. Thanks.

  12. gennathcacston
    Member
    Posted 3 years ago #

    Same here - Disabling NegGen ImageFlow fixed the issue!

  13. sazz3000
    Member
    Posted 3 years ago #

    NextGEN ImageFlow - yes, that is the problem. Thanks.

  14. lukeratto
    Member
    Posted 3 years ago #

    had the same issue, tried disabling NextGEN, still didn't do it, AFTER also deactivating Calendar Press, worked fine!

  15. lukeratto
    Member
    Posted 3 years ago #

    oh, but now the calendar data is gone. Oh well.

  16. JustCarmen
    Member
    Posted 3 years ago #

    it's quite simple to get rid of that bug.

    I just did a search on the text 'you are not allowed etc.' in Dreamweaver and found a bunch of files in the imageflow plugin that uses that text.

    But the one that is important is the one in plugins/nextgen-imageflow/lib/core.php

    Just uncomment the first line of that file by adding // after the <?php.

    So the line will look like this:
    <?php //if(preg_match('#' . basename(__FILE__) . '#', $_SERVER['PHP_SELF'])) { die('You are not allowed to call this page directly.'); }

    After that you can reach the update-core file again.

    I never used this plugin before and normally I won't use any plugins that are so buggy (because this is not the only bug I found) but I haven't found any other plugin that does the same imageflow so I give it a shot anyway.

  17. davenportagents
    Member
    Posted 3 years ago #

    NextGEN ImageFlow - disabled the plugin and now can update no problem. Thank you!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.