WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin/install.php problems (15 posts)

  1. crystalcopywriting
    Member
    Posted 5 years ago #

    I have uploaded files to my url and the next step is to Run the WordPress installation script by accessing wp-admin/install.php in your favorite web browser. When I open this in my browser, it's a page of code. Do you know what I need to do to make it work?

  2. tomontoast
    Member
    Posted 5 years ago #

    Where have you uploaded these files to? Is it a web server which supports PHP?

  3. crystalcopywriting
    Member
    Posted 5 years ago #

    yes, web-mania. abolutely supports PHP. Any ideas?

  4. Samuel B
    moderator
    Posted 5 years ago #

    yes - have your host enable PHP

  5. itsdesignrelated
    Member
    Posted 5 years ago #

    so i've had the same problem. i've uploaded my file through Fetch on to the wordpress folder in my root directory. i've changed the config file....so when i copy and paste "wp-admin/install.php" in my web browser it doesnt work? Help please!

    If I am supposed to enable PHP, how do i do that?

  6. Samuel B
    moderator
    Posted 5 years ago #

    @ itsdesignrelated
    you are using the entire url - correct?
    http://domain.com/wp-admin/install.php

  7. itsdesignrelated
    Member
    Posted 5 years ago #

  8. Samuel B
    moderator
    Posted 5 years ago #

    yea - all aspects time out
    I think you may have a server problem - have you talked to host?

  9. itsdesignrelated
    Member
    Posted 5 years ago #

    I see...

    Well yesterday I hald talked to several people because apparently because I intially started my site with Google/Blogger the website was not going to the correct IP address. I worked with Google to fix that. My next step was to continue the installation with WordPress, however when I followed directions its not working. So because of the error description that shows up when i plug in http://itsdesignrelated.com/wordpress/wp-admin/install.php, its is a server problem. It isnt because my wordpress files (config file for example) is wrong?

    Thats what im getting here. I'll give my host a call.

  10. freestyl
    Member
    Posted 5 years ago #

    Please help - completely deadended
    2 possibly connected problems:
    1. At this point I have a wordpress folder in my web root but when I connect to wordpress/wp-admin/install.php I get a dialog asking to download or open with Notepad. At some point in the fatigue fogged past I did see a page partially addressing this issue, but hey, that was 300 pages ago.

    2. Accessing other wordpress php files produces an error message page: 'Invalid or missing PDO driver'

    I am installing a personal blog on localhost & as such don't need a huge database.
    I am trying to install WP using the PDO-sqlite plugin as per http://wordpress.org/extend/plugins/pdo-for-wordpress/installation/ which I think I have right.
    I am using Vista, Apache 2.2, PHP 5.2
    Apache is configured for PHP as a module
    php_info() shows:
    PDO
    PDO support enabled
    PDO drivers sqlite2

    WordPress V 2.5.1 as specified for this plugin
    PHP.ini shows:
    extension_dir ="C:\Web\PHP\ext"
    [PHP_PDO]
    extension=php_pdo.dll
    [PHP_SQLITE]
    extension=php_sqlite.dll

    The PHP\ext folder shows:
    php_pdo.dll
    php_sqlite.dll

    phpinfo() works and shows:
    PDO
    PDO support enabled
    PDO drivers sqlite2

    wp-config.php shows:

    // ** MySQL settings ** //
        define('DB_NAME', 'wordpress');    // The name of the database
        define('DB_USER', 'root');     // Your MySQL username
        define('DB_PASSWORD', ''); // ...and password
        define('DB_HOST', 'localhost');    // 99% chance you won't need to change this value
        define('DB_CHARSET', 'utf8');
        define('DB_COLLATE', '');
        define('DB_TYPE', 'sqlite');    //mysql or sqlite
        define('SECRET_KEY', 'Dear Diary, what a day it's been'); // Change this to a unique phrase.
    
        // You can have multiple installations in one database if you give each a unique prefix
        $table_prefix  = 'wp_';   // Only numbers, letters, and underscores please!
        define ('WPLANG', '');
        define('ABSPATH', dirname(__FILE__).'/');
        require_once(ABSPATH.'wp-settings.php');
        ?>
    I apologise the the length but felt I neeed to provide as much relevent info as possible.

  11. doubleruger
    Member
    Posted 5 years ago #

    Hey!
    it's ok - but you just forgot to set file name! ;-)
    And re-arrange code-lines like I did it:
    ---start----
    define('DB_TYPE', 'sqlite'); //exactly
    define('DB_NAME', 'sqlite:db.fil'); //!!! put it or another one
    define('DB_HOST', 'localhost'); //
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');
    ---end------

    And that's all - it works at my home server.
    I guess it will help you!

  12. itsdesignrelated
    Member
    Posted 5 years ago #

    Thanks so much! That has helped greatly!!!

  13. fouyapot
    Member
    Posted 5 years ago #

    Hey guys I’m New to wordpress I’m trying to install it on my 1and1 hosting but when it comes to run mysitename.com/wp-admin/install.php
    it’s says Error establishing a database connection
    But I am certain to modify wp-config.php good. So someone can help me?
    Best regards!

  14. mibsolutionsllc
    Member
    Posted 5 years ago #

    make sure you that you need to specify you host location. Instead of localhost, some servers make you put in a long url

  15. Gen3ric.
    Member
    Posted 5 years ago #

    I'm having a same problem as a fouyapot. But im fromt lithuania so im using tinklalapis.net hosting, and when i type myadress.lt/wp-admin/install.php it says (ofcourse my real URL instead "myadress":

    The page cannot be displayed
    The page you are looking for is currently unavailable. The Web site might be experiencing technical difficulties, or you may need to adjust your browser settings.
    To attempt fixing network connectivity problems, click Tools, and then click "Diagnose Connection Problems..."

    What to do?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.