WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin/install.php can't open the page (3 posts)

  1. joadard
    Member
    Posted 3 years ago #

    Hello,

    I've searched through the various threads on the installation forum and am not sure that anyone has found this same issue. I see lots of 'blank page' install.php errors, but haven't seen one where someone has seen the 'can't open the page' error on Safari, or where the file tries to open when you hit that page in Firefox.

    I was able to launch the install process and receive the wp-config.php info - although it told me that it couldn't write the file and that I'd need to manually install it. I went ahead and did so, but then hit a roadblock when the wp-admin/install.php file was hit. The file, by the way, is in the wp-admin directory (I have confirmed that it was there) but I receive a 'failed to open page/can't open the page' error when I try to open the page in Safari.

    Incidentally, the hosting company is running the Plesk platform and I have installed the WordPress files in the httpdocs directory. Clearly, if its starting the process, the directory info etc... should be okay - but I'm not sure why its stopping when it hits the install.php file.

    Any thoughts?

    Thanks so much in advance!!!

  2. bh_WP_fan
    Member
    Posted 3 years ago #

    Make sure that php is running on your server.
    Also make sure your files have sufficient permissions. Generally directories are 755 and files are 644, however, depending on your host, you may need 777 in some instances.

    Create a file named info.php and put the following code into it:
    <?php phpinfo();

    Then access that file in a web browser and make sure things are running.

  3. juju1111
    Member
    Posted 3 years ago #

    joadard did you happen to solve your problem? Because I have exactly the same. Also under Plesk, though that's probably not the cause.

    I'll keep you informed if I find something as well.

    EDIT: Setting ALL files permission to 777 didn't work for me. Anyway having the files world writable wasn't really viable was it.

    I contacted my host Kreativmedia.ch to see if he knows something about this issue. "safe-php" is turned on for me. Heard turning it off solved the problem for some users, but I read somewhere on WordPress.org that "safe-php on" wasn't an issue to run wp.

    Let's see.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.