WordPress.org

Ready to get started?Download WordPress

Forums

WP-Admin Theme Template File Display (6 posts)

  1. Chip Bennett
    Theme Review Admin
    Posted 7 years ago #

    Upon upgrade to WP 2.1, the Theme Editor in WP-Admin seems to display my theme template files differently.

    For example, a template file named "ext_blogrolls.php" with the commented description "Template Name: External Blogrolls" in the file:

    Formerly displayed: "External Blogrolls" in the theme file list
    Now displays: "External" in the theme file list.

    (In fact, all files with multiple words in the "Template Name" declaration only display the first word.)

    Also, the files are all in a different order than they were previously (not a huge problem, but my eye was trained to find a certain file vertically in the list of file names).

    Finally, some files no longer display in the list at all. For instance, a second page template file, called "pikeblog.php" with "Template Name: PikeBlog" does not display in the list.

    Is this list something that is user-configurable?

    Any ideas on what changed?

  2. Chip Bennett
    Theme Review Admin
    Posted 7 years ago #

    {bump}

    Anyone?

  3. LaPoetessa
    Member
    Posted 7 years ago #

    Could it be anything to do with 'Permissions'? I've just been trying to solve a different problem to yours, but it was all very easy to put right. I hope you find a solution to the prob soon.

  4. Chip Bennett
    Theme Review Admin
    Posted 7 years ago #

    Any thoughts on the WP-Admin "Presentation / Theme Editor" file list in WP 2.1 versus 2.0.7?

  5. brooke35
    Member
    Posted 7 years ago #

    I'm having the same problem. Template files I'd created that worked in 2.0.7 aren't showing up on the list at all in 2.1.

    Did you figure anything out yet?

  6. madman75
    Member
    Posted 7 years ago #

    I had the same problem. It's an issue with line 1605 of the admin-functions.php file. The details are shown here:

    http://trac.wordpress.org/ticket/3674

    I removed the extra space from my file as described in the article and my theme files now display correctly once again.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags