WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin suddenly redirects to 127.0.0.1 (30 posts)

  1. krneki10
    Member
    Posted 1 year ago #

    Few days ago I tried to reach my admin panel but suddenly it redirected me right away to 127.0.0.1 (even login window won't show up). It has been working fine for months, I haven't changed anything but now suddenly this weird problem occurred. Why? How may I fix it?

    Thank you

  2. marians
    Member
    Posted 1 year ago #

    Is your server behind a reverse proxy?

    I have no solution, but seem to have a related issue. I am trying to run WordPress on Apache, which is configured to listen to 127.0.0.1:8002. In front of this, I have nginx listening to http://www.mydomain.com:80 and passing requests to Apache.

    Have you tried setting WP_HOME and WP_SITEURL as constants in wp-config.php? (See http://codex.wordpress.org/Changing_The_Site_URL for more info.)

    In my case, I have both settings in wp-config.php and still get some links in the admin panel pointing to 127.0.0.1:8002. Example: In the posts list, when I click on one of the table headers to change the sort order.

  3. krneki10
    Member
    Posted 1 year ago #

    So I put these 2 lines into wp-config.php

    define('WP_HOME','http://mysiteurl.com');
    define('WP_SITEURL','http://mysiteurl.com');

    And it didn't change anything. I still can't access admin panel, it simply redirects to http://127.0.0.1. I don't have my own hosting server, my website is hosted on one of hosting providers.

    What should I do?

  4. bemdesign
    Member
    Posted 1 year ago #

    The host may be blocking brute force attacks and making the wp-admin inaccessible (thus preventing attackers from breaking in as they can't even reach it) and redirecting people back to localhost. Try contacting your host.

    Another possibility is that you're using a WordPress security plugin that after so many failed attempts to login redirects the attacker (based on IP address) to "localhost". If this is so, disable the plugin via FTP/SFTP by renaming its folder and see if that let's you get in.

  5. krneki10
    Member
    Posted 1 year ago #

    I have contacted my host and they said that everything should be fine.

    I've also tried to rename "plugins" folder but it didn't make any difference.

  6. krneki10
    Member
    Posted 1 year ago #

    Got it, it was WP All In One Security who modified .htaccess in a way that completely broken wp-admin. It works fine now.

    Thanks for help guys.

  7. ideep13
    Member
    Posted 11 months ago #

    Hi, I am having the same problem with WP All in One Security.

    But now I have deleted the plugin folder via filezilla, but still don't have an access to my panel.

    Any suggestions what to do next?

    @Krneki10 - mi poveš kontakt od wp all in one security memberjev oz. kodo ?

  8. esmi
    Forum Moderator
    Posted 11 months ago #

  9. andersonenvy
    Member
    Posted 8 months ago #

    This is currently happening on *all* 1&1 websites FYI - in case anyone is Googling this error...

  10. kilrain
    Member
    Posted 8 months ago #

    @andersonenvy is right. I am having all sorts of difficulties with 1and1

  11. tigermendoza
    Member
    Posted 8 months ago #

    Yep happening to mine and I'm on 1and1. So is it the DDOS thing rather than a plugin? Don't think that any of my plugins are changing htaccess.

  12. Ann Stokes
    Member
    Posted 8 months ago #

    I am having the same problem. I am hosted on 1and1. Is there any official info from 1and1 on this?

  13. kilrain
    Member
    Posted 8 months ago #

  14. Ann Stokes
    Member
    Posted 8 months ago #

    Found some info: http://status-1and1.com/#Incident

    Start:12/30/2013 2:41 PM
    Estimated end:Unknown
    Last update:12/30/2013 2:41 PM
    Type:Incident
    Affected services:Websites
    Description:
    We're experiencing an issue affecting less than 0.5% of the 1&1 customer base.
    The affected users are unable to access their WordPress Admin-Login.

  15. gmackay1903
    Member
    Posted 8 months ago #

    Yeah. having the same issue too - spent ages trying to get to the bottom of it.

    I'm using the workaround for the time being which works, but a bit of a pain.

  16. Pioneer Valley Web Design
    Member
    Posted 8 months ago #

    I would consult 1&1 before using any work around - they may have a logical reason to be blocking admin logins on a server....

  17. gerasimnj
    Member
    Posted 8 months ago #

    I am on 1and1 and using previous links I was able to login:
    Thanks to all bright minds!
    Used FTP client and connect to my folder on 1and1.

    Renamed my wp-login.php to say logmein.php.

    Once the login screen appears, using "Firebug" found the <form> tag and modified the action="wp-login.php" to action="logmein.php".

    Renamed logmein.php back to wp-login.php

    Installed "Rename wp-login" plugin to prevent this from ever happening again.

  18. Installed "Rename wp-login" plugin to prevent this from ever happening again.

    I'm really glad you got back into your WordPress dashboard but that's just a work around. If it's the host that's doing this to mitigate an attack or brute force logins then they need to be suffer the Internet "Wagging The Disapproving Finger of SHAME™" at them.

    Host problems like this should be fixed on a host level. Again I'm glad you can login but this isn't really a good fix.

  19. mankle30@gmail.com
    Member
    Posted 8 months ago #

    can someone tell me what "Firebug" is? and how to use it find the <form> tag?

    These instructions would be more helpful if I could understand what they actually mean

  20. WPyogi
    Volunteer Moderator
    Posted 8 months ago #

  21. mankle30@gmail.com
    Member
    Posted 8 months ago #

    Thanks WPyogi.

    Unfortunately, I couldn't even get to that stage. I changed the name of wp-login.php to logmein.php and couldn't get to a log-in screen.

    gerasimnj - What extension after the domain did you use? http://www.mywebsite.com/ .. . . . ?

    Thanks again.

  22. dquigley
    Member
    Posted 8 months ago #

    @Mankie30@gmail.com -- Like WPyogi mentioned they are referring to a browser plugin/extension called Firebug that you can use in Firefox to see and modify the source of a webpage that you currently have open. There are similar tools for Internet Explorer and Google Chrome already built in.

    To complete what they are describing you FTP into your wordpress website, make a copy of the wp-login.php to something else like wp-login2.php, and then go to yourwebsitename.com/wp-login2.php

    On that page use Firebug (if you're using Firefox) to inspect the page and find the <form> tag and edit the destination.

    If all of this is still too complex though, I'd advise just waiting for 1&1 to come up with a solution, as you could accidentally break your website more if you aren't careful.

  23. gerasimnj
    Member
    Posted 8 months ago #

  24. mankle30@gmail.com
    Member
    Posted 8 months ago #

    Thanks a lot dquigley. I appreciate the step by step explanation.

  25. JonRWilson
    Member
    Posted 8 months ago #

    I too am having this problem with 1&1. Hopefully they'll fix it up by the time the 2014 festivities have settled down and it's time to make another post...Or perhaps 2014 will be the year to move to a big boy host. TBD

  26. mankle30@gmail.com
    Member
    Posted 8 months ago #

    Thanks to dquigley, I've been able to access my site through the workaround.

    I also hope that 1and1 gets their act together. I spoke to them on the phone earlier (about 5-6 hours ago) and the person I spoke to couldn't tell me anything about when they'd expect to get it fixed.

  27. mankle30@gmail.com
    Member
    Posted 8 months ago #

    I also want to thank gerasimnj for the help (and dquigley for filling in some of the gaps).

    This has solved the problem and I've been able to fully implement the work-around (including using the rename wp-login plugin).

  28. palsokar.mandar
    Member
    Posted 3 months ago #

    not loggedin any option for setting new admin credentials

  29. @palsokar.mandar As this topic is months old you may have more luck starting your own topic with your own details.

    https://wordpress.org/support/forum/how-to-and-troubleshooting#postform

    That's also something recommended in the forum welcome.

  30. Zmathew
    Member
    Posted 4 weeks ago #

    Hi,

    I was working on my website wp-admin. (www.xpresswebmarketing.com/wp-admin)

    In mean while i saw that my website is not working properly and my http://www.xpresswebmarketing.com/wp-admin/ automatically redirects to wordpress.com

    I tried to contact my hosting company and they said the problem is from your side. Please Help me ASAP.

    Regards,
    Zack Mathew

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.