WordPress.org

Ready to get started?Download WordPress

Forums

wp-admin suddenly not working (37 posts)

  1. Stigmartyr
    Member
    Posted 3 years ago #

    Hi folks! So I've done lots of searching on the subject of wp-admin not working specifically with that redirect_to=http://website.com%2Fwp-admin%2F&reauth=1 trouble lots of people were getting in various ways.

    In our case http://www.BradsCustomAuto.com is using a very simple site that was running fine the last time it was checked (no new development in months) and suddenly going to /wp-admin/ will introduce this reauth nonsense, where the site tells me I'm looking for a page that doesn't exist. However, going directly to wp-login.php gets me to the login page where I can submit my creds only to be redirected right to the URL I posted above.

    I find that the path before me is paved with alot of different techniques, all of which I believe I have tried, thus bringing me to logging my issue on it's own.

    I've tried disabling all plugins, not that there were very many to disable anyways, some gallery stuff and a custom theme. No dice.

    I tried modifying the .htaccess files, wp-config.php statements to define the siteurl and homeurl, I tried making sure site/home urls in the db were accurate using phpMyAdmin. No Go..

    I tried CHMOD all files in /wp-admin and /wp-includes to 755.

    Now I just tried to overwrite my installation with the latest WP 3.1.3 so we're at the latest files and database. The upgrade seems to have completed fine, yet I still cannot get to the Dashboard.

    The most perplexing thing is that I am the only admin/developer and know that nothing has changed since the last time. I've even tried this in 4 different browsers, dumping local cache.

    Is there some other approach I can take to this then? None of the above has worked and I can't login to my Dashboard :( I haz a sad. Going to shoot some zombies, eat a gallon of ice cream and come back to see if someone can pick my efforts up off the floor :P

  2. Stigmartyr
    Member
    Posted 3 years ago #

    Bumpity bump bump bumpity bump bump...

    Please tell me how you would go about this issue? Would backing up the photos and database then reinstalling be a good idea?

  3. Stigmartyr
    Member
    Posted 3 years ago #

  4. keesiemeijer
    moderator
    Posted 3 years ago #

    have a read of this codex guide: http://codex.wordpress.org/Login_Trouble

    have a look in your error logs at your hosts backend.

    try:
    1. logout or logout with http://www.yourdomain.com/wp-login.php?action=logout
    2. disable all plugins
    3. clear cookies/cache
    4. exit browser

    just for troubleshooting purposes try:
    - switching to the default theme by renaming your current theme's folder in wp-content/themes using FTP or whatever file management application your host provides.

    - resetting the plugins folder by using FTP or whatever file management application your host provides. Sometimes, an apparently inactive plugin can still cause problems.

    - renaming or deleting the .htaccess file after making a backup of this file

  5. Stigmartyr
    Member
    Posted 3 years ago #

    Thank you for the reply, and yes I did visit that page, and I am at the point now where it says:

    IF ALL ELSE FAILS.

    So here's my post. I'm willing to let a developer have a crack at it. Otherwise I'm out of ideas.

    What is making it redirect to some 'reauth=1" address when I go to /wp-admin? That is the question.

  6. keesiemeijer
    moderator
    Posted 3 years ago #

    Check your .htaccess and wp-config.php if they are correct. check their permissions as well. wp-config.php should be 600 to prevent other users on the server from reading it. 644 is normally required and recommended for .htaccess files. But these (default) permission settings do not always work in different server configurations.

    Try renewing security keys in wp-config.php, clearing your browsers cookies/cache again and checking permissions on wp-config.php again.

  7. Stigmartyr
    Member
    Posted 3 years ago #

    Thank you Kees - I set file permissions as suggested and tried resetting security keys using the generator. I then deleted all cookies/cache and restarting my system even. Still redirecting me to the ..reauth=1 nonsense when I go to /wp-admin

    I'm not sure if my .htaccess file is correct but all that is in it is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

  8. keesiemeijer
    moderator
    Posted 3 years ago #

    try with

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
  9. Kelly 62
    Member
    Posted 3 years ago #

    I was just on my blog last week; a very simple one using an existing theme.

    I went in to post today, and it's completely gone. Can't get anywhere near it. This is what I find, whether I am trying to access it internally through admin, or outside. According to google analytics, two people were reading it yesterday.

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    I have done nothing to it except post about 10 days ago.

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    @Kelly 62: It is considered impolite to interrupt another poster's thread. Please post a new topic.

  11. kmessinger
    Volunteer Moderator
    Posted 3 years ago #

    Edited out the same message. In your new post please post url and error messages you are getting if any also

  12. Kelly 62
    Member
    Posted 3 years ago #

    YIKES who knew the etiquette of posting? Thought you were supposed to find something/someone having a similar issue. Deepest apologies for interrupting and thanks for the heads up!

  13. Stigmartyr
    Member
    Posted 3 years ago #

    lol yeah don't sweat it Kelly. Usually in etiquette it's ok to post your issue in the same thread if you're experiencing the 'exact' same issue or if the issue was resolved and following their steps you can't find resolution.

    I started this thread because I saw alot of other threads with some similar symptoms but they were related to some multi-site plugin.

    I've tried everything in the Codex and unless my .htaccess file is wrong then nothing has worked so far. I did a couple manual 'upgrades' to 3.1.3 overwriting my wp-admin and wp-includes folders, updating the db, changing the hashes in wp-config.php, checking site_url statements so that every instance of the web url is all the same.. I've deployed and managed dozens of WP sites and never came across this.

    At first I thought it was a simple caching thing but it's not. I have a feeling it's simple enough because the rest of the site works, but getting to the dash board is just not happening.

    The only other thing I can try at this point is backing up my theme folder, the db and just burning the site to the ground and starting over.

    @ Kees - thank you so much for keeping me moving forward on this. I tried editing the .htaccess as you recommended but no avail..

    Is part of the problem that it's reformatting the URL with hex? http%3A%2F%2Fbradscustomauto.com%2Fwp-admin%2F&reauth=1

  14. francesca79
    Member
    Posted 3 years ago #

    Hello everyone!
    I'm having this problem too. Login page redirects me to the login page again, without any errors.
    I'm asking my webhost, maybe it has something to do with them.

  15. francesca79
    Member
    Posted 3 years ago #

    Hello everyone!
    I'm having this problem too. Login page redirects me to the login page again, without any errors.
    I'm asking my webhost, maybe it has something to do with them.

  16. Stigmartyr
    Member
    Posted 2 years ago #

    We're all having this issue :( but it's not an area that WP seems to know much about.

  17. tasty.donuts
    Member
    Posted 2 years ago #

    @stigmartyr

    We're all having this issue :( but it's not an area that WP seems to know much about.

    Is this a "login" page that you got bounced out of the Admin onto? Are you able to get into the site if you close out your browser or open another tab?

    Are you getting any errors in Chrome / Firebug?

    Are you sure that all of your JQuery libraries, etc. are not being loaded in the Admin section (i.e use some kind of !is_admin statement)?

  18. Stigmartyr
    Member
    Posted 2 years ago #

    Basically it was working fine one day and the next /wp-admin and wp-login.php and redirecting me to a 404 page.

    I've tried over writing the files with the latest ones and all the suggestions you see above in my previous posts. I know I can just reinstall but that doesn't help me solve the issue therefore I've left it like this to better understand what is going on -- hopefully resolve it.

  19. Stigmartyr
    Member
    Posted 2 years ago #

    Yup.. so working on this again. I just manually updated to WP 3.2.1 and this site is still having the issue. When I go to /wp-admin/ I am directed to the login screen. However after I enter my creds, I am redirected to a 404 page who's URL looks like:

    http://mysite.com/wp-login.php?redirect_to=http%3A%2F%2Fmysite.com%2Fwp-admin%2F&reauth=1

    I've tried several different combinations of .htaccess files and wp-config.php as I found in searching google/wordpress.org

    I've tried making sure that the URL is written correctly in the wp_options table in the db, I've tried praying to a higher power. I've tried smoking lots of pot to forget about it, I've tried communicating with the dead, and even tried singing to my computer..

    My .htaccess

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
  20. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    http://bradscustomauto.com/wp-login.php - this is working so you can get to the site.

  21. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

  22. Stigmartyr
    Member
    Posted 2 years ago #

    http://bradscustomauto.com/wp-login.php - this is working so you can get to the site.

    Yeah I'm pretty sure that isn't correct behavior as explained in the posts above. I cannot get to the dashboard.

  23. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Yes, I see. I registered and was sent a password but 404'd.

  24. tasty.donuts
    Member
    Posted 2 years ago #

    are you getitng a literal "404"? Can you enable PHP debugging on your host for the time being so you can see if you have a conflict in one of the plugin files or themes of your site?

    Also, have you tried using the login -- entering your credentials -- and then navigating DIRECTLY to http://bradscustomauto.com/wp-admin/ within the same browser session?

  25. Stigmartyr
    Member
    Posted 2 years ago #

    Thanks for your help fellers - yes indeed it does do this even with the entire plugin folder disabled (renamed to plugins.off)

    Today I updated to WP 3.2.1 and updated the custom theme to the latest and greatest version...

    Reinstalling the entire site may resolve it but we'll all be back at the drawing board if this ever happens again so I'm holding out for a fix.

    @ tasty.donuts - yes after it 404's I've tried that, even tried manually typing out URLs like /wp-admin/users.php just to get to a page anywhere on the dashboard, tried some .htacess tricks in the wp-admin folder and other statements to 'allow all'. I've tried CHMOD (just cause) some other different tricks recommended in any slightly relevant article, just trying to force my way in.

    I did try to move my theme folder away (deleted it) and the site came up blank (this was after the 3.2.1 upgrade) not sure why it didn't go to 2011 theme. It actually gives me a 500 error after I login (when I move away the present theme). I might have to set something in the db telling it to look to the default? But I thought WP would default to Twenty Eleven.

  26. tasty.donuts
    Member
    Posted 2 years ago #

    Have you checked the site's URL in the database?

    Also, have you tried navigating directly to your admin dashboard with the www. in front of your site's name and without?

  27. Stigmartyr
    Member
    Posted 2 years ago #

    Unsolved Mysteries - *UPDATE*

    "We still have no f***ing clue what's wrong" :P

    BUT! Just scrolling through the thread looking at kmessinger post (yes about Brads site) I clicked the reauth=1 link again and it directed me to the wp-login.php page again where I entered my creds again but this time I went to the dashboard..

    So to make this perfectly clear, here are my steps:

    I typed in: http://bradscustomauto.com/wp-admin/ and was directed to a 404 page telling me these aren't the droids I'm looking for.

    I then cut and pasted the below link into the same browser window/session and it goes to the wp-login.php page (again) prompting me to login (again) and then it sends me to the dashboard.

    http://bradscustomauto.com/wp-login.php?redirect_to=http%3A%2F%2Fmysite.com%2Fwp-admin%2F&reauth=1

    I'm confused as to why it's behaving this way.

  28. Stigmartyr
    Member
    Posted 2 years ago #

    @Tasty - yes I did try to add www. and that didn't work. Site's URL in the DB matches what it should be. I am not using the dubdubdub.

    I also set that in wp-config.php but it made no different so I removed it.

    Im using /%category%/%postname%/ permalink structure..

    Getting into the dashboard now is nice, but it's the way I have to get in there that's confusing.

  29. tasty.donuts
    Member
    Posted 2 years ago #

    Have you tried turning PHP error reporting on?

  30. Stigmartyr
    Member
    Posted 2 years ago #

    Hi tasty - does that mean to set WP_DEBUG to 'true' ?

    If I need to edit the php.ini file I'll need to contact the host. Although I recall there was a way to force it in wp-config.php assuming apache is set to allow over rides.

Topic Closed

This topic has been closed to new replies.

About this Topic