WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] wp-admin returns error 404 (4 posts)

  1. FLJeffM
    Member
    Posted 1 year ago #

    I have been running WP for several years without a problem. I was in the process of redirecting my site URL to WP (ver. 3.5) instead of to my current flash website and have totally hosed it. I can't access wp-admin, I get a 404 error. The blog is still viewable but the theme style appears gone and it's all out of whack http://www.jeffmasonphoto.com/blog/. My install of WP is in a /blog/ directory and I [think] I changed the Site URL in Settings>General. I copied index.php to the root directory on the server and changed the 'require' line to point to the /blog/ directory. I also copied the .htaccess to the root directory. Following online instructions I may have saved something in Pretty Permalinks but I really don't know for sure. I have since removed the index.php and .htaccess from the root in an effort to get my baseline blog back.

    I've read more WP support threads, forums, and blogs than I can count and I'm more confused than ever. Some instructions say to go into Apache or make changes to the database but I'm just not comfortable with that (I have access through my account at 1and1.com but will surely screw it up even more). The last thing I did was to download a new version of WP. I copied in a new wp-admin directory, and a wp-includes directory. I also replaced all files in the /blog/root but preserved wp-config.php.

    Nothing has worked and I'm pretty much at a loss for what to do. Can someone please direct me how to get get my blog back or where to find a resolution? Thank you for your consideration.

    Sincerely, Jeff

  2. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    This is about how to change the url to the proper setting.
    http://codex.wordpress.org/Changing_The_Site_URL

  3. FLJeffM
    Member
    Posted 1 year ago #

    kmessinger...
    Bless you!! Admin panel is back. I used the hardcode 'define' method so I can't update the General settings but that's what got me in trouble in the first place. It's probably a good thing. I do want to have my http://www.jeffmasonphoto.com URL redirect to my blog in the /blog/ sub-directory so I can use it as my main site but I'll figure that out next.

    Thanks for the article link.

  4. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Glad you had success. Please mark resolved.

Topic Closed

This topic has been closed to new replies.

About this Topic